IAR Embedded Workbench®

IDE Project Management and Building Guide

for Advanced RISC Machines Ltd’s
ARM Cores
Brief contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>9</td>
</tr>
<tr>
<td>Figures</td>
<td>11</td>
</tr>
<tr>
<td>Preface</td>
<td>15</td>
</tr>
<tr>
<td><strong>Part 1. Project management and building</strong></td>
<td>21</td>
</tr>
<tr>
<td>The development environment</td>
<td>23</td>
</tr>
<tr>
<td>Managing projects</td>
<td>29</td>
</tr>
<tr>
<td>Building</td>
<td>59</td>
</tr>
<tr>
<td>Editing</td>
<td>67</td>
</tr>
<tr>
<td><strong>Part 2. Reference information</strong></td>
<td>79</td>
</tr>
<tr>
<td>Installed files</td>
<td>81</td>
</tr>
<tr>
<td>IAR Embedded Workbench IDE reference</td>
<td>87</td>
</tr>
<tr>
<td>General options</td>
<td>155</td>
</tr>
<tr>
<td>Compiler options</td>
<td>163</td>
</tr>
<tr>
<td>Assembler options</td>
<td>179</td>
</tr>
<tr>
<td>Output converter options</td>
<td>187</td>
</tr>
<tr>
<td>Custom build options</td>
<td>189</td>
</tr>
<tr>
<td>Build actions options</td>
<td>191</td>
</tr>
<tr>
<td>Linker options</td>
<td>193</td>
</tr>
<tr>
<td>Library builder options</td>
<td>205</td>
</tr>
<tr>
<td>Glossary</td>
<td>207</td>
</tr>
<tr>
<td>Index</td>
<td>223</td>
</tr>
</tbody>
</table>
Contents

Tables ........................................................................................................................ 9
Figures .................................................................................................................... 11
Preface ..................................................................................................................... 15

Who should read this guide ............................................................... 15
How to use this guide ............................................................. 15
What this guide contains .......................................................... 16
Other documentation ................................................................. 17

User and reference guides .......................................................... 17
The online help system ............................................................. 18
Web sites ......................................................................................... 18

Document conventions ................................................................. 18

Typographic conventions .......................................................... 19
Naming conventions ........................................................................... 19

Part 1. Project management and building ............ 21

The development environment .................................................. 23

The IAR Embedded Workbench IDE—an overview ............ 23

The toolchain .................................................................................. 23
Continuous workflow ................................................................. 23
An extensible and modular environment ......................... 23
Window management ................................................................. 23
Running the IDE .......................................................................... 24
Exiting ............................................................................................. 25

Customizing the environment .................................................. 25

Organizing the windows on the screen .................................. 25
Customizing the IDE ................................................................. 26
Invoking external tools ............................................................. 27
Menus ................................................................. 100
General options .................................................... 155
  Description of general options ......................... 155
Compiler options .................................................. 163
  Description of compiler options ....................... 163
Assembler options ............................................... 179
  Description of assembler options .................... 179
Output converter options .................................... 187
  Description of output converter options .......... 187
Custom build options .......................................... 189
  Description of custom build options ............... 189
Build actions options ......................................... 191
  Description of build actions options ............. 191
Linker options ................................................... 193
  Description of linker options ....................... 193
Library builder options ...................................... 205
  Description of library builder options ........... 205
Glossary ........................................................... 207
Index ............................................................... 223
Tables

1: Typographic conventions used in this guide ......................................................... 19
2: Naming conventions used in this guide ................................................................. 19
3: iarbuild.exe command line options ..................................................................... 63
4: The ARM directory .............................................................................................. 81
5: The common directory .......................................................................................... 82
6: File types ............................................................................................................... 83
7: Editor keyboard commands for insertion point navigation ................................. 95
8: Editor keyboard commands for scrolling .............................................................. 95
9: Editor keyboard commands for selecting text ...................................................... 96
10: Argument variables ............................................................................................ 121
Figures

1: IAR Embedded Workbench IDE window ................................................................. 24
2: Configure Tools dialog box .................................................................................. 27
3: Customized Tools menu ....................................................................................... 28
4: Examples of workspaces and projects ................................................................ 32
5: Displaying a project in the Workspace window .................................................. 36
6: Workspace window—an overview ....................................................................... 37
7: Workspace window ............................................................................................... 41
8: Workspace window context menu ....................................................................... 43
9: Create New Project dialog box ........................................................................... 45
10: Configurations for project dialog box ................................................................. 46
11: New Configuration dialog box ........................................................................... 47
12: Source Browser window ..................................................................................... 48
13: Source Browser window context menu .............................................................. 50
14: Version Control System menu for SCC ............................................................ 51
15: Select Source Code Control Provider dialog box ............................................. 53
16: Check In Files dialog box ................................................................................... 53
17: Check Out Files dialog box ................................................................................ 55
18: Version Control System menu for Subversion .................................................. 56
19: General options .................................................................................................. 60
20: Editor window .................................................................................................... 68
21: Parenthesis matching in editor window ............................................................. 71
22: Editor window status bar ................................................................................... 71
23: Inserting a code template .................................................................................. 72
24: Specifying an external command line editor .................................................... 76
25: External editor DDE settings ............................................................................. 77
26: IAR Embedded Workbench IDE window ........................................................... 88
27: IDE toolbar ......................................................................................................... 89
28: IAR Embedded Workbench IDE window status bar ........................................ 90
29: Editor window .................................................................................................... 90
30: Editor window tab context menu ..................................................................... 91
31: Go to Function window ..................................................................................... 92
<table>
<thead>
<tr>
<th>Page</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>32</td>
<td>Editor window context menu</td>
</tr>
<tr>
<td>33</td>
<td>Build window (message window)</td>
</tr>
<tr>
<td>34</td>
<td>Build window context menu</td>
</tr>
<tr>
<td>35</td>
<td>Find in Files window (message window)</td>
</tr>
<tr>
<td>36</td>
<td>Find in Files window context menu</td>
</tr>
<tr>
<td>37</td>
<td>Tool Output window (message window)</td>
</tr>
<tr>
<td>38</td>
<td>Tool Output window context menu</td>
</tr>
<tr>
<td>39</td>
<td>Debug Log window (message window)</td>
</tr>
<tr>
<td>40</td>
<td>Debug Log window context menu</td>
</tr>
<tr>
<td>41</td>
<td>File menu</td>
</tr>
<tr>
<td>42</td>
<td>Edit menu</td>
</tr>
<tr>
<td>43</td>
<td>Find dialog box</td>
</tr>
<tr>
<td>44</td>
<td>Replace dialog box</td>
</tr>
<tr>
<td>45</td>
<td>Find in Files dialog box</td>
</tr>
<tr>
<td>46</td>
<td>Incremental Search dialog box</td>
</tr>
<tr>
<td>47</td>
<td>Template dialog box</td>
</tr>
<tr>
<td>48</td>
<td>View menu</td>
</tr>
<tr>
<td>49</td>
<td>Project menu</td>
</tr>
<tr>
<td>50</td>
<td>Erase Memory dialog box</td>
</tr>
<tr>
<td>51</td>
<td>Options dialog box</td>
</tr>
<tr>
<td>52</td>
<td>Batch Build dialog box</td>
</tr>
<tr>
<td>53</td>
<td>Edit Batch Build dialog box</td>
</tr>
<tr>
<td>54</td>
<td>Tools menu</td>
</tr>
<tr>
<td>55</td>
<td>Common Fonts options</td>
</tr>
<tr>
<td>56</td>
<td>Key Bindings options</td>
</tr>
<tr>
<td>57</td>
<td>Language options</td>
</tr>
<tr>
<td>58</td>
<td>Editor options</td>
</tr>
<tr>
<td>59</td>
<td>Configure Auto Indent dialog box</td>
</tr>
<tr>
<td>60</td>
<td>External Editor options</td>
</tr>
<tr>
<td>61</td>
<td>Editor Setup Files options</td>
</tr>
<tr>
<td>62</td>
<td>Editor Colors and Fonts options</td>
</tr>
<tr>
<td>63</td>
<td>Messages options</td>
</tr>
<tr>
<td>64</td>
<td>Message dialog box containing a Don’t show again option</td>
</tr>
<tr>
<td>65</td>
<td>Project options</td>
</tr>
</tbody>
</table>
66: Source Code Control options ................................................................. 139
67: Debugger options ............................................................................. 140
68: Stack options .................................................................................. 141
69: Register Filter options ..................................................................... 143
70: Terminal I/O options ........................................................................ 145
71: Configure Tools dialog box ............................................................... 146
72: Customized Tools menu ................................................................. 147
73: Filename Extensions dialog box ......................................................... 149
74: Filename Extension Overrides dialog box ........................................... 150
75: Edit Filename Extensions dialog box .................................................. 151
76: Configure Viewers dialog box ............................................................ 151
77: Edit Viewer Extensions dialog box ...................................................... 152
78: Window menu .................................................................................. 153
79: General target options ..................................................................... 155
80: Output options .................................................................................. 157
81: Library Configuration options .......................................................... 158
82: Library Options ............................................................................... 160
83: Multi-file Compilation ...................................................................... 163
84: Compiler language options ............................................................... 164
85: Compiler language options ............................................................... 167
86: Code options .................................................................................... 168
87: Optimizations options ...................................................................... 170
88: Compiler output options .................................................................... 171
89: Compiler list file options ................................................................. 172
90: Compiler preprocessor options .......................................................... 174
91: Compiler diagnostics options ............................................................ 176
92: Compiler extra options ..................................................................... 177
93: Assembler language options ............................................................ 179
94: Choosing macro quote characters ..................................................... 180
95: Assembler output options ................................................................. 181
96: Assembler list file options ................................................................. 181
97: Assembler preprocessor options ........................................................ 183
98: Assembler diagnostics options .......................................................... 184
99: Extra Options for the assembler ......................................................... 185
100: Converter output options ................................................................. 187
101: Custom tool configuration options .................................................. 189
102: Build actions configuration options ............................................... 191
103: Linker configuration options ............................................................ 193
104: Linker library options .................................................................... 194
105: Linker input options ...................................................................... 195
106: Linker optimization options ............................................................ 197
107: Linker output options .................................................................... 198
108: Linker list options ......................................................................... 199
109: Linker #define options ................................................................. 200
110: Linker diagnostics options .............................................................. 201
111: Linker checksum and fill options ................................................... 202
112: Linker extra options ..................................................................... 204
113: Library builder output options ....................................................... 206
Preface

Welcome to the IDE Project Management and Building Guide for ARM. The purpose of this guide is to help you fully use the features in IAR Embedded Workbench with its integrated Windows development tools for the ARM core. The IAR Embedded Workbench IDE is a very powerful Integrated Development Environment that allows you to develop and manage a complete embedded application project.

This guide describes the processes of editing, project managing, and building, and provides related reference information.

Who should read this guide

Read this guide if you want to get the most out of the features and tools available in the IDE. In addition, you should have working knowledge of:

- The C or C++ programming language
- Application development for embedded systems
- The architecture and instruction set of the ARM core (refer to the chip manufacturer's documentation)
- The operating system of your host computer.

For more information about the other development tools incorporated in the IDE, refer to their respective documentation, see Other documentation, page 17.

How to use this guide

If you are new to using this product, we suggest that you first read the guide Getting Started with IAR Embedded Workbench® for an overview of the tools and the features that the IDE offers. The tutorials which you can find in IAR Information Center can help you get started. They will help you get started using IAR Embedded Workbench.

The process of managing projects and building, as well as editing, is described in this guide, whereas information about how to use C-SPY for debugging is described in the C-SPY® Debugging Guide for ARM®.
What this guide contains

This is a brief outline and summary of the chapters in this guide.

**Part 1. Project management and building**

This section describes the process of editing and building your application:

- *The development environment* introduces you to the IAR Embedded Workbench development environment. The chapter also demonstrates the facilities available for customizing the environment to meet your requirements.

- *Managing projects* describes how you can create workspaces with multiple projects, build configurations, groups, source files, and options that help you handle different versions of your applications.

- *Building* discusses the process of building your application.

- *Editing* contains detailed descriptions of the IAR Embedded Workbench editor, how to use it, and the facilities related to its usage. The final section also contains information about how to integrate an external editor of your choice.

**Part 2. Reference information**

- *Installed files* describes the directory structure and the types of files it contains.

- *IAR Embedded Workbench IDE reference* contains detailed reference information about the development environment, such as details about the graphical user interface.

- *General options* specifies the target, output, library, and MISRA C options.

- *Compiler options* specifies compiler options for language, optimizations, code, output, list file, preprocessor, diagnostics, and MISRA C.

- *Assembler options* describes the assembler options for language, output, list, preprocessor, and diagnostics.

- *Output converter options* describes the options available for converting linker output files from the ELF format.

- *Custom build options* describes the options available for custom tool configuration.
Other documentation

User documentation is available as hypertext PDFs and as a context-sensitive online help system in HTML format. You can access the documentation from the Information Center or from the Help menu in the IAR Embedded Workbench IDE. The online help system is also available via the F1 key.

USER AND REFERENCE GUIDES

The complete set of IAR Systems development tools is described in a series of guides. For information about:

- System requirements and information about how to install and register the IAR Systems products, refer to the booklet Quick Reference (available in the product box) and the Installation and Licensing Guide.
- Getting started using IAR Embedded Workbench and the tools it provides, see the guide Getting Started with IAR Embedded Workbench®.
- Using the IAR C-SPY® Debugger, see the C-SPY® Debugging Guide for ARM®.
- Programming for the IAR C/C++ Compiler for ARM and linking using the IAR ILINK Linker, see the IAR C/C++ Development Guide for ARM.
- Programming for the IAR Assembler for ARM, see the ARM® IAR Assembler Reference Guide.
- Using the IAR DLIB Library, see the DLIB Library Reference information, available in the online help system.
- Porting application code and projects created with a previous version of the IAR Embedded Workbench for ARM, see the IAR Embedded Workbench® Migration Guide for ARM®.

Note: Additional documentation might be available depending on your product installation.
THE ONLINE HELP SYSTEM

The context-sensitive online help contains:

- Comprehensive information about debugging using the IAR C-SPY® Debugger
- Reference information about the menus, windows, and dialog boxes in the IDE
- Compiler reference information
- Keyword reference information for the DLIB library functions. To obtain reference information for a function, select the function name in the editor window and press F1.

WEB SITES

Recommended web sites:

- The Advanced RISC Machines Ltd web site, www.arm.com, contains information and news about the ARM cores.
- Finally, the Embedded C++ Technical Committee web site, www.caravan.net/ec2plus, contains information about the Embedded C++ standard.

Document conventions

When, in this text, we refer to the programming language C, the text also applies to C++, unless otherwise stated.

When referring to a directory in your product installation, for example arm\doc, the full path to the location is assumed, for example c:\Program Files\IAR Systems\Embedded Workbench 6.m\arm\doc.
**TYPOGRAPHIC CONVENTIONS**

This guide uses the following typographic conventions:

<table>
<thead>
<tr>
<th>Style</th>
<th>Used for</th>
</tr>
</thead>
<tbody>
<tr>
<td>computer</td>
<td>• Source code examples and file paths.</td>
</tr>
<tr>
<td></td>
<td>• Text on the command line.</td>
</tr>
<tr>
<td></td>
<td>• Binary, hexadecimal, and octal numbers.</td>
</tr>
<tr>
<td>parameter</td>
<td>A placeholder for an actual value used as a parameter, for example</td>
</tr>
<tr>
<td></td>
<td>filename.h where filename represents the name of the file.</td>
</tr>
<tr>
<td>[option]</td>
<td>An optional part of a command.</td>
</tr>
<tr>
<td>[a</td>
<td>b</td>
</tr>
<tr>
<td>(a</td>
<td>b</td>
</tr>
<tr>
<td>bold</td>
<td>Names of menus, menu commands, buttons, and dialog boxes that appear on</td>
</tr>
<tr>
<td></td>
<td>the screen.</td>
</tr>
<tr>
<td>italic</td>
<td>• A cross-reference within this guide or to another guide.</td>
</tr>
<tr>
<td></td>
<td>• Emphasis.</td>
</tr>
<tr>
<td>...</td>
<td>An ellipsis indicates that the previous item can be repeated an arbitrary</td>
</tr>
<tr>
<td></td>
<td>number of times.</td>
</tr>
<tr>
<td>🍁</td>
<td>Identifies instructions specific to the IAR Embedded Workbench® IDE</td>
</tr>
<tr>
<td></td>
<td>interface.</td>
</tr>
<tr>
<td>📱</td>
<td>Identifies instructions specific to the command line interface.</td>
</tr>
<tr>
<td>💡</td>
<td>Identifies helpful tips and programming hints.</td>
</tr>
<tr>
<td>⚠️</td>
<td>Identifies warnings.</td>
</tr>
</tbody>
</table>

Table 1: Typographic conventions used in this guide

**NAMING CONVENTIONS**

The following naming conventions are used for the products and tools from IAR Systems® referred to in this guide:

<table>
<thead>
<tr>
<th>Brand name</th>
<th>Generic term</th>
</tr>
</thead>
<tbody>
<tr>
<td>IAR Embedded Workbench® for ARM</td>
<td>IAR Embedded Workbench®</td>
</tr>
<tr>
<td>IAR Embedded Workbench® IDE for ARM</td>
<td>the IDE</td>
</tr>
<tr>
<td>IAR C-SPY® Debugger for ARM</td>
<td>C-SPY, the debugger</td>
</tr>
<tr>
<td>IAR C-SPY® Simulator</td>
<td>the simulator</td>
</tr>
<tr>
<td>IAR C/C++ Compiler™ for ARM</td>
<td>the compiler</td>
</tr>
</tbody>
</table>

Table 2: Naming conventions used in this guide
<table>
<thead>
<tr>
<th>Brand name</th>
<th>Generic term</th>
</tr>
</thead>
<tbody>
<tr>
<td>IAR Assembler™ for ARM</td>
<td>the assembler</td>
</tr>
<tr>
<td>IAR ILINK Linker™</td>
<td>ILINK, the linker</td>
</tr>
<tr>
<td>IAR DLIB Library™</td>
<td>the DLIB library</td>
</tr>
</tbody>
</table>

*Table 2: Naming conventions used in this guide (Continued)*
Part 1. Project management and building

This part of the IDE Project Management and Building Guide contains these chapters:

- The development environment
- Managing projects
- Building
- Editing.
The development environment

This chapter introduces you to the IAR Embedded Workbench® integrated development environment (IDE). The chapter also demonstrates how you can customize the environment to suit your requirements.

The IAR Embedded Workbench IDE—an overview

THE TOOLCHAIN

The IDE is the environment where all necessary tools—the toolchain—are integrated: a C/C++ compiler, an assembler, a linker, an editor, a project manager with Make utility, and the IAR C-SPY® Debugger. The tools used specifically for building your source code are referred to as the build tools.

The compiler, assembler, and linker can also be run from a command line environment, if you want to use them as external tools in an already established project environment.

CONTINUOUS WORKFLOW

You have the same user interface regardless of which microcontroller you have chosen to work with—coupled with general and target-specific support for each device.

AN EXTENSIBLE AND MODULAR ENVIRONMENT

Although the IDE provides all the features required for your project, you can also integrate with other tools. For example, you can add IAR visualSTATE to the toolchain, which means that you can add state machine diagrams directly to your project in the IDE. Using a version control system is useful for keeping track of different versions of your source code. The IDE can identify and access any third-party version control system that conforms to the SCC interface published by Microsoft. The IDE can also attach to files in a Subversion working copy. You can use the Custom Build mechanism to incorporate also other tools to the toolchain, see Extending the toolchain, page 64.

WINDOW MANAGEMENT

To give you full and convenient control of the placement of the windows, each window is dockable and you can optionally organize the windows in tab groups.
The IAR Embedded Workbench IDE—an overview

This illustration shows the IAR Embedded Workbench IDE window with various components.

**Figure 1: IAR Embedded Workbench IDE window**

The window might look different depending on what additional tools you are using.

**RUNNING THE IDE**

Click the Start button on the Windows taskbar and choose All Programs> IAR Systems> IAR Embedded Workbench for ARM> IAR Embedded Workbench.

The file iarIdePm.exe is located in the common\bin directory under your IAR Systems installation, in case you want to start the program from the command line or within Windows Explorer.
Double-clicking the workspace filename

The workspace file has the filename extension eww. If you double-click a workspace filename, the IDE starts. If you have several versions of IAR Embedded Workbench installed, the workspace file is opened by the most recently used version of your IAR Embedded Workbench that uses that file type.

EXITING

To exit the IDE, choose File>Exit. You will be asked whether you want to save any changes to editor windows, the projects, and the workspace before closing them.

Customizing the environment

The IDE is a highly customizable environment. This section demonstrates how you can work with and organize the windows on the screen, the possibilities for customizing the IDE, and how you can set up the environment to communicate with external tools.

ORGANIZING THE WINDOWS ON THE SCREEN

In the IDE, you can position the windows and arrange a layout according to your preferences. You can dock windows at specific places, and organize them in tab groups. You can also make a window floating, which means it is always on top of other windows. If you change the size or position of a floating window, other currently open windows are not affected.

Each time you open a previously saved workspace, the same windows are open, and they have the same sizes and positions.

For every project that is executed in the C-SPY environment, a separate layout is saved. In addition to the information saved for the workspace, information about all open debugger-specific windows is also saved.

Using docked versus floating windows

Each window that you open has a default location, which depends on other currently open windows. To give you full and convenient control of window placement, each window can either be docked or floating.

A docked window is locked to a specific area in the Embedded Workbench main window, which you can decide. To keep many windows open at the same time, you can organize the windows in tab groups. This means one area of the screen is used for several concurrently open windows. The system also makes it easy to rearrange the size of the windows. If you rearrange the size of one docked window, the sizes of any other docked windows are adjusted accordingly.
A floating window is always on top of other windows. Its location and size does not affect other currently open windows. You can move a floating window to any place on your screen, also outside of the IAR Embedded Workbench IDE main window.

**Note:** The editor window is always docked. When you open the editor window, its placement is decided automatically depending on other currently open windows. For more information about how to work with the editor window, see *Using the IAR Embedded Workbench editor*, page 67.

**Organizing windows**

To place a window as a separate window, drag it next to another open window.

To place a window in the same tab group as another open window, drag the window you want to locate and drop it in the middle of the other window.

To make a window floating, double-click on the window’s title bar.

The status bar, located at the bottom of the IAR Embedded Workbench IDE main window, contains useful help about how to arrange windows.

**CUSTOMIZING THE IDE**

To customize the IDE, choose **Tools>Options** to get access to a wide variety of commands for:

- Configuring the editor
- Configuring the editor colors and fonts
- Configuring the project build command
- Organizing the windows in C-SPY
- Using an external editor
- Changing common fonts
- Changing key bindings
- Configuring the amount of output to the Messages window.

In addition, you can increase the number of recognized filename extensions. By default, each tool in the build toolchain accepts a set of standard filename extensions. If you have source files with a different filename extension, you can modify the set of accepted filename extensions. Choose **Tools>Filename Extensions** to get access to the necessary commands.

For reference information about the commands for customizing the IDE, see *Tools menu*, page 124. You can also find further information related to customizing the editor in the section *Customizing the editor environment*, page 75. For further information about customizations related to C-SPY, see the *C-SPY® Debugging Guide for ARM®*. 
INVOKING EXTERNAL TOOLS

The Tools menu is a configurable menu to which you can add external tools for convenient access to these tools from within the IDE. For this reason, the menu might look different depending on which tools you have preconfigured to appear as menu commands.

To add an external tool to the menu, choose Tools>Configure Tools to open the Configure Tools dialog box.

For reference information about this dialog box, see Configure Tools dialog box, page 146.

Note: You cannot use the Configure Tools dialog box to extend the toolchain in the IDE, see The toolchain, page 23.
After you have entered the appropriate information and clicked **OK**, the menu command you have specified is displayed on the **Tools** menu.

![Customized Tools menu](image)

**Figure 3: Customized Tools menu**

**Note:** If you intend to add an external tool to the standard build toolchain, see *Extending the toolchain*, page 64.

### Adding command line commands

Command line commands and calls to batch files must be run from a command shell. You can add command line commands to the **Tools** menu and execute them from there.

1. **To add commands to the Tools menu,** you must specify an appropriate command shell. Type a command shell in the **Command** text box, for example `cmd.exe`.

2. **Specify the command line command or batch file name** in the **Argument** text box.

   The **Argument** text should be specified as:

   `/C name`

   where `name` is the name of the command or batch file you want to run.

   The `/C` option terminates the shell after execution, to allow the IDE to detect when the tool has finished.

**Example**

To add the command **Backup** to the **Tools** menu to make a copy of the entire project directory to a network drive, you would specify **Command** as `cmd.exe` (or `command.cmd` depending on your host environment), and **Argument** as:

```
/C copy c:\project\*.* F:
```

Alternatively, to use a variable for the argument to allow relocatable paths:

```
/C copy $PROJ_DIR\*.* F:
```
Managing projects

This chapter describes how projects are organized and how you can specify workspaces with multiple projects, build configurations, groups, source files, and options that help you handle different versions of your applications. The chapter also describes the steps involved in interacting with an external third-party version control system.

More specifically, this means:

- Introduction to managing projects
- Procedures for managing projects
- Reference information on managing projects.

Introduction to managing projects

This section introduces project management in the IDE.

These topics are covered:

- Briefly about managing projects
- How projects are organized
- Interacting with version control systems.

BRIEFLY ABOUT MANAGING PROJECTS

In a large-scale development project, with hundreds of files, you must be able to organize the files in a structure that is easily navigated and maintained by perhaps several engineers.

The IDE comes with functions that will help you to stay in control of all project modules, for example, C or C++ source code files, assembler files, include files, and other related modules. You create workspaces and let them contain one or several projects. Files can be grouped, and options can be set on all levels—project, group, or file. Changes are tracked so that a request for rebuild will retranslate all required modules, making sure that no executable files contain out-of-date modules.
This list shows some additional features:

- Project templates to create a project that can be built and executed for a smooth development startup
- Hierarchical project representation
- Source browser with an hierarchical symbol presentation
- Options can be set globally, on groups of source files, or on individual source files
- The Make command automatically detects changes and performs only the required operations
- Text-based project files
- Custom Build utility to expand the standard toolchain in an easy way
- Command line build with the project file as input.

**Navigating between project files**

There are two main different ways to navigate your project files: using the Workspace window or the Source Browser window. The Workspace window displays an hierarchical view of the source files, dependency files, and output files and how they are logically grouped. The Source Browser window, on the other hand, displays information about the build configuration that is currently active in the Workspace window. For that configuration, the Source Browser window displays a hierarchical view of all globally defined symbols, such as variables, functions, and type definitions. For classes, information about any base classes is also displayed.

**HOW PROJECTS ARE ORGANIZED**

The IDE has been designed to suit the way that software development projects are typically organized. For example, perhaps you need to develop related versions of an application for different versions of the target hardware, and you might also want to include debugging routines into the early versions, but not in the final application.

Versions of your applications for different target hardware will often have source files in common, and you might want to be able to maintain only one unique copy of these files, so that improvements are automatically carried through to each version of the application. Perhaps you also have source files that differ between different versions of the application, such as those dealing with hardware-dependent aspects of the application.

The IDE allows you to organize projects in an hierarchical tree structure showing the logical structure at a glance. In the following sections the various levels of the hierarchy are described.
Projects and workspaces

Typically you create one or several projects, where each project can contain either:

- Source code files, which you can use for producing your embedded application or a library. For an example where a library project has been combined with an application project, see the example about creating and using libraries in the tutorials.

- An externally built executable file that you want to load in C-SPY. For information about how to load executable files built outside of the IDE, see the *C-SPY® Debugging Guide for ARM®*.

If you have several related projects, you can access and work with them simultaneously. To achieve this, you can organize related projects in workspaces.

Each workspace you define can contain one or more projects, and each project must be part of at least one workspace.

Consider this example: two related applications—for instance A and B—are developed, requiring one development team each (team A and B). Because the two applications are related, they can share parts of the source code between them. The following project model can be applied:

- Three projects—one for each application, and one for the common source code
- Two workspaces—one for team A and one for team B.
Collecting the common sources in a library project (compiled but not linked object code) is both convenient and efficient, to avoid having to compile it unnecessarily.

**Projects and build configurations**

Often, you need to build several versions of your project. The Embedded Workbench lets you define multiple build configurations for each project. In a simple case, you might need just two, called **Debug** and **Release**, where the only differences are the options used for optimization, debug information, and output format. In the Release configuration, the preprocessor symbol `NDEBUG` is defined, which means the application will not contain any asserts.

Additional build configurations might be useful, for instance, if you intend to use the application on different target devices. The application is the same, but hardware-related parts of the code differ. Thus, depending on which target device you intend to build for, you can exclude some source files from the build configuration. These build configurations might fulfill these requirements for Project A:

- Project A - Device 1: Release
- Project A - Device 1: Debug
- Project A - Device 2: Release
- Project A - Device 2: Debug
Groups

Normally, projects contain hundreds of files that are logically related. You can define each project to contain one or more groups, in which you can collect related source files. You can also define multiple levels of subgroups to achieve a logical hierarchy. By default, each group is present in all build configurations of the project, but you can also specify a group to be excluded from a particular build configuration.

Source files and their paths

Source files can be located directly under the project node or in a hierarchy of groups. The latter is convenient if the amount of files makes the project difficult to survey. By default, each file is present in all build configurations of the project, but you can also specify a file to be excluded from a particular build configuration.

Only the files that are part of a build configuration will actually be built and linked into the output code.

Once a project has been successfully built, all include files and output files are displayed in the structure below the source file that included or generated them.

Note: The settings for a build configuration can affect which include files that are used during the compilation of a source file. This means that the set of include files associated with the source file after compilation can differ between the build configurations.

The IDE supports relative source file paths to a certain degree, for:

- Project file
  Paths to files part of the project file is relative if they are located on the same drive. The path is relative either to $PROJ_DIR$ or $EW_DIR$. The argument variable $EW_DIR$ is only used if the path refers to a file located in subdirectory to $EW_DIR$ and the distance from $EW_DIR$ is shorter than the distance from $PROJ_DIR$.
  Paths to files that are part of the project file are absolute if the files are located on different drives.

- Workspace file
  For files located on the same drive as the workspace file, the path is relative to $PROJ_DIR$.
  For files located on another drive as the workspace file, the path is absolute.

- Debug files
  If your ELF file contains debug information, any paths in the file that references source files are absolute.
Drag and drop
You can easily drag individual source files and project files from the Windows file explorer to the Workspace window. Source files dropped on a group are added to that group. Source files dropped outside the project tree—on the Workspace window background—are added to the active project.

INTERACTING WITH VERSION CONTROL SYSTEMS
The IAR Embedded Workbench IDE can identify and access any:

- Installed third-party version control system that conforms to the Source Code Control (SCC) interface published by Microsoft corporation
- Files that are in a Subversion (SVN) working copy.

From within the IDE you can connect an IAR Embedded Workbench project to an external SCC or SVN project, and perform some of the most commonly used operations.

To connect your IAR Embedded Workbench project to a version control system you should be familiar with the version control client application you are using. Note that some of the windows and dialog boxes that appear when you work with version control in the IDE originate from the version control system and are not described in the documentation from IAR Systems. For information about details in the client application, refer to the documentation supplied with that application.

Note: Different version control systems use very different terminology even for some of the most basic concepts involved. You must keep this in mind when you read the descriptions about interacting between the IDE and the version control system.

Procedures for managing projects
This section gives you step-by-step descriptions of how to use certain features related to project management.

More specifically, you will get information about:

- Creating and managing workspaces
- Viewing the workspace
- Displaying browse information
- Interacting with SCC-compatible systems
- Interacting with Subversion.
CREATING AND MANAGING WORKSPACES

Here, you will get the overall procedure for creating the workspace, projects, groups, files, and build configurations, but not the corresponding in-depth step-by-step descriptions. The File menu provides the commands for creating workspaces. The Project menu provides commands for creating projects, adding files to a project, creating groups, specifying project options, and running the IAR Systems development tools on the current projects.

The steps involved for creating and managing a workspace and its contents are:

- Creating a workspace.
  An empty Workspace window appears, which is the place where you can view your projects, groups, and files.
- Adding new or existing projects to the workspace.
  When creating a new project, you can base it on a template project with preconfigured project settings. Template projects are available for C applications, C++ applications, assembler applications, and library projects.
- Creating groups.
  A group can be added either to the project’s top node or to another group within the project.
- Adding files to the project.
  A file can be added either to the project’s top node or to a group within the project.
- Creating new build configurations.
  By default, each project you add to a workspace will have two build configurations called Debug and Release.
  You can base a new configuration on an already existing configuration. Alternatively, you can choose to create a default build configuration.
  Note that you do not have to use the same toolchain for the new build configuration as for other build configurations in the same project.
- Excluding groups and files from a build configuration.
  Note that the icon indicating the excluded group or file will change to white in the Workspace window.
- Removing items from a project.

**Note:** It might not be necessary for you to perform all of these steps.

For a detailed example, see *Creating an application project* in the tutorials.
VIEWING THE WORKSPACE

The Workspace window is where you access your projects and files during the application development.

1. To choose which project you want to view, click its tab at the bottom of the Workspace window.

For each file that has been built, an Output folder icon appears, containing generated files, such as object files and list files. The latter is generated only if the list file option is enabled. There is also an Output folder related to the project node that contains generated files related to the whole project, such as the executable file and the linker map file (if the list file option is enabled).

Also, any included header files will appear, showing dependencies at a glance.

2. To display the project with a different build configuration, choose that build configuration from the drop-down list at the top of the Workspace window.
The project and build configuration you have selected are displayed highlighted in the Workspace window. It is the project and build configuration that you select from the drop-down list that is built when you build your application.

3 To display an overview of all projects in the workspace, click the **Overview** tab at the bottom of the Workspace window.

An overview of all project members is displayed.

![Figure 6: Workspace window—an overview](image)

The current selection in the **Build Configuration** drop-down list is also highlighted when an overview of the workspace is displayed.

**DISPLAYING BROWSE INFORMATION**

1 To open the Source Browser window, choose **View>Source Browser**.

The Source Browser window is, by default, docked with the Workspace window. Source browse information is displayed for the active build configuration.

Note that you can choose a file filter and a type filter from the context menu that appears when you right-click in the top pane of the window.

2 To display browse information in the Source Browser window, choose **Tools>Options>Project** and select the option **Generate browse information**.

3 To see the definition of a global symbol or a function, you can use three alternative methods:
In the Source Browser window, right-click on a symbol, or function, and choose the Go to definition command from the context menu that appears.

In the Source Browser window, double-click on a row.

In the editor window, right-click on a symbol, or function, and choose the Go to definition command from the context menu that appears.

The definition of the symbol or function is displayed in the editor window.

The source browse information is continuously updated in the background. While you are editing source files, or when you open a new project, there will be a short delay before the information is up-to-date.

INTERACTING WITH SCC-COMPATIBLE SYSTEMS

In any SCC-compatible system, you use a client application to maintain a central archive. In this archive you keep the working copies of the files of your project. The version control integration in IAR Embedded Workbench allows you to conveniently perform some of the most common version control operations directly from within the IDE. However, several tasks must still be performed in the client application.

To connect an IAR Embedded Workbench project to an SCC system, you should:

1. In the Microsoft SCC-compatible client application, set up an SCC project.
2. In the IDE, connect your application project to the SCC project.

Setting up an SCC project in the SCC client application

Use your SCC client tools to set up a working directory for the files in your IAR Embedded Workbench project that you want to control using your SCC system. The files can be placed in one or more nested subdirectories, all located under a common root. Specifically, all source files must reside in the same directory as the .ewp project file, or in subdirectories of this directory.

For information about the steps involved, refer to the documentation supplied with the SCC client application.

Connecting application projects to the SCC project

1. In the Workspace window, select the project for which you have created an SCC project.
2. From the Project menu, choose Version Control System>Connect Project To SCC Project. This command is also available from the context menu that appears when you right-click in the Workspace window.

Note: The commands on the Source Code Control submenu are available when you have successfully connected your application project to your SCC project.
3 If you have SCC-compatible systems from different vendors installed, you will be prompted to choose which system you want to connect to.

4 An SCC-specific dialog box will appear where you can navigate to the SCC project that you have set up.

For reference information about the commands available for accessing the SCC system, see *Version Control System menu for SCC*, page 51.

**Viewing the SCC states**

When your IAR Embedded Workbench project has been connected to the SCC project, a column that contains status information for version control will appear in the Workspace window. Different icons are displayed depending on the state.

There are also icons for some combinations of these states. Note that the interpretation of these states depends on the SCC client application you are using. For reference information about the icons and the different states they represent, see *Source code control states*, page 55.

**Configuring the interaction between the IDE and SCC**

To configure the interaction between the IDE and SCC, choose **Tools>Options** and click the **Source Code Control** tab. For reference information about the available commands, see *Source Code Control options*, page 139.

**INTERACTING WITH SUBVERSION**

The version control integration in IAR Embedded Workbench allows you to conveniently perform some of the most common Subversion operations directly from within the IDE, using the client applications **svn.exe** and **TortoiseProc.exe**.

To connect an IAR Embedded Workbench project to an SVN system, you should:

1 In the SVN client application, set up an SVN working copy
2 In the IDE, connect your application project to the SVN working copy.

**Setting up a Subversion working copy**

1 To use the Subversion integration in the IDE, make sure that **svn.exe** and **TortoiseProc.exe** are in your path.
2 Check out a working copy from a Subversion repository.

   The files that constitute your project do not have to come from the same working copy; all files in the project are treated individually. However, note that **TortoiseProc.exe** does not allow you to simultaneously, for example, check in files coming from different repositories.
Connecting application projects to the Subversion working copy

1. In the Workspace window, select the project for which you have created a Subversion working copy.

2. From the Project menu, choose Version Control System>Connect Project to Subversion. This command is also available from the context menu that appears when you right-click in the Workspace window.

For reference information about the commands available for accessing the Subversion working copy, see Version Control System menu for Subversion, page 56.

Viewing the Subversion states

When your IAR Embedded Workbench project has been connected to the Subversion working copy, a column that contains status information for version control will appear in the Workspace window. Various icons are displayed, where each icon reflects the svn status, see Subversion states, page 57.

Reference information on managing projects

This section gives reference information about these windows and dialog boxes:

- Workspace window, page 41
- Create New Project dialog box, page 45
- Configurations for project dialog box, page 46
- New Configuration dialog box, page 47
- Source Browser window, page 48
- Version Control System menu for SCC, page 51
- Select Source Code Control Provider dialog box, page 53
- Check In Files dialog box, page 53
- Check Out Files dialog box, page 54
- Source code control states, page 55
- Version Control System menu for Subversion, page 56
- Subversion states, page 57.

See also:

Source Code Control options, page 139.
Workspace window

The Workspace window is available from the View menu.

Use the Workspace window to access your projects and files during the application development.

Drop-down list

At the top of the window there is a drop-down list where you can choose a build configuration to display in the window for a specific project.

The display area

This area contains four columns.

The Files column displays the name of the current workspace and a tree representation of the projects, groups and files included in the workspace. One or more of these icons are displayed:

- Workspace
- Project
- Project with multi-file compilation
- Group of files

Figure 7: Workspace window
Group excluded from the build
Group of files, part of multi-file compilation
Group of files, part of multi-file compilation, but excluded from the build
Object file or library
Assembler source file
C source file
C++ source file
Source file excluded from the build
Header file
Text file
HTML text file
Control file, for example the linker configuration file
IDE internal file
Other file

The column that contains status information about option overrides can have one of three icons for each level in the project:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank</td>
<td>There are no settings/overrides for this file/group.</td>
</tr>
<tr>
<td>Black check mark</td>
<td>There are local settings/overrides for this file/group.</td>
</tr>
<tr>
<td>Red check mark</td>
<td>There are local settings/overrides for this file/group, but they are either identical to the inherited settings or they are ignored because you use multi-file compilation, which means that the overrides are not needed.</td>
</tr>
</tbody>
</table>

The column that contains build status information can have one of three icons for each file in the project:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank</td>
<td>The file will not be rebuilt next time the project is built.</td>
</tr>
<tr>
<td>Red star</td>
<td>The file will be rebuilt next time the project is built.</td>
</tr>
<tr>
<td>Gearwheel</td>
<td>The file is being rebuilt.</td>
</tr>
</tbody>
</table>
The column contains status information about version control. For information about the various icons, see:

- Source code control states, page 55
- Subversion states, page 57.

Use the tabs at the bottom of the window to choose which project to display. Alternatively, you can choose to display an overview of the entire workspace.

For more information about project management and using the Workspace window, see the Introduction to managing projects, page 29.

**Context menu**

This context menu is available:

![Context menu](image)

These commands are available:

**Options**
Displays a dialog box where you can set options for each build tool, for the selected item in the Workspace window. You can set options for the entire project, for a group of files, for an individual file. See Setting options, page 59.

**Make**
Brings the current target up to date by compiling, assembling, and linking only the files that have changed since the last build.
Compile

Compiles or assembles the currently active file as appropriate. You can choose the file either by selecting it in the Workspace window, or by selecting the editor window containing the file you want to compile.

Rebuild All

Recompiles and relinks all files in the selected build configuration.

Clean

Deletes intermediate files.

Stop Build

Stops the current build operation.

Add> Add Files

Displays a dialog box where you can add files to the project.

Add> Add filename

Adds the indicated file to the project. This command is only available if there is an open file in the editor.

Add> Add Group

Displays the Add Group dialog box where you can add new groups to the project. For more information about groups, see Groups, page 33.

Remove

Removes selected items from the Workspace window.

Rename

Displays the Rename Group dialog box where you can rename a group. For more information about groups, see Groups, page 33.

Version Control System

Opens a submenu with commands for source code control, see Version Control System menu for SCC, page 51.

Open Containing Folder

Opens the File Explorer that displays the directory where the selected file resides.

File Properties

Displays a standard File Properties dialog box for the selected file.

Set as Active

Sets the selected project in the overview display to be the active project. It is the active project that will be built when the Make command is executed.
Create New Project dialog box

The Create New Project dialog box is available from the Project menu.

![Create New Project dialog box](image)

Use this dialog box to create a new project based on a template project. Template projects are available for C/C++ applications, assembler applications, and library projects. You can also create your own template projects.

**Tool chain**

Selects the target to build for. If you have several versions of IAR Embedded Workbench for different targets installed on your host computer, the drop-down list might contain some or all of these targets.

**Project templates**

Select a template to base the new project on, from this list of available template projects.

**Description**

A description of the currently selected template.
Configurations for project dialog box

The Configurations for project dialog box is available by choosing Project>Edit Configurations.

Use this dialog box to define new build configurations for the selected project; either entirely new, or based on a previous project.

- **Configurations**
  Lists existing configurations, which can be used as templates for new configurations.

- **New**
  Displays a dialog box where you can define new build configurations, see New Configuration dialog box, page 47.

- **Remove**
  Removes the configuration that is selected in the Configurations list.
New Configuration dialog box

The New Configuration dialog box is available by clicking New in the Configurations for project dialog box.

![New Configuration dialog box](image)

**Figure 11: New Configuration dialog box**

Use this dialog box to define new build configurations; either entirely new, or based on any currently defined configuration.

**Name**

Type the name of the build configuration.

**Tool chain**

Specify the target to build for. If you have several versions of IAR Embedded Workbench for different targets installed on your host computer, the drop-down list might contain some or all of these targets.

**Based on configuration**

Selects a currently defined build configuration to base the new configuration on. The new configuration will inherit the project settings and information about the factory settings from the old configuration. If you select None, the new configuration will be based strictly on the factory settings.

**Factory settings**

Select the default factory settings that you want to apply to your new build configuration. These factory settings will be used by your project if you click the Factory Settings button in the Options dialog box.
Choose between:

**Debug**  
Factory settings suitable for a debug build configuration.

**Release**  
Factory settings suitable for a release build configuration.

**Source Browser window**

The Source Browser window is available from the **View** menu.

![Source Browser window](image)

The Source Browser window displays an hierarchical view in alphabetical order of all symbols defined in the active build configuration. This means that source browse information is available for symbols in source files and include files part of that configuration. Source browse information is not available for symbols in linked libraries. The window consists of two separate display areas.

For more information about how to use the Source Browser window, see *Displaying browse information*, page 37.

**The upper display area**

The upper display area contains two columns:

<table>
<thead>
<tr>
<th>Symbol type classification</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icons used for the symbol types</td>
<td>page 49</td>
</tr>
</tbody>
</table>

**Figure 12: Source Browser window**
If you click in the window header, you can sort the symbols either by name or by symbol type.

In the upper display area you can also access a context menu; see "Context menu," page 50.

**The lower display area**

For a symbol selected in the upper display area, the lower area displays its properties:

- **Full name**: Displays the unique name of each element, for instance `classname::membername`.
- **Symbol type**: Displays the symbol type for each element, see "Icons used for the symbol types," page 49.
- **Filename**: Specifies the path to the file in which the element is defined.

**Icons used for the symbol types**

These are the icons used:

- Base class
- Class
- Configuration
- Enumeration
- Enumeration constant
- Field of a struct
- Function
- Macro
- Namespace
- Template class
- Template function
- Type definition
Context menu

This context menu is available in the upper display area:

<table>
<thead>
<tr>
<th>Go to Definition</th>
<th>Move to Parent</th>
<th>All Symbols</th>
<th>All Functions &amp; Variables</th>
<th>Non-Member Functions &amp; Variables</th>
<th>Types</th>
<th>Constants &amp; Macros</th>
<th>All Files</th>
</tr>
</thead>
</table>

- **Go to Definition**: The editor window will display the definition of the selected item.
- **Move to Parent**: If the selected element is a member of a class, struct, union, enumeration, or namespace, this menu command can be used for moving to its enclosing element.
- **All Symbols**: Type filter; displays all global symbols and functions defined in the project.
- **All Functions & Variables**: Type filter; displays all functions and variables defined in the project.
- **Non-Member Functions & Variables**: Type filter; displays all functions and variables that are not members of a class.
- **Types**: Type filter; displays all types such as structures and classes defined in the project.
- **Constants & Macros**: Type filter; displays all constants and macros defined in the project.
- **All Files**: File filter; displays symbols from all files that you have explicitly added to your project and all files included by them.
Version Control System menu for SCC

The Version Control System submenu is available from the Project menu and from the context menu in the Workspace window.

This is the menu for SCC-compatible systems:

```
Exclude System
Includes
Only Project Members
```

**Note:** The contents of the Version Control System submenu reflect the version control system in use, either an SCC-compatible system or Subversion.

For more information about interacting with an external version control system, see *Interacting with version control systems*, page 34.

These commands are available for SCC:

- **Check In**
  Displays the Check In Files dialog box where you can check in the selected files; see *Check In Files dialog box*, page 53. Any changes you have made in the files will be stored in the archive. This command is enabled when currently checked-out files are selected in the Workspace window.
Check Out
Checks out the selected file or files. Depending on the SCC (Source Code Control) system you are using, a dialog box might appear; see Check Out Files dialog box, page 54. This means you get a local copy of the file(s), which you can edit. This command is enabled when currently checked-in files are selected in the Workspace window.

Undo Checkout
Reverts the selected files to the latest archived version; the files are no longer checked out. Any changes you have made to the files will be lost. This command is enabled when currently checked-out files are selected in the Workspace window.

Get Latest Version
Replaces the selected files with the latest archived version.

Compare
Displays—in an SCC-specific window—the differences between the local version and the most recent archived version.

History
Displays SCC-specific information about the revision history of the selected file.

Properties
Displays information available in the version control system for the selected file.

Refresh
Updates the version control system display status for all the files that are part of the project. This command is always enabled for all projects under the version control system.

Connect Project to SCC Project
Displays a dialog box, which originates from the SCC client application, to let you create a connection between the selected IAR Embedded Workbench project and an SCC project; the IAR Embedded Workbench project will then be an SCC-controlled project. After creating this connection, a special column that contains status information will appear in the Workspace window.

Disconnect Project from SCC Project
Removes the connection between the selected IAR Embedded Workbench project and an SCC project; your project will no longer be a SCC-controlled project. The column in the Workspace window that contains SCC status information will no longer be visible for that project.
Select Source Code Control Provider dialog box

The Select Source Code Control Provider dialog box is displayed if several SCC systems from different vendors are available.

Figure 15: Select Source Code Control Provider dialog box

Use this dialog box to choose the SCC system you want to use.

Check In Files dialog box

The Check In Files dialog box is available by choosing the Project>Source Code Control>Check In command, alternatively available from the Workspace window context menu.

Figure 16: Check In Files dialog box
Comment

Specify a comment—typically a description of your changes—that will be stored in the archive together with the file revision. This text box is only enabled if the SCC system supports adding comments at check in.

Keep checked out

Specifies that the files will continue to be checked out after they have been checked in. Typically, this is useful if you want to make your modifications available to other members in your project team, without stopping your own work with the file.

Advanced

Displays a dialog box, originating from the SCC client application, that contains advanced options. This button is only available if the SCC system supports setting advanced options at check in.

Files

Lists the files that will be checked in. The list will contain all files that were selected in the Workspace window when the Check In Files dialog box was opened.

Check Out Files dialog box

The Check Out Files dialog box is available by choosing the Project>Source Code Control>Check Out command, alternatively available from the Workspace window.
context menu. However, this dialog box is only available if the SCC system supports adding comments at check out or advanced options.

![Check Out Files dialog box](image)

**Comment**

Specify a comment—typically the reason why the file is checked out—that will be placed in the archive together with the file revision. This text box is only enabled if the SCC system supports the adding of comments at check out.

**Advanced**

Displays a dialog box, originating from the SCC client application, that contains advanced options. This button is only available if the SCC system supports setting advanced options at check out.

**Files**

Lists files that will be checked out. The list will contain all files that were selected in the Workspace window when the **Check Out Files** dialog box was opened.

### Source code control states

Each source code-controlled file can be in one of several states.

- **(blank)** Checked out to you. The file is editable.
Note: The source code control in the IAR Embedded Workbench IDE depends on the information provided by the SCC system. If the SCC system provides incorrect or incomplete information about the states, the IDE might display incorrect symbols.

### Version Control System menu for Subversion

The **Version Control System** submenu is available from the **Project** menu and from the context menu in the Workspace window.

This is the menu for Subversion:

<table>
<thead>
<tr>
<th>Menu Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Commit...</td>
</tr>
<tr>
<td>Add</td>
</tr>
<tr>
<td>Reset...</td>
</tr>
<tr>
<td>Update...</td>
</tr>
<tr>
<td>Diff...</td>
</tr>
<tr>
<td>Log...</td>
</tr>
<tr>
<td>Properties...</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SubMenu Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Checked Project to SCC Project...</td>
</tr>
<tr>
<td>Checked Project from SCC Project...</td>
</tr>
<tr>
<td>Checked Project to Subversion...</td>
</tr>
<tr>
<td>Checked Project from Subversion...</td>
</tr>
</tbody>
</table>

**Figure 18: Version Control System menu for Subversion**

**Note:** The contents of the Version Control System submenu reflect the version control system in use, either an SCC-compatible system or Subversion.
For more information about interacting with an external version control system, see *Interacting with version control systems*, page 34.

These commands are available for Subversion:

- **Commit**
  Displays Tortoise’s Commit dialog box for the selected file(s).

- **Add**
  Displays Tortoise’s Add dialog box for the selected file(s).

- **Revert**
  Displays Tortoise’s Revert dialog box for the selected file(s).

- **Update**
  Opens Tortoise’s Update window for the selected file(s).

- **Diff**
  Opens Tortoise’s Diff window for the selected file(s).

- **Log**
  Opens Tortoise’s Log window for the selected file(s).

- **Properties**
  Displays information available in the version control system for the selected file.

- **Refresh**
  Updates the version control system display status for all files that are part of the project. This command is always enabled for all projects under the version control system.

- **Connect Project to SVN Project**
  Checks whether **svn.exe** and **TortoiseProc.exe** are in the path and then enables the connection between the IAR Embedded Workbench project and an existing checked-out working copy. After this connection has been created, a special column that contains status information appears in the Workspace window. Note that you must check out the source files from outside the IDE.

- **Disconnect Project from SVN Project**
  Removes the connection between the selected IAR Embedded Workbench project and Subversion. The column in the Workspace window that contains SVN status information will no longer be visible for that project.

### Subversion states

Each Subversion-controlled file can be in one of several states.

- **(blue A)** Added.
- **(red C)** Conflicted.
- **(red D)** Deleted.
(red I) Ignored.

(blank) Not modified.

(red M) Modified.

(red R) Replaced.

(gray X) An unversioned directory created by an external definition.

(gray question mark) Item is not under version control.

(black exclamation mark) Item is missing—removed by a non-svn command—or incomplete.

(red tilde) Item obstructed by an item of a different type.

Note: The version control system in the IAR Embedded Workbench IDE depends on the information provided by Subversion. If Subversion provides incorrect or incomplete information about the states, the IDE might display incorrect symbols.
Building

This chapter briefly discusses the process of building your project, and describes how you can extend the chain of build tools with tools from third-party suppliers.

Building your project

The build process consists of these steps:

- Setting project options
- Building the project, either an application project or a library project
- Correcting any errors detected during the build procedure.

To make the build process more efficient, you can use the Batch Build command. This gives you the possibility to perform several builds in one operation. If necessary, you can also specify pre-build and post-build actions.

In addition to using the IAR Embedded Workbench IDE to build projects, you can also use the command line utility iarbuild.exe.

For examples of building application and library projects, see the tutorials in the Information Center. For further information about building library projects, see the IAR C/C++ Development Guide for ARM.

SETTING OPTIONS

To specify how your project should be built, you must define one or several build configurations. Every build configuration has its own settings, which are independent of the other configurations. All settings are indicated in a separate column in the Workspace window.

For example, a configuration that is used for debugging would not be highly optimized, and would produce output that suits the debugging. Conversely, a configuration for building the final application would be highly optimized, and produce output that suits a flash or PROM programmer.

For each build configuration, you can set options on the project level, group level, and file level. Many options can only be set on the project level because they affect the entire build configuration. Examples of such options are General Options (for example, processor variant and library object file), linker settings, and debug settings. Other options, such as compiler and assembler options, that you set on project level are default for the entire build configuration.
To override project level settings, select the required item—for instance a specific group of files—and then select the option **Override inherited settings**. The new settings will affect all members of that group, that is, files and any groups of files. To restore all settings to the default factory settings, click the **Factory Settings** button.

**Note:** There is one important restriction on setting options. If you set an option on group or file level (group or file level override), no options on higher levels that operate on files will affect that group or file.

**Using the Options dialog box**

The **Options** dialog box—available by choosing **Project>Options**—provides options for the build tools. You set these options for the selected item in the Workspace window. Options in the **General Options**, **Linker**, and **Debugger** categories can only be set for the entire build configuration, and not for individual groups and files. However, the options in the other categories can be set for the entire build configuration, a group of files, or an individual file.

![Options dialog box](image)

The **Category** list allows you to select which building tool to set options for. Which tools that are available in the **Category** list depends on which tools are included in your

---

**IDE Project Management and Building Guide**

for ARM
product. When you select a category, one or more pages containing options for that component are displayed.

Click the tab corresponding to the type of options you want to view or change. To restore all settings to the default factory settings, click the **Factory Settings** button, which is available for all categories except **General Options** and **Custom Build**. Note that two sets of factory settings are available: Debug and Release. Which one that is used depends on your build configuration; see *New Configuration dialog box*, page 47.

For information about each option and how to set options, see the chapters:

- General options
- Compiler options
- Assembler options
- Output converter options
- Linker options
- Library builder options
- Custom build options
- C-SPY driver options (see the C-SPY® Debugging Guide for ARM®).

**Note:** If you add to your project a source file with a non-recognized filename extension, you cannot set options on that source file. However, you can add support for additional filename extensions. For reference information, see *Filename Extensions dialog box*, page 149.

**BUILDING A PROJECT**

You can build your project either as an application project or a library project.

**Note:** To build your project as a library project, choose **Project>Options>General Options>Output>Output file>Library** before you build your project. Then, **Linker** is replaced by **Library Builder** in the **Category** list in the options dialog box, and the result of the build will be a library. For an example, see the tutorials.

You have access to the build commands both from the **Project** menu and from the context menu that appears if you right-click an item in the Workspace window.

The three build commands **Make**, **Compile**, and **Rebuild All** run in the background, so you can continue editing or working with the IDE while your project is being built.

For further reference information, see *Project menu*, page 115.

**BUILDING MULTIPLE CONFIGURATIONS IN A BATCH**

Use the batch build feature when you want to build more than one configuration at once. A batch is an ordered list of build configurations. The **Batch Build** dialog
Building your project

box—available from the Project menu—lets you create, modify, and build batches of configurations.

For workspaces that contain several configurations, it is convenient to define one or more different batches. Instead of building the entire workspace, you can build only the appropriate build configurations, for instance Release or Debug configurations.

For detailed information about the Batch Build dialog box, see Batch Build dialog box, page 122.

**USING PRE- AND POST-BUILD ACTIONS**

If necessary, you can specify pre-build and post-build actions that you want to occur before or after the build. The Build Actions dialog box—available from the Project menu—lets you specify the actions required.

For detailed information about the Build Actions dialog box, see Build actions options, page 191.

Using pre-build actions for time stamping

You can use pre-build actions to embed a time stamp for the build in the resulting binary file. Follow these steps:

1. Create a dedicated time stamp file, for example, timestamp.c and add it to your project.
2. In this source file, use the preprocessor macros __TIME__ and __DATE__ to initialize a string variable.
3. Choose Project>Options>Build Actions to open the Build Actions dialog box.
4. In the Pre-build command line text field, specify for example this pre-build action:

   ```
   "touch $PROJ_DIR\timestamp.c"
   ```

   You can use the open source command line utility touch for this purpose or any other suitable utility which updates the modification time of the source file.

5. If the project is not entirely up-to-date, the next time you use the Make command, the pre-build action will be invoked before the regular build process. Then the regular build process must always recompile timestamp.c and the correct timestamp will end up in the binary file.

If the project already is up-to-date, the pre-build action will not be invoked. This means that nothing is built, and the binary file still contains the timestamp for when it was last built.
CORRECTING ERRORS FOUND DURING BUILD

The compiler, assembler, and debugger are fully integrated with the development environment. If your source code contains errors, you can jump directly to the correct position in the appropriate source file by double-clicking the error message in the error listing in the Build message window, or selecting the error and pressing Enter.

After you have resolved any problems reported during the build process and rebuilt the project, you can directly start debugging the resulting code at the source level.

To specify the level of output to the Build message window, choose Tools>Options to open the IDE Options dialog box. Click the Messages tab and select the level of output in the Show build messages drop-down list. Alternatively, you can right-click in the Build Messages window and select Options from the context menu.

For reference information about the Build messages window, see Build window, page 96.

BUILDING FROM THE COMMAND LINE

To build the project from the command line, use the IAR Command Line Build Utility (iarbuild.exe) located in the common\bin directory. As input you use the project file, and the invocation syntax is:

```
iarbuild project.ewp [-clean|-build|-make] <configuration> [-log errors|warnings|info|all]
```

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>project.ewp</td>
<td>Your IAR Embedded Workbench project file.</td>
</tr>
<tr>
<td>-clean</td>
<td>Removes any intermediate and output files.</td>
</tr>
<tr>
<td>-build</td>
<td>Rebuilds and relinks all files in the current build configuration.</td>
</tr>
<tr>
<td>-make</td>
<td>Brings the current build configuration up to date by compiling, assembling, and linking only the files that have changed since the last build.</td>
</tr>
<tr>
<td>configuration</td>
<td>The name of the configuration you want to build, which can either be one of the predefined configurations Debug or Release, or a name that you define yourself. For more information about build configurations, see Projects and build configurations, page 32.</td>
</tr>
<tr>
<td>-log errors</td>
<td>Displays build error messages.</td>
</tr>
<tr>
<td>-log warnings</td>
<td>Displays build warning and error messages.</td>
</tr>
<tr>
<td>-log info</td>
<td>Displays build warning and error messages, and messages issued by the #pragma message preprocessor directive.</td>
</tr>
</tbody>
</table>

Table 3: iarbuild.exe command line options
If you run the application from a command shell without specifying a project file, you will get a sign-on message describing available parameters and their syntax.

Extending the toolchain

IAR Embedded Workbench provides a feature—Custom Build—which lets you extend the standard toolchain. This feature is used for executing external tools (not provided by IAR Systems). You can make these tools execute each time specific files in your project have changed.

If you specify custom build options on the Custom tool configuration page, the build commands treat the external tool and its associated files in the same way as the standard tools within the IAR Embedded Workbench IDE and their associated files. The relation between the external tool and its input files and generated output files is similar to the relation between the C/C++ Compiler, c files, h files, and o files. See Custom build options, page 189, for details about available custom build options.

You specify filename extensions of the files used as input to the external tool. If the input file has changed since you last built your project, the external tool is executed; just as the compiler executes if a c file has changed. In the same way, any changes in additional input files (for instance include files) are detected.

You must specify the name of the external tool. You can also specify any necessary command line options needed by the external tool, and the name of the output files generated by the external tool. Note that you can use argument variables for substituting file paths.

For some of the file information, you can use argument variables.

You can specify custom build options to any level in the project tree. The options you specify are inherited by any sublevel in the project tree.

TOOLS THAT CAN BE ADDED TO THE TOOLCHAIN

Some examples of external tools, or types of tools, that you can add to the IAR Embedded Workbench toolchain are:

- Tools that generate files from a specification, such as Lex and YACC
Tools that convert binary files—for example files that contain bitmap images or audio data—to a table of data in an assembler or C source file. This data can then be compiled and linked together with the rest of your application.

**ADDING AN EXTERNAL TOOL**

The following example demonstrates how to add the tool *Flex* to the toolchain. The same procedure can be used also for other tools.

In the example, Flex takes the file `myFile.lex` as input. The two files `myFile.c` and `myFile.h` are generated as output.

1. Add the file you want to work with to your project, for example `myFile.lex`.
2. Select this file in the workspace window and choose **Project>Options**. Select **Custom Build** from the list of categories.
3. In the **Filename extensions** field, type the filename extension `.lex`. Remember to specify the leading period (`.`).
4. In the **Command line** field, type the command line for executing the external tool, for example
   ```
   flex $FILE_PATH$ -o$FILE_BNAME$.c
   ```
   During the build process, this command line is expanded to:
   ```
   flex myFile.lex -omyFile.c
   ```
   Note the usage of **argument variables**. Note specifically the use of `$FILE_BNAME$` which gives the base name of the input file, in this example appended with the `c` extension to provide a C source file in the same directory as the input file `foo.lex`. For further details of these variables, see **Argument variables**, page 121.
5. In the **Output files** field, describe the output files that are relevant for the build. In this example, the tool Flex would generate two files—one source file and one header file. The text in the **Output files** text box for these two files would look like this:
   ```
   $FILE_BPATH$.c
   $FILE_BPATH$.h
   ```
6. If the external tool uses any additional files during the build, these should be added in the **Additional input files** field, for instance:
   ```
   $TOOLKIT_DIR\inc\stdio.h
   ```
   This is important, because if the dependency files change, the conditions will no longer be the same and the need for a rebuild is detected.
7. Click **OK**.
8. To build your application, choose **Project>Make**.
Extending the toolchain
Editing

This chapter describes in detail how to use the IAR Embedded Workbench editor. The final section describes how to customize the editor and how to use an external editor of your choice.

Using the IAR Embedded Workbench editor

The integrated text editor allows editing of multiple files in parallel, and provides all basic editing features expected from a modern editor. In addition, it provides functions specific to software development, like coloring of keywords (C/C++, assembler, and user-defined), block indent, and function navigation within source files. It also recognizes C language elements like matching brackets. This list shows some additional features:

- Context-sensitive help system that can display reference information for DLIB library functions
- Syntax of C or C++ programs and assembler directives shown using text styles and colors
- Powerful search and replace commands, including multi-file search
- Direct jump to context from error listing
- Multibyte character support
- Parenthesis matching
- Automatic completion and indentation
- Bookmarks
- Unlimited undo and redo for each window.

EDITING A FILE

The editor window is where you write, view, and modify your source code. You can open one or several text files, either from the File menu, or by double-clicking a file in the Workspace window. If you open several files, they are organized in a tab group. Several editor windows can be open at the same time.
Click the tab for the file that you want to display. All open files are also available from the drop-down menu at the upper right corner of the editor window.

The name of the open source file is displayed on the tab. If a file is read-only, a padlock is visible at the bottom left corner of the editor window. If a file has been modified after it was last saved, an asterisk appears on the tab after the filename, for example **Utilities.c**.

The commands on the **Window** menu allow you to split the editor window into panes. On the **Window** menu you also find commands for opening multiple editor windows, and commands for moving files between editor windows. For reference information about each command on the menu, see **Window menu**, page 153. For reference information about the editor window, see **Editor window**, page 90.

**Note:** When you want to print a source file, it can be useful to enable the option **Show line numbers**—available by choosing **Tools>Options>Editor**.
Accessing reference information for DLIB library functions

When you need to know the syntax for any library function, select the function name in the editor window and press F1. The library documentation for the selected function appears in a help window.

Using and customizing editor commands and shortcut keys

The Edit menu provides commands for editing and searching in editor windows, for instance, unlimited undo/redo (the Edit>Undo and Edit>Redo commands, respectively). You can also find some of these commands on the context menu that appears when you right-click in the editor window. For reference information about each command, see Edit menu, page 103.

There are also editor shortcut keys for:
- moving the insertion point
- scrolling text
- selecting text.

For detailed information about these shortcut keys, see Editor shortcut key summary, page 95.

To change the default shortcut key bindings, choose Tools>Options, and click the Key Bindings tab. For further details, see Key Bindings options, page 126.

Splitting the editor window into panes

You can split the editor window horizontally or vertically into multiple panes, to look at different parts of the same source file at once, or to move text between two different panes.

To split the window, double-click the appropriate splitter bar, or drag it to the middle of the window. Alternatively, you can split a window into panes using the Window>Split command.

To revert to a single pane, double-click the splitter control or drag it back to the end of the scroll bar.

Dragging and dropping of text

You can easily move text within an editor window or between editor windows. Select the text and drag it to the new location.
**Syntax coloring**

If the *Tools>*Options>*Editor>*Syntax highlighting option is enabled, the IAR Embedded Workbench editor automatically recognizes the syntax of:

- C and C++ keywords
- C and C++ comments
- Assembler directives and comments
- Preprocessor directives
- Strings.

The different parts of source code are displayed in different text styles.

To change these styles, choose *Tools>*Options, and use the *Editor>*Colors and Fonts options. For additional information, see *Editor Colors and Fonts options*, page 134.

In addition, you can define your own set of keywords that should be syntax-colored automatically:

1. In a text file, list all the keywords that you want to be automatically syntax-colored. Separate each keyword with either a space or a new line.
2. Choose *Tools>*Options and select *Editor>*Setup Files.
3. Select the *Use Custom Keyword File* option and specify your newly created text file. A browse button is available for your convenience.
4. Select *Editor>*Colors and Fonts and choose *User Keyword* from the Syntax Coloring list. Specify the font, color, and type style of your choice. For additional information, see *Editor Colors and Fonts options*, page 134.
5. In the editor window, type any of the keywords you listed in your keyword file; see how the keyword is syntax-colored according to your specification.

**Automatic text indentation**

The text editor can perform various kinds of indentation. For assembler source files and normal text files, the editor automatically indents a line to match the previous line. If you want to indent several lines, select the lines and press the Tab key. Press Shift+Tab to move a whole block of lines to the left.

For C/C++ source files, the editor indents lines according to the syntax of the C/C++ source code. This is performed whenever you:

- Press the Return key
- Type any of the special characters {, }, ;, and #
- Have selected one or several lines, and choose the *Edit>*Auto Indent command.
To enable or disable the indentation:

1. Choose Tools>Options and select Editor.
2. Select or deselect the Auto indent option.

To customize the C/C++ automatic indentation, click the Configure button.

For additional information, see Configure Auto Indent dialog box, page 130.

Matching brackets and parentheses

When the insertion point is located next to a parenthesis, the matching parenthesis is highlighted with a light gray color:

```c
    for (int i = 0; i < 10; i++)
    {
    }
```

Figure 21: Parenthesis matching in editor window

The highlight remains in place as long as the insertion point is located next to the parenthesis.

To select all text between the brackets surrounding the insertion point, choose Edit>Match Brackets. Every time you choose Match Brackets after that, the selection will increase to the next hierarchic pair of brackets.

Note: Both of these functions—automatic matching of corresponding parentheses and selection of text between brackets—apply to (), [], and {}.

Displaying status information

As you are editing, the status bar—available by choosing View>Status Bar—shows the current line and column number containing the insertion point, and the Caps Lock, Num Lock, and Overwrite status:

Figure 22: Editor window status bar

USING AND ADDING CODE TEMPLATES

Code templates is a method for conveniently inserting frequently used source code sequences, for example for loops and if statements. The code templates are defined in...
a normal text file. By default, a few example templates are provided. In addition, you can easily add your own code templates.

**Enabling code templates**

By default, code templates are enabled. To enable and disable the use of code templates:

1. Choose **Tools>Options**.
2. Go to the **Editor Setup Files** page.
3. Select or deselect the **Use Code Templates** option.
4. In the text field, specify which template file you want to use; either the default file or one of your own template files. A browse button is available for your convenience.

**Inserting a code template into your source code**

To insert a code template into your source code, place the insertion point at the location where you want the template to be inserted, right-click, and choose **Insert Template** and the appropriate code template from the menu that appears.

If the code template you choose requires any type of field input, as in the `for` loop example which needs an end value and a count variable, an input dialog box appears.
Adding your own code templates

The source code templates are defined in a normal text file. The original template file CodeTemplates.txt is located in the common\config installation directory. The first time you use IAR Embedded Workbench, the original template file is copied to a directory for local settings, and this is the file that is used by default if code templates are enabled. To use your own template file, follow the procedure described in Enabling code templates, page 72.

To open the template file and define your own code templates, choose Edit>Code Templates>Edit Templates.

The syntax for defining templates is described in the default template file.

Selecting the correct language version of the code template file

When you start the IAR Embedded Workbench IDE for the very first time, you are asked to select a language version. This only applies if you are using an IDE that is available in other languages than English.

Selecting a language creates a corresponding language version of the default code template file in the Application Data\IAR Embedded Workbench subdirectory of the current Windows user (for example CodeTemplates.ENU.txt for English and CodeTemplates.JPN.txt for Japanese). The default code template file does not change automatically if you change the language version of the IDE afterwards.

To change the code template:

1. Choose Tools>Options>IDE Options>Editor>Setup Files.
2. Click the browse button of the Use Code Templates option and select a different template file.
   
   If the code template file you want to select is not in the browsed directory, you must:
3. Delete the file name in the Use Code Templates text box.
4. Deselect the Use Code Templates option and click OK.
5. Restart the IAR Embedded Workbench IDE.
6. Then choose Tools>Options>IDE Options>Editor>Setup Files again.

   The default code template file for the selected language version of the IDE should now be displayed in the Use Code Templates text box. Select the check box to enable the template.
NAVIGATING IN AND BETWEEN FILES

The editor provides several functions for easy navigation within the files and between files:

- Switching between source and header files
  If the insertion point is located on an `#include` line, you can choose the Open "header.h" command from the context menu, which opens the header file in an editor window. You can also choose the command Open Header/Source File, which opens the header or source file that corresponds to the current file, or activates it if it is already open. This command is available if the insertion point is located on any line except an `#include` line.

- Function navigation
  Click the Go to function button in the bottom left corner in an editor window to list all functions defined in the source file displayed in the window. You can then choose to go directly to one of the functions by double-clicking it in the list.

- Adding bookmarks
  Use the Edit>Navigate>Toggle Bookmark command to add and remove bookmarks. To switch between the marked locations, choose Edit>Navigate>Go to Bookmark.

SEARCHING

There are several standard search functions available in the editor:

- Quick search text box
- Find dialog box
- Replace dialog box
- Find in files dialog box
- Incremental Search dialog box.

To use the Quick search text box on the toolbar:

1. Type the text you want to search for and press Enter.

2. Press Esc to stop the search. This is a quick method for searching for text in the active editor window.

To use the Find, Replace, Find in Files, and Incremental Search functions:

1. Before you use the search commands, choose Tools>Options>Editor and make sure the Show bookmarks option is selected.

2. Choose the appropriate search command from the Edit menu. For reference information about each search function, see Edit menu, page 103.
3 To remove the blue flag icons that have appeared in the left-hand margin, right-click in
the Find in Files window and choose Clear All from the context menu.

Customizing the editor environment

The IDE editor can be configured on the IDE Options pages Editor and Editor Colors
and Fonts. Choose Tools>Options to access the pages.

For details about these pages, see Tools menu, page 124.

USING AN EXTERNAL EDITOR

The External Editor options—available by choosing Tools>Options>Editor—let you
specify an external editor of your choice.

Note: While debugging using C-SPY, C-SPY will not use the external editor for
displaying the current debug state. Instead, the built-in editor will be used.

To specify an external editor of your choice, follow this procedure:

1 Select the option Use External Editor.

2 An external editor can be called in one of two ways, using the Type drop-down menu.
   Command Line calls the external editor by passing command line parameters.
   DDE calls the external editor by using DDE (Windows Dynamic Data Exchange).

3 If you use the command line, specify the command line to pass to the editor, that is, the
   name of the editor and its path, for instance:
   C:\Windows\NOTEPAD.EXE.
To send an argument to the external editor, type the argument in the **Arguments** field. For example, type `$FILE_PATH$` to start the editor with the active file (in editor, project, or Messages window).

**Figure 24: Specifying an external command line editor**

**Note:** Options for Register Filter and Terminal I/O are only available when the C-SPY debugger is running.

4. If you use DDE, specify the editor’s DDE service name in the **Service** field. In the **Command** field, specify a sequence of command strings to send to the editor.

The service name and command strings depend on the external editor that you are using. Refer to the user documentation of your external editor to find the appropriate settings.

The command strings should be entered as:

```
DDE-Topic CommandString1
DDE-Topic CommandString2
```
as in this example, which applies to Codewright®:

![Figure 25: External editor DDE settings](image)

The command strings used in this example will open the external editor with a dedicated file activated. The cursor will be located on the current line as defined in the context from where the file is open, for instance when searching for a string in a file, or when double-clicking an error message in the Message window.

5 Click **OK**.

When you double-click a file in the Workspace window, the file is opened by the external editor.

Variables can be used in the arguments. For more information about the argument variables that are available, see *Argument variables*, page 121.
Customizing the editor environment
Part 2. Reference information

This part of the IDE Project Management and Building Guide contains these chapters:

- Installed files
- IAR Embedded Workbench IDE reference
- General options
- Compiler options
- Assembler options
- Output converter options
- Custom build options
- Build actions options
- Linker options
- Library builder options.
Installed files

This chapter describes which directories that are created during installation and which file types that are used.

Directory structure

The installation procedure creates several directories to contain the various types of files used with the IAR Systems development tools. The following sections give a description of the files contained by default in each directory.

ROOT DIRECTORY

The root directory created by the default installation procedure is the \Program Files\IAR Systems\Embedded Workbench 6.n\ directory where x is the drive where Microsoft Windows is installed and 6.n is the version number of the IDE.

THE ARM DIRECTORY

The arm directory contains all product-specific subdirectories.

<table>
<thead>
<tr>
<th>Directory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>arm\bin</td>
<td>The arm\bin subdirectory contains executable files for ARM-specific components, such as the compiler, the assembler, the linker and the library tools, and the C-SPY® drivers.</td>
</tr>
<tr>
<td>arm\CMSIS</td>
<td>The arm\CMSIS subdirectory contains CMSIS and CMSIS DSP library files and documentation.</td>
</tr>
</tbody>
</table>
| arm\config        | The arm\config subdirectory contains files used for configuring the development environment and projects, for example:  
                    • Linker configuration files (*.icf)  
                    • C-SPY device description files (*.ddf)  
                    • Device selection files (*.i79, *.menu)  
                    • Flash loader applications for various devices (*.out)  
                    • Syntax coloring configuration files (*.cfg)  
                    • Project templates for both application and library projects (*.ewp), and for the library projects, the corresponding library configuration files. |

Table 4: The ARM directory
THE COMMON DIRECTORY

The common directory contains subdirectories for components shared by all IAR Embedded Workbench products.

<table>
<thead>
<tr>
<th>Directory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>arm\doc</td>
<td>The arm\doc subdirectory contains release notes with recent additional information about the ARM tools. We recommend that you read all of these files. The directory also contains online versions in hypertext PDF format of the user guide, and of the ARM reference guides, as well as online help files (*.chm).</td>
</tr>
<tr>
<td>arm\drivers</td>
<td>The arm\drivers subdirectory contains low-level device drivers, typically USB drivers required by the C-SPY drivers.</td>
</tr>
<tr>
<td>arm\examples</td>
<td>The arm\examples subdirectory contains files related to example projects, which can be opened from the Information Center.</td>
</tr>
<tr>
<td>arm\inc</td>
<td>The arm\inc subdirectory holds files, such as the header files for the standard C or C++ library. There are also specific header files that define special function registers (SFRs); these files are used by both the compiler and the assembler.</td>
</tr>
<tr>
<td>arm\lib</td>
<td>The arm\lib subdirectory holds prebuilt libraries and the corresponding library configuration files, used by the compiler.</td>
</tr>
<tr>
<td>arm\plugins</td>
<td>The arm\plugins subdirectory contains executable files and description files for components that can be loaded as plugin modules.</td>
</tr>
<tr>
<td>arm\src</td>
<td>The arm\src subdirectory holds source files for some configurable library functions. This directory also holds the library source code and the source code for ELF utilities.</td>
</tr>
<tr>
<td>arm\tutor</td>
<td>The arm\tutor subdirectory contains the files used for the tutorials in the Information Center.</td>
</tr>
</tbody>
</table>

Table 4: The ARM directory (Continued)

THE COMMON DIRECTORY

The common directory contains subdirectories for components shared by all IAR Embedded Workbench products.

<table>
<thead>
<tr>
<th>Directory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>common\bin</td>
<td>The common\bin subdirectory contains executable files for components common to all IAR Embedded Workbench products, such as the editor and the graphical user interface components. The executable file for the IDE is also located here.</td>
</tr>
<tr>
<td>common\config</td>
<td>The common\config subdirectory contains files used by the IDE for settings in the development environment.</td>
</tr>
</tbody>
</table>

Table 5: The common directory
THE INSTALL-INFO DIRECTORY

The install-info directory contains metadata (version number, name, etc.) about the installed product components. Do not modify these files.

File types

The ARM versions of the IAR Systems development tools use the following default filename extensions to identify the produced files and other recognized file types:

<table>
<thead>
<tr>
<th>Ext.</th>
<th>Type of file</th>
<th>Output from</th>
<th>Input to</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>Library</td>
<td>iarchive</td>
<td>ILINK</td>
</tr>
<tr>
<td>asm</td>
<td>Assembler source code</td>
<td>Text editor</td>
<td>Assembler</td>
</tr>
<tr>
<td>bat</td>
<td>Windows command batch file</td>
<td>C-SPY</td>
<td>Windows</td>
</tr>
<tr>
<td>board</td>
<td>Configuration file for flash loader</td>
<td>Text editor</td>
<td>C-SPY</td>
</tr>
<tr>
<td>c</td>
<td>C source code</td>
<td>Text editor</td>
<td>Compiler</td>
</tr>
<tr>
<td>cfg</td>
<td>Syntax coloring configuration</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>chm</td>
<td>Online help system file</td>
<td>--</td>
<td>IDE</td>
</tr>
<tr>
<td>cpp</td>
<td>C++ source code</td>
<td>Text editor</td>
<td>Compiler</td>
</tr>
<tr>
<td>dat</td>
<td>Macros for formatting of STL containers</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>dbgdt</td>
<td>Debugger desktop settings</td>
<td>C-SPY</td>
<td>C-SPY</td>
</tr>
<tr>
<td>ddf</td>
<td>Device description file</td>
<td>Text editor</td>
<td>C-SPY</td>
</tr>
<tr>
<td>dep</td>
<td>Dependency information</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>dni</td>
<td>Debugger initialization file</td>
<td>C-SPY</td>
<td>C-SPY</td>
</tr>
<tr>
<td>ewd</td>
<td>Project settings for C-SPY</td>
<td>IDE</td>
<td>IDE</td>
</tr>
</tbody>
</table>

Table 6: File types
### File types

<table>
<thead>
<tr>
<th>Ext.</th>
<th>Type of file</th>
<th>Output from</th>
<th>Input to</th>
</tr>
</thead>
<tbody>
<tr>
<td>ewp</td>
<td>IAR Embedded Workbench project (current version)</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>ewplugin</td>
<td>IDE description file for plugin modules</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>eww</td>
<td>Workspace file</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>flash</td>
<td>Configuration file for flash loader</td>
<td>Text editor</td>
<td>C-SPY</td>
</tr>
<tr>
<td>fmt</td>
<td>Formatting information for the Locals and Watch windows</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>h</td>
<td>C/C++ or assembler header source</td>
<td>Text editor</td>
<td>Compiler or assembler</td>
</tr>
<tr>
<td></td>
<td>Help menu configuration file</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>html.htm</td>
<td>HTML document</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>i</td>
<td>Preprocessed source</td>
<td>Compiler</td>
<td>Compiler</td>
</tr>
<tr>
<td>i/t9</td>
<td>Device selection file</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>icf</td>
<td>Linker configuration file</td>
<td>Text editor</td>
<td>ILINK linker</td>
</tr>
<tr>
<td>inc</td>
<td>Assembler header source</td>
<td>Text editor</td>
<td>Assembler</td>
</tr>
<tr>
<td>ini</td>
<td>Project configuration</td>
<td>IDE</td>
<td>–</td>
</tr>
<tr>
<td>log</td>
<td>Log information</td>
<td>IDE</td>
<td>–</td>
</tr>
<tr>
<td>lst</td>
<td>List output</td>
<td>Compiler and assembler</td>
<td>–</td>
</tr>
<tr>
<td>mac</td>
<td>C-SPY macro definition</td>
<td>Text editor</td>
<td>C-SPY</td>
</tr>
<tr>
<td>menu</td>
<td>Device selection file</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>o</td>
<td>Object module</td>
<td>Compiler and assembler</td>
<td>ILINK</td>
</tr>
<tr>
<td>out</td>
<td>Target application</td>
<td>ILINK</td>
<td>EPROM, C-SPY, etc.</td>
</tr>
<tr>
<td>out</td>
<td>Target application with debug information</td>
<td>ILINK</td>
<td>C-SPY and other symbolic debuggers</td>
</tr>
<tr>
<td>pbd</td>
<td>Source browse information</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>pbi</td>
<td>Source browse information</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>psw</td>
<td>IAR Embedded Workbench project (old project format)</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>prj</td>
<td>IAR Embedded Workbench project (old project format)</td>
<td>IDE</td>
<td>IDE</td>
</tr>
</tbody>
</table>

Table 6: File types (Continued)
When you run the IDE, some files are created and located in dedicated directories under your project directory, by default $PROJ_DIR$/Debug, $PROJ_DIR$/Release, $PROJ_DIR$/settings, and the file *.dep under the installation directory. None of these directories or files affect the execution of the IDE, which means you can safely remove them if required.

### FILES WITH NON-DEFAULT FILENAME EXTENSIONS

In the IDE you can increase the number of recognized filename extensions using the **Filename Extensions** dialog box, available from the **Tools** menu. You can also connect your filename extension to a specific tool in the toolchain. See **Filename Extensions dialog box**, page 149.

To override the default filename extension from the command line, include an explicit extension when you specify a filename.

---

<table>
<thead>
<tr>
<th>Ext.</th>
<th>Type of file</th>
<th>Output from</th>
<th>Input to</th>
</tr>
</thead>
<tbody>
<tr>
<td>s</td>
<td>ARM assembler source code</td>
<td>Text editor</td>
<td>Assembler</td>
</tr>
<tr>
<td>svd</td>
<td>CMSIS System View Description</td>
<td>--</td>
<td>C-SPY</td>
</tr>
<tr>
<td>vsp</td>
<td>visualSTATE project files</td>
<td>IAR visualSTATE</td>
<td>IAR visualSTATE Designer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Designer</td>
<td>Designer and IAR Embedded Workbench IDE</td>
</tr>
<tr>
<td>wsdtn</td>
<td>Workspace desktop settings</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>xcl</td>
<td>Extended command line</td>
<td>Text editor</td>
<td>Assembler, compiler, linker</td>
</tr>
</tbody>
</table>

*Table 6: File types (Continued)*
IAR Embedded
Workbench IDE reference

This chapter contains reference information about the windows, menus, menu commands, and the corresponding components that are found in the IDE. This chapter contains the following sections:

- **Windows**, page 87
- **Menus**, page 100.

The IDE is a modular application. Which menus are available depends on which components are installed.

## Windows

The available windows are:

- IAR Embedded Workbench IDE window
- Workspace window
- Editor window
- Source Browser window
- Message windows.

In addition, a set of C-SPY®-specific windows becomes available when you start the debugger. For reference information about these windows, see the *C-SPY® Debugging Guide for ARM®*. 

IAR Embedded Workbench IDE window

The main window of the IDE is displayed when you launch the IDE.

The figure shows the window and its various components. The window might look different depending on which plugin modules you are using.

Menu bar

The menu bar contains:

**File**
Commands for opening source and project files, saving and printing, and exiting from the IDE.

**Edit**
Commands for editing and searching in editor windows and for enabling and disabling breakpoints in C-SPY.
For reference information about each menu, see Menus, page 100.

**Toolbar**

The IDE toolbar—available from the View menu—provides buttons for the most useful commands on the IDE menus, and a text box for typing a string to do a quick search.

For a description of any button, point to it with the mouse button. When a command is not available, the corresponding toolbar button is dimmed, and you will not be able to click it.

Figure 27: IDE toolbar

**Note:** When you start C-SPY, the Download and Debug button will change to a Make and Debug button and the Debug without Downloading will change to a Restart Debugger button.

**Status bar**

The status bar at the bottom of the window displays the number of errors and warnings generated during a build, the position of the insertion point in the editor window, and the state of the modifier keys. The status bar can be enabled from the View menu.
As you are editing, the status bar shows the current line and column number containing the insertion point, and the Caps Lock, Num Lock, and Overwrite status. A flag in the corner shows the language version you are using. Click the flag to change the language the next time you launch the IDE.

![Figure 28: IAR Embedded Workbench IDE window status bar](image)

**Editor window**

The editor window is opened when you open or create a text file in the IDE.

![Figure 29: Editor window](image)

Source code files and HTML files are displayed in editor windows. From an open HTML document, hyperlinks to HTML files work like in normal web browsing. A link
to an existing workspace file opens the workspace in the IDE, and closes any currently open workspace and the open HTML document.

You can have one or several editor windows open at the same time. On the Window menu you find commands for opening multiple editor windows, and commands for moving files between the editor windows.

The editor window is always docked, and its size and position depend on other currently open windows. If a file is read-only, a padlock icon is visible at the bottom left corner of the editor window.

For more information about using the editor, see Edit menu, page 103 and the .

**Source file paths**

The IDE supports relative source file paths to a certain degree.

If a source file is located in the project file directory or in any subdirectory of the project file directory, the IDE will use a path relative to the project file when accessing the source file.

**Window tabs**

The name of the open file is displayed on the tab. If a file has been modified after it was last saved, an asterisk appears after the filename on the tab, for example `Utilities.c*`.

A context menu appears if you right-click on a tab in the editor window.

![Figure 30: Editor window tab context menu](image)

These commands are available:

- **Save file** Saves the file.
- **Close** Closes the file.
- **Open Containing Folder** Opens the File Explorer that displays the directory where the selected file resides.
- **File Properties** Displays a standard file properties dialog box.

All open files are available from the drop-down menu in the upper right corner of the editor window.
Splitter controls

Use the Window>Split command—or the Splitter controls—to split the editor window horizontally or vertically into multiple panes.

Go to function

Click the Go to function button in the bottom left-hand corner of the editor window to list all functions of the C or C++ editor window.

![Go to Function window](image)

Figure 31: Go to Function window

Double-click the function that you want to show in the editor window.

Context menu

This context menu is available:

![Editor window context menu](image)

Figure 32: Editor window context menu
The contents of this menu depend on whether the debugger is started or not, and on the
C-SPY driver you are using. Typically, additional breakpoint types might be available
on this menu. For information about available breakpoints, see the C-SPY® Debugging
Guide for ARM®.

These commands are available:

- **Cut, Copy, Paste** Standard window commands.
- **Complete** Attempts to complete the word you have begun to type, basing
  the guess on the contents of the rest of the editor document.
- **Match Brackets** Selects all text between the brackets immediately surrounding
  the insertion point, increases the selection to the next hierarchic
  pair of brackets, or beeps if there is no higher bracket hierarchy.
- **Insert Template** Displays a list in the editor window from which you can choose
  a code template to be inserted at the location of the insertion
  point. If the code template you choose requires any field input,
  the **Template** dialog box appears; for information about this
  dialog box, see Template dialog box, page 112. For information
  about using code templates, see Using and adding code
templates, page 71.
- **Open "header.h"** Opens the header file header.h in an editor window. This menu
  command is only available if the insertion point is located on an
  #include line when you open the context menu.
- **Open Header/Source File** Jumps from the current file to the corresponding header or
  source file. If the destination file is not open when performing
  the command, the file will first be opened. This menu command
  is only available if the insertion point is located on any line
  except an #include line when you open the context menu.
  This command is also available from the **File>Open** menu.
- **Go to definition of symbol** Shows the declaration of the symbol where the insertion point
  is placed.
- **Check In** Commands for source code control; for more details, see
  Version Control System menu for SCC, page 51. These menu
  commands are only available if the current source file in the
  editor window is SCC-controlled. The file must also be a
  member of the current project.
<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle Breakpoint (Code)</td>
<td>Toggles a code breakpoint at the statement or instruction containing or close to the cursor in the source window. For information about code breakpoints, see the C-SPY® Debugging Guide for ARM®.</td>
</tr>
<tr>
<td>Toggle Breakpoint (Log)</td>
<td>Toggles a log breakpoint at the statement or instruction containing or close to the cursor in the source window. For information about log breakpoints, see the C-SPY® Debugging Guide for ARM®.</td>
</tr>
<tr>
<td>Toggle Breakpoint (Trace Start)</td>
<td>Toggles a Trace Start breakpoint. When the breakpoint is triggered, trace data collection starts. For information about Trace Start breakpoints, see the C-SPY® Debugging Guide for ARM®. Note that this menu command is only available if the C-SPY driver you are using supports trace.</td>
</tr>
<tr>
<td>Toggle Breakpoint (Trace Stop)</td>
<td>Toggles a Trace Stop breakpoint. When the breakpoint is triggered, trace data collection stops. For information about Trace Stop breakpoints, see the C-SPY® Debugging Guide for ARM®. Note that this menu command is only available if the C-SPY driver you are using supports trace.</td>
</tr>
<tr>
<td>Enable/disable Breakpoint</td>
<td>Toggles a breakpoint between being disabled, but not actually removed—making it available for future use—and being enabled again.</td>
</tr>
<tr>
<td>Set Data Breakpoint for 'variable'</td>
<td>Toggles a data breakpoint on variables with static storage duration. Requires support in the C-SPY driver you are using.</td>
</tr>
<tr>
<td>Find in Trace</td>
<td>Searches the content of the Trace window for occurrences of the given location—the position of the insertion point in the source code—and reports the result in the Find in Trace window. This menu command requires support for Trace in the C-SPY driver you are using, see the C-SPY® Debugging Guide for ARM®.</td>
</tr>
<tr>
<td>Edit Breakpoint</td>
<td>Displays the Edit Breakpoint dialog box to let you edit the breakpoint available on the source code line where the insertion point is located. If there is more than one breakpoint on the line, a submenu is displayed that lists all available breakpoints on that line.</td>
</tr>
<tr>
<td>Set Next Statement</td>
<td>Sets the PC directly to the selected statement or instruction without executing any code. Use this menu command with care. This menu command is only available when you are using the debugger.</td>
</tr>
</tbody>
</table>
Editor shortcut key summary

The following tables summarize the editor’s shortcut keys.

### Moving the insertion point:

<table>
<thead>
<tr>
<th>To move the insertion point</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>One character left</td>
<td>Arrow left</td>
</tr>
<tr>
<td>One character right</td>
<td>Arrow right</td>
</tr>
<tr>
<td>One word left</td>
<td>Ctrl+Arrow left</td>
</tr>
<tr>
<td>One word right</td>
<td>Ctrl+Arrow right</td>
</tr>
<tr>
<td>One line up</td>
<td>Arrow up</td>
</tr>
<tr>
<td>One line down</td>
<td>Arrow down</td>
</tr>
<tr>
<td>To the start of the line</td>
<td>Home</td>
</tr>
<tr>
<td>To the end of the line</td>
<td>End</td>
</tr>
<tr>
<td>To the first line in the file</td>
<td>Ctrl+Home</td>
</tr>
<tr>
<td>To the last line in the file</td>
<td>Ctrl+End</td>
</tr>
</tbody>
</table>

*Table 7: Editor keyboard commands for insertion point navigation*

### Scrolling text:

<table>
<thead>
<tr>
<th>To scroll</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up one line</td>
<td>Ctrl+Arrow up</td>
</tr>
<tr>
<td>Down one line</td>
<td>Ctrl+Arrow down</td>
</tr>
</tbody>
</table>

*Table 8: Editor keyboard commands for scrolling*
Build window

The Build window is available by choosing View>Messages.

![Build window](image)

The Build window displays the messages generated when building a build configuration. When opened, this window is, by default, grouped together with the other
message windows, see Windows, page 87. Double-click a message in the Build window to open the appropriate file for editing, with the insertion point at the correct position.

**Context menu**

This context menu is available:

![Build window context menu](image)

Figure 34: Build window context menu

These commands are available:

- **Copy** Copies the contents of the window.
- **Select All** Selects the contents of the window.
- **Clear All** Deletes the contents of the window.
- **Options** Opens the Messages page of the IDE options dialog box. On this page you can set options related to messages; see Messages options, page 135.

**Find in Files window**

The Find in Files window is available by choosing View>Messages.

![Find in Files window](image)

Figure 35: Find in Files window (message window)

The Find in Files window displays the output from the Edit>Find and Replace>Find in Files command. When opened, this window is, by default, grouped together with the other message windows, see Windows, page 87.
Double-click an entry in the window to open the appropriate file with the insertion point positioned at the correct location. That source location is highlighted with a blue flag icon.

**Context menu**

This context menu is available:

![Context menu](image)

*Figure 36: Find in Files window context menu*

These commands are available:

- **Copy**  
  Copies the contents of the window.
- **Select All**  
  Selects the contents of the window.
- **Clear All**  
  Deletes the contents of the window and any blue flag icons in the left-side margin of the editor window.

**Tool Output window**

The Tool Output window is available by choosing `View > Messages > Tool Output`.

![Tool Output window](image)

*Figure 37: Tool Output window (message window)*

The Tool Output window displays any messages output by user-defined tools in the `Tools` menu, provided that you have selected the option `Redirect to Output Window` in the `Configure Tools` dialog box; see `Configure Tools dialog box`, page 146. When opened, this window is, by default, grouped together with the other message windows, see `Windows`, page 87.
Context menu

This context menu is available:

![Context menu]

*Figure 38: Tool Output window context menu*

These commands are available:

- **Copy**: Copies the contents of the window.
- **Select All**: Selects the contents of the window.
- **Clear All**: Deletes the contents of the window.

Debug Log window

The Debug Log window is available by choosing **View > Messages > Debug Log**.

*Figure 39: Debug Log window (message window)*

The Debug Log window displays debugger output, such as diagnostic messages and trace information. When opened, this window is, by default, grouped together with the other message windows, see **Windows**, page 87.

Double-click any rows in one of the following formats to display the corresponding source code in the editor window:

```plaintext
<path> (<row>):<message>
<path> (<row>,<column>):<message>
```
Menus

The available menus are:

- File menu
- Edit menu
- View menu
- Project menu
- Tools menu
- Window menu
- Help menu.

In addition, a set of C-SPY-specific menus become available when you start the debugger. For reference information about these menus, see the C-SPY® Debugging Guide for ARM®.

File menu

The File menu provides commands for opening workspaces and source files, saving and printing, and exiting from the IDE.
The menu also includes a numbered list of the most recently opened files and workspaces. To open one of them, choose it from the menu.

![Figure 41: File menu](image)

These commands are available:

- **New**
  - Ctrl+N
  - Displays a submenu with commands for creating a new workspace, or a new text file.

- **Open>File**
  - Ctrl+O
  - Displays a submenu from which you can select a text file or an HTML document to open. See *Editor window*, page 90.

- **Open>Workspace**
  - Displays a submenu from which you can select a workspace file to open. Before a new workspace is opened you will be prompted to save and close any currently open workspaces.

- **Open>Header/Source File**
  - Ctrl+Shift+H
  - Opens the header file or source file that corresponds to the current file, and jumps from the current file to the newly opened file. This command is also available from the context menu available from the editor window.

- **Close**
  - Closes the active window. You will be given the opportunity to save any files that have been modified before closing.
**Open Workspace**
Displays a dialog box where you can open a workspace file.

You will be given the opportunity to save and close any currently open workspace file that has been modified before opening a new workspace.

**Save Workspace**
Saves the current workspace file.

**Close Workspace**
Closes the current workspace file.

**Save**
Ctrl+S
Saves the current text file or workspace file.

**Save As**
Displays a dialog box where you can save the current file with a new name.

**Save All**
Saves all open text documents and workspace files.

**Page Setup**
Displays a dialog box where you can set printer options.

**Print**
Ctrl+P
Displays a dialog box where you can print a text document.

**Recent Files**
Displays a submenu where you can quickly open the most recently opened text documents.

**Recent Workspaces**
Displays a submenu where you can quickly open the most recently opened workspace files.

**Exit**
Exits from the IDE. You will be asked whether to save any changes to text files before closing them. Changes to the project are saved automatically.
Edit menu

The Edit menu provides commands for editing and searching.

These commands are available:

- **Undo** Ctrl+Z
  - Undoes the last edit made to the current editor window.

- **Redo** Ctrl+Y
  - Redoes the last Undo in the current editor window.
  - You can undo and redo an unlimited number of edits independently in each editor window.

- **Cut** Ctrl+X
  - The standard Windows command for cutting text in editor windows and text boxes.

- **Copy** Ctrl+C
  - The standard Windows command for copying text in editor windows and text boxes.

- **Paste** Ctrl+V
  - The standard Windows command for pasting text in editor windows and text boxes.

- **Paste Special**
  - Provides you with a choice of the most recent contents of the clipboard to choose from when pasting in editor documents.
Select All
Ctrl+A
Selects all text in the active editor window.

Find and Replace>Find
Ctrl+F
Displays the Find dialog box where you can search for text within the current editor window; see Find dialog box, page 107. Note that if the insertion point is located in the Memory window when you choose the Find command, the dialog box will contain a different set of options than otherwise. If the insertion point is located in the Trace window when you choose the Find command, the Find in Trace dialog box is opened; the contents of this dialog box depend on the C-SPY driver you are using, see the C-SPY® Debugging Guide for ARM® for more information.

Find and Replace>Find Next
F3
Finds the next occurrence of the specified string.

Find and Replace>Find Previous
Shift+F3
Finds the previous occurrence of the specified string.

Find and Replace>Find Next
(Selected)
Ctrl+F3
Searches for the next occurrence of the currently selected text or the word currently surrounding the insertion point.

Find and Replace>Find Previous (Selected)
Ctrl+Shift+F3
Searches for the previous occurrence of the currently selected text or the word currently surrounding the insertion point.

Find and Replace>Replace
Ctrl+H
Displays a dialog box where you can search for a specified string and replace each occurrence with another string; see Replace dialog box, page 108. Note that if the insertion point is located in the Memory window when you choose the Replace command, the dialog box will contain a different set of options than otherwise.

Find and Replace>Find in Files
Displays a dialog box where you can search for a specified string in multiple text files; see Find in Files dialog box, page 109.

Find and Replace>Incremental Search
Ctrl+I
Displays a dialog box where you can gradually fine-tune or expand the search by continuously changing the search string; see Incremental Search dialog box, page 111.
Navigate>Go To Ctrl+G
Displays the Go to Line dialog box where you can move the insertion point to a specified line and column in the current editor window.

Navigate>Toggle Bookmark Ctrl+F2
Toggles a bookmark at the line where the insertion point is located in the active editor window.

Navigate>Go to Bookmark F2
Moves the insertion point to the next bookmark that has been defined with the Toggle Bookmark command.

Navigate>Navigate Backward Alt+Left Arrow
Navigates backward in the insertion point history. The current position of the insertion point is added to the history by actions like Go to definition and clicking on a result from the Find in Files command.

Navigate>Navigate Forward Alt+Right Arrow
Navigates forward in the insertion point history. The current position of the insertion point is added to the history by actions like Go to definition and clicking on a result from the Find in Files command.

Navigate>Go to Definition F12
Shows the declaration of the selected symbol or the symbol where the insertion point is placed. This menu command is available when browse information has been enabled, see Project options, page 137.

Code Templates>Insert Template Ctrl+Shift+Space
Displays a list in the editor window from which you can choose a code template to be inserted at the location of the insertion point. If the code template you choose requires any field input, the Template dialog box appears; see Template dialog box, page 112. For information about using code templates, see Using and adding code templates, page 71.

Code Templates>Edit Templates
Opens the current code template file, where you can modify existing code templates and add your own code templates. For information about using code templates, see Using and adding code templates, page 71.

Next Error/Tag F4
If the message window contains a list of error messages or the results from a Find in Files search, this command displays the next item from that list in the editor window.
### Previous Error/Tag
Shift+F4
If the message window contains a list of error messages or the results from a **Find in Files** search, this command displays the previous item from that list in the editor window.

### Complete
Ctrl+Space
Attempts to complete the word you have begun to type, basing the guess on the contents of the rest of the editor document.

### Match Brackets
Selects all text between the brackets immediately surrounding the insertion point, increases the selection to the next hierarchic pair of brackets, or beeps if there is no higher bracket hierarchy.

### Auto Indent
Ctrl+T
Indents one or several lines you have selected in a C/C++ source file. To configure the indentation, see *Configure Auto Indent dialog box*, page 130.

### Block Comment
Ctrl+K
Places the C++ comment character sequence `//` at the beginning of the selected lines.

### Block Uncomment
Ctrl+K
Removes the C++ comment character sequence `//` from the beginning of the selected lines.

### Toggle Breakpoint
F9
Toggles a breakpoint at the statement or instruction that contains or is located near the cursor in the source window.

### Enable/Disable Breakpoint
Ctrl+F9
Toggles a breakpoint between being disabled, but not actually removed—making it available for future use—and being enabled again.
The **Find** dialog box is available from the **Edit** menu.

![Find dialog box](image)

**Find** dialog box

Note that the contents look different if you search in an editor window compared to if you search in the Memory window.

- **Find what**: Specify the text to search for.
- **Match case**: Searches only for occurrences that exactly match the case of the specified text. Otherwise, specifying `int` will also find `INT` and `Int`. This option is only available when you search in an editor window.
- **Match whole word**: Searches for the specified text only if it occurs as a separate word. Otherwise, specifying `int` will also find `print`, `sprintf` etc. This option is only available when you search in an editor window.
- **Search as hex**: Searches for the specified hexadecimal value. This option is only available when you search in the Memory window.
- **Find next**: Searches for the next occurrence of the selected text.
- **Find previous**: Searches for the previous occurrence of the selected text.
- **Stop**: Stops an ongoing search. This button is only available during a search in the Memory window.
Replace dialog box

The Replace dialog box is available from the Edit menu.

![Replace dialog box](image)

Note that the contents look different if you search in an editor window compared to if you search in the Memory window.

- **Find what**: Specify the text to search for.
- **Replace with**: Specify the text to replace each found occurrence with.
- **Match case**: Searches only for occurrences that exactly match the case of the specified text. Otherwise, specifying `int` will also find `INT` and `Int`. This option is only available when you search in an editor window.
- **Match whole word**: Searches for the specified text only if it occurs as a separate word. Otherwise, `int` will also find `print`, `sprintf`, etc. This option is only available when you search in an editor window.
- **Search as hex**: Searches for the specified hexadecimal value. This option is only available when you perform the search in the Memory window.
- **Find next**: Searches for the next occurrence of the text you have specified.
- **Replace**: Replaces the searched text with the specified text.
- **Replace all**: Replaces all occurrences of the searched text in the current editor window.
Find in Files dialog box

The Find in Files dialog box is available from the Edit menu.

The result of the search appears in the Find in Files message window—available from the View menu. You can then go to each occurrence by choosing the Edit>Next Error/Tag command, alternatively by double-clicking the messages in the Find in Files message window. This opens the corresponding file in an editor window with the insertion point positioned at the start of the specified text. A blue flag in the left-hand margin indicates the line.

Find what

Specify the string you want to search for or a regular expression. You can narrow the search down with one or more of these conditions:

Match case  Searches only for occurrences that exactly match the case of the specified text. Otherwise, specifying int will also find INT and Int.

Match whole word  Searches only for the string when it occurs as a separate word (short cut &w). Otherwise, int will also find print, sprintf and so on.
Menus

**Look in**

Specify which files you want to search in. Choose between:

- **For all projects in workspace**
  Searches all projects in the workspace, not just the active project.

- **Project files**
  Searches all files that you have explicitly added to your project.

- **Project files and user include files**
  Searches all files that you have explicitly added to your project and all files that they include, except the include files in the IAR Embedded Workbench installation directory.

- **Project files and all include files**
  Searches all project files that you have explicitly added to your project and all files that they include.

- **Directory**
  Searches the directory that you specify. Recent search locations are saved in the drop-down list. Locate the directory using the browse button.

- **Look in subdirectories**
  Searches the directory that you have specified and all its subdirectories.

**File types**

A filter for choosing which type of files to search; the filter applies to all **Look in** settings. Choose the appropriate filter from the drop-down list. The text field is editable, to let you add your own filters. Use the * character to indicate zero or more unknown characters of the filters, and the ? character to indicate one unknown character.

**Stop**

Stops an ongoing search. This button is only available during an ongoing search.
Incremental Search dialog box

The Incremental Search dialog box is available from the Edit menu.

![Incremental Search dialog box](image)

*Figure 46: Incremental Search dialog box*

Use this dialog box to gradually fine-tune or expand the search string.

**Find What**

Type the string to search for. The search is performed from the location of the insertion point—the start point. Every character you add to or remove from the search string instantly changes the search accordingly. If you remove a character, the search starts over again from the start point.

If a word in the editor window is selected when you open the Incremental Search dialog box, this word will be displayed in the Find What text box.

**Match Case**

Searches for occurrences that exactly match the case of the specified text. Otherwise, searching for `int` will also find `INT` and `Int`.

**Find Next**

Searches for the next occurrence of the current search string. If the Find What text box is empty when you click the Find Next button, a string to search for will automatically be selected from the drop-down list. To search for this string, click Find Next.

**Close**

Closes the dialog box.
Template dialog box

The Template dialog box appears when you insert a code template that requires any field input.

Note: The figure reflects the default code template that can be used for automatically inserting code for a for loop.

Text fields

Specify the required input in the text fields. Which fields that appear depends on how the code template is defined.

Display area

The display area shows the code that would result from the code template, using the values you submit.

For more information about using code templates, see Using and adding code templates, page 71.

View menu

The View menu provides several commands for opening windows and displaying toolbars in the IDE. When the debugger is running you can also open debugger-specific
windows from this menu. See the *C-SPY® Debugging Guide for ARM®* for information about these.

![View menu](image)

*Figure 48: View menu*

These commands are available:

- **Messages**
  Displays a submenu which gives access to the message windows—Build, Find in Files, Tool Output, Debug Log—that display messages and text output from the IAR Embedded Workbench commands. If the window you choose from the menu is already open, it becomes the active window.

- **Workspace**
  Opens the current Workspace window, see *Workspace window*, page 41.

- **Source Browser**
  Opens the Source Browser window, see *Source Browser window*, page 48.

- **Breakpoints**
  Opens the Breakpoints window, see the *C-SPY® Debugging Guide for ARM®*.

- **Disassembly window**
  Opens the Disassembly window. Only available when the debugger is running.

- **Memory window**
  Opens the Memory window. Only available when the debugger is running.

- **Symbolic Memory window**
  Opens the Symbolic Memory window. Only available when the debugger is running.

- **Register window**
  Opens the Register window. Only available when the debugger is running.

- **Watch window**
  Opens the Watch window. Only available when the debugger is running.

- **Locals window**
  Opens the Locals window. Only available when the debugger is running.
### Menus

<table>
<thead>
<tr>
<th>Window</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Statics window</td>
<td>Opens the Statics window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Auto window</td>
<td>Opens the Auto window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Live Watch window</td>
<td>Opens the Live Watch window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Quick Watch window</td>
<td>Opens the Quick Watch window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Call Stack window</td>
<td>Opens the Call Stack window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Terminal I/O window</td>
<td>Opens the Terminal I/O window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Code Coverage window</td>
<td>Opens the Code Coverage window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Profiling window</td>
<td>Opens the Profiling window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Stack window</td>
<td>Opens the Stack window. Only available when the debugger is running.</td>
</tr>
<tr>
<td>Toolbars</td>
<td>The options <strong>Main</strong> and <strong>Debug</strong> toggle the two toolbars on or off.</td>
</tr>
<tr>
<td>Status bar</td>
<td>Toggles the status bar on or off.</td>
</tr>
</tbody>
</table>

**IDE Project Management and Building Guide for ARM**

114
Project menu

The **Project** menu provides commands for working with workspaces, projects, groups, and files, and for specifying options for the build tools, and running the tools on the current project.

| Add Files... | Displays a dialog box where you can select which files to include in the current project. |
| Add Group... |
| Create Project... |
| Edit Configurations... |

**Screws**

- Create New Project...
- Add Existing Project...
- Options... [ALT+F7]

**Version Control System**

<table>
<thead>
<tr>
<th>Make</th>
<th>F7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compile</td>
<td>CTRL+F7</td>
</tr>
<tr>
<td>Rebuild All</td>
<td></td>
</tr>
<tr>
<td>Clear</td>
<td></td>
</tr>
<tr>
<td>Batch build...</td>
<td>F8</td>
</tr>
</tbody>
</table>

**Start Debugging**

- Download and Debug [CTRL+D]
- Debug without Downloading
- Manual Download Debugger [CTRL+R]
- Manual Download [CTRL+SHIFT+F10]
- Download

**Open Service File**

*Figure 49: Project menu*

These commands are available:

**Add Files**

Displays a dialog box where you can select which files to include in the current project.

**Add Group**

Displays a dialog box where you can create a new group. In the **Group Name** text box, specify the name of the new group. For more information about groups, see **Groups**, page 33.
Import File List Displays a standard Open dialog box where you can import information about files and groups from projects created using another IAR Systems toolchain.

To import information from project files which have one of the older filename extensions .pew or .prj you must first have exported the information using the context menu command Export File List available in your current IAR Embedded Workbench.

Edit Configurations Displays the Configurations for project dialog box, where you can define new or remove existing build configurations. See Configurations for project dialog box, page 46.

Remove In the Workspace window, removes the selected item from the workspace.

Create New Project Displays the Create New Project dialog box where you can create a new project and add it to the workspace; see Create New Project dialog box, page 45.

Add Existing Project Displays a standard Open dialog box where you can add an existing project to the workspace.

Options Displays the Options dialog box, where you can set options for the build tools, for the selected item in the Workspace window; see Options dialog box, page 119. You can set options for the entire project, for a group of files, or for an individual file.

Version Control System Displays a submenu with commands for version control, see Version Control System menu for SCC, page 51.

Make Brings the current build configuration up to date by compiling, assembling, and linking only the files that have changed since the last build.
**Compile**  
**Ctrl+F7**  
Compiles or assembles the currently selected file, files, or group.

One or more files can be selected in the Workspace window—all files in the same project, but not necessarily in the same group. You can also select the editor window containing the file you want to compile. The **Compile** command is only enabled if all files in the selection can be compiled or assembled.

You can also select a group, in which case the command is applied to each file in the group (including inside nested groups) that can be compiled, even if the group contains files that cannot be compiled, such as header files.

If the selected file is part of a multi-file compilation group, the command will still only affect the selected file.

**Rebuild All**  
Rebuilds and relinks all files in the current target.

**Clean**  
Removes any intermediate files.

**Batch Build**  
**F8**  
Displays the **Batch Build** dialog box where you can configure named batch build configurations, and build a named batch. See **Batch Build dialog box**, page 122.

**Stop Build**  
**Ctrl+Break**  
Stops the current build operation.

**Download and Debug**  
**Ctrl+D**  
Downloads the application and starts C-SPY so that you can debug the project object file. If necessary, a make will be performed before running C-SPY to ensure the project is up to date. This command is not available during debugging.

**Debug without Downloading**  
Starts C-SPY so that you can debug the project object file. This menu command is a shortcut for the **Suppress Download** option available on the **Download** page. The **Debug without Downloading** command is not available during debugging.

**Make & Restart Debugger**  
Stops C-SPY, makes the active build configuration, and starts the debugger again; all in a single command. This command is only available during debugging.

**Restart Debugger**  
Stops C-SPY and starts the debugger again; all in a single command. This command is only available during debugging.
Menus

**Download**

Commands for flash download and erase. Choose between these commands:

**Download active application** downloads the active application to the target without launching a full debug session. The result is roughly equivalent to launching a debug session but exiting it again before the execution starts.

**Download file** opens a standard Open dialog box where you can specify a file to be downloaded to the target system without launching a full debug session.

**Erase memory** erases all parts of the flash memory.

If your .board file specifies only one flash memory, a simple confirmation dialog box is displayed where you confirm the erasure. However, if your .board file specifies two or more flash memories, the **Erase Memory** dialog box is displayed. See **Erase Memory dialog box**, page 118.

**Open Device File**

Opens a submenu with commands for opening the active file that contains a device description or SFR definitions.

**Erase Memory dialog box**

The **Erase Memory** dialog box is displayed when you have chosen **Project>Download>Erase Memory** and your flash memory system configuration file (filename extension .board) specifies two or more flash memories.

![Erase Memory dialog box](image)

**Figure 50: Erase Memory dialog box**
Use this dialog box to erase one or more of the flash memories.

**Display area**

Each line lists the path to the flash memory device configuration file (filename extension `.flash`) and the associated memory range. Select the memory you want to erase.

**Buttons**

These buttons are available:

- **Erase all** All memories listed in the dialog box are erased, regardless of individually selected lines.
- **Erase** Erases the selected memories.
- **Cancel** Closes the dialog box.

**Options dialog box**

The **Options** dialog box is available from the **Project** menu.

![Options dialog box](image)
Use this dialog box to specify your project settings.

**Category**

Selects the build tool you want to set options for. The available categories will depend on the tools installed in your IAR Embedded Workbench IDE, and will typically include:

- **General Options**: General options, see *General options*, page 155.
- **C/C++ Compiler**: IAR C/C++ Compiler options, see *Compiler options*, page 163.
- **Assembler**: IAR Assembler options, see *Assembler options*, page 179.
- **Output Converter**: Options for converting ELF output to Motorola, Intel-standard, or other simple formats, see *Output converter options*, page 187.
- **Custom Build**: Options for extending the toolchain, see *Custom build options*, page 189.
- **Build Actions**: Options for pre-build and post-build actions, see *Build actions options*, page 191.
- **Linker**: Linker options, see *Linker options*, page 193. This category is available for application projects.
- **Library Builder**: Library builder options, see *Library builder options*, page 205. This category is available for library projects.
- **Debugger**: IAR C-SPY Debugger options, see the *C-SPY® Debugging Guide for ARM®*.
- **Simulator**: Simulator-specific options, see the *C-SPY® Debugging Guide for ARM®*.
- **C-SPY hardware drivers**: Options specific to additional hardware debuggers, see the *C-SPY® Debugging Guide for ARM®*.

Selecting a category displays one or more pages of options for that component of the IDE.

**Factory Settings**

Restores all settings to the default factory settings.
## Argument variables

On many of the pages in the Options dialog box, you can use argument variables for paths and arguments:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$CONFIG_NAME$</td>
<td>The name of the current build configuration, for example Debug or Release.</td>
</tr>
<tr>
<td>$CUR_DIR$</td>
<td>Current directory</td>
</tr>
<tr>
<td>$CUR_LINE$</td>
<td>Current line</td>
</tr>
<tr>
<td>$DATE$</td>
<td>Today’s date</td>
</tr>
<tr>
<td>$EW_DIR$</td>
<td>Top directory of IAR Embedded Workbench, for example c:\program files\iar systems\embedded workbench 6.n</td>
</tr>
<tr>
<td>$EXE_DIR$</td>
<td>Directory for executable output</td>
</tr>
<tr>
<td>$FILE_BNAME$</td>
<td>Filename without extension</td>
</tr>
<tr>
<td>$FILE_BPATH$</td>
<td>Full path without extension</td>
</tr>
<tr>
<td>$FILE_DIR$</td>
<td>Directory of active file, no filename</td>
</tr>
<tr>
<td>$FILE_FNAME$</td>
<td>Filename of active file without path</td>
</tr>
<tr>
<td>$FILE_PATH$</td>
<td>Full path of active file (in Editor, Project, or Message window)</td>
</tr>
<tr>
<td>$LIST_DIR$</td>
<td>Directory for list output</td>
</tr>
<tr>
<td>$OBJ_DIR$</td>
<td>Directory for object output</td>
</tr>
<tr>
<td>$PROJ_DIR$</td>
<td>Project directory</td>
</tr>
<tr>
<td>$PROJ_FNAME$</td>
<td>Project filename without path</td>
</tr>
<tr>
<td>$PROJ_PATH$</td>
<td>Full path of project file</td>
</tr>
<tr>
<td>$TARGET_DIR$</td>
<td>Directory of primary output file</td>
</tr>
<tr>
<td>$TARGET_BNAME$</td>
<td>Filename without path of primary output file and without extension</td>
</tr>
<tr>
<td>$TARGET_BPATH$</td>
<td>Full path of primary output file without extension</td>
</tr>
<tr>
<td>$TARGET_FNAME$</td>
<td>Filename without path of primary output file</td>
</tr>
<tr>
<td>$TARGET_PATH$</td>
<td>Full path of primary output file</td>
</tr>
<tr>
<td>$TOOLKIT_DIR$</td>
<td>Directory of the active product, for example c:\program files\iar systems\embedded workbench 6.n\arm</td>
</tr>
<tr>
<td>$USER_NAME$</td>
<td>Your host login name</td>
</tr>
<tr>
<td>$<em>ENVVAR</em>$</td>
<td>The environment variable ENVVAR. Any name within $ and _ will be expanded to that system environment variable.</td>
</tr>
</tbody>
</table>

*Table 10: Argument variables*
Argument variables can also be used on some pages in the IDE Options dialog box, see Tools menu, page 124.

**Batch Build dialog box**

The Batch Build dialog box is available by choosing Project>Batch build.

![Batch Build dialog box](image)

This dialog box lists all defined batches of build configurations. For more information, see Building multiple configurations in a batch, page 61.

**Batches**

Select the batch you want to build from this list of currently defined batches of build configurations.

**Build**

Give the build command you want to execute:

- Make
- Clean
- Rebuild All.

**New**

Displays the Edit Batch Build dialog box, where you can define new batches of build configurations; see Edit Batch Build dialog box, page 123.
Remove

Removes the selected batch.

Edit

Displays the Edit Batch Build dialog box, where you can edit existing batches of build configurations.

**Edit Batch Build dialog box**

The Edit Batch Build dialog box is available from the Batch Build dialog box.

![Edit Batch Build dialog box](image)

Use this dialog box to create new batches of build configurations, and edit already existing batches.

**Name**

Type a name for a batch that you are creating, or change the existing name (if you wish) for a batch that you are editing.

**Available configurations**

Select the configurations you want to move to be included in the batch you are creating or editing, from this list of all build configurations that belong to the workspace.

To move a build configuration from the Available configurations list to the Configurations to build list, use the arrow buttons.
**Configurations to build**

Lists the build configurations that will be included in the batch you are creating or editing. Drag the build configurations up and down to set the order between the configurations.

**Tools menu**

The **Tools** menu provides commands for customizing the environment, such as changing common fonts and shortcut keys.

It is a user-configurable menu to which you can add tools for use with IAR Embedded Workbench. Thus, it might look different depending on which tools you have preconfigured to appear as menu items.

![Figure 54: Tools menu](image)

These commands are available:

- **Options** displays the IDE Options dialog box where you can customize the IDE.
- **Configure Tools** displays the Configure Tools dialog box where you can set up the interface to use external tools; see Configure Tools dialog box, page 146.
- **Filename Extensions** displays the Filename Extensions dialog box where you can define the filename extensions to be accepted by the build tools; see Filename Extensions dialog box, page 149.
- **Configure Viewers** displays the Configure Viewers dialog box where you can configure viewer applications to open documents with; see Configure Viewers dialog box, page 151.
- **Notepad** user-configured. This is an example of a user-configured addition to the Tools menu.
Common Fonts options

The Common Fonts options are available by choosing Tools>Options.

Use this page to configure the fonts used for all project windows except the editor windows.

For information about how to change the font in the editor windows, see Editor Colors and Fonts options, page 134.

Fixed Width Font

Selects which font to use in the Disassembly, Register, and Memory windows.

Proportional Width Font

Selects which font to use in all windows except the Disassembly, Register, Memory, and editor windows.
**Key Bindings options**

The Key Bindings options are available by choosing Tools>Options.

Figure 56: Key Bindings options

Use this page to customize the shortcut keys used for the IDE menu commands.

**Menu**

Selects the menu to be edited. Any currently defined shortcut keys for the selected menu are listed below the Menu drop-down list.

**List of commands**

Selects the menu command you want to configure your own shortcut keys for, from this list of all commands available on the selected menu.

**Press shortcut key**

Type the key combination you want to use as shortcut key for the selected command. You cannot set or add a shortcut if it is already used by another command.

**Primary**

Choose to:

- **Set** Saves the key combination in the Press shortcut key field as a shortcut for the selected command in the list.
- **Clear** Removes the listed primary key combination as a shortcut for the selected command in the list.
The new shortcut will be displayed next to the command on the menu.

**Alias**

Choose to:

- **Add** Saves the key combination in the **Press shortcut key** field as an alias—a hidden shortcut—for the selected command in the list.
- **Clear** Removes the listed alias key combination as a shortcut for the selected command in the list.

The new shortcut will be not displayed next to the command on the menu.

**Reset All**

Reverts the shortcuts for all commands to the factory settings.

**Language options**

The **Language** options are available by choosing **Tools>Options**.

![Language options](image)

*Figure 57: Language options*

Use this page to specify the language to be used in windows, menus, dialog boxes, etc.
Language

Selects the language to be used. In the IDE, **English (United States)** and **Japanese** are available.

**Note:** If you have installed IAR Embedded Workbench for several different toolchains in the same directory, the IDE might be in mixed languages if the toolchains are available in different languages.

Editor options

The **Editor** options are available by choosing **Tools>Options**.

![Figure 58: Editor options](image)

Use this page to configure the editor.

For more information about the editor, see **Editing**, page 67.

Tab size

Specify how wide a tab character is, in terms of character spaces.

Indent size

Specify the number of spaces to be used when tabulating with an indentation.
Tab Key Function

Controls what happens when you press the Tab key. Choose between:

- **Insert tab**: Inserts a tab character when the Tab key is pressed.
- **Indent with spaces**: Inserts an indentation (space characters) when the Tab key is pressed.

EOL character

Selects which line break character to be used when editor documents are saved. Choose between:

- **PC (default)**: Windows and DOS end of line characters.
- **Unix**: UNIX end of line characters.
- **Preserve**: The same end of line character as the file had when it was opened, either PC or UNIX. If both types or neither type are present in the opened file, PC end of line characters are used.

Show right margin

Displays the area of the editor window outside the right margin as a light gray field. If this option is selected, you can set the width of the text area between the left margin and the right margin. Choose to set the width based on:

- **Printing edge**: Bases the width on the printable area, which is taken from the general printer settings.
- **Columns**: Bases the width based on the number of columns.

Syntax highlighting

Makes the editor display the syntax of C or C++ applications in different text styles. To read more about syntax highlighting, see Editor Colors and Fonts options, page 134, and Syntax coloring, page 70.

Auto indent

Makes the editor indent the new line automatically when you press Return. For C/C++ source files, click the Configure button to configure the automatic indentation; see Configure Auto Indent dialog box, page 130. For all other text files, the new line will have the same indentation as the previous line.
Show line numbers

Makes the editor display line numbers in the editor window.

Scan for changed files

Makes the editor reload files that have been modified by another tool.

If a file is open in the IDE, and the same file has concurrently been modified by another tool, the file will be automatically reloaded in the IDE. However, if you already started to edit the file, you will be prompted before the file is reloaded.

Show bookmarks

Makes the editor display a column on the left side in the editor window, with icons for compiler errors and warnings, Find in Files results, user bookmarks, and breakpoints.

Enable virtual space

Allows the insertion point to move outside the text area.

Remove trailing blanks

Removes trailing blanks from files when they are saved to disk. Trailing blanks are blank spaces between the last non-blank character and the end of line character.

Configure Auto Indent dialog box

The Configure Auto Indent dialog box is available from the IDE Options dialog box.

Use this dialog box to configure the editor’s automatic indentation of C/C++ source code.
To read more about indentation, see *Automatic text indentation*, page 70.

**To open the Configure Auto Indent dialog box:**

1. Choose *Tools>*Options.
2. Open the *Editor* page.
3. Select the *Auto indent* option and click the *Configure* button.

**Opening Brace (a)**

Specify the number of spaces used for indenting an opening brace.

**Body (b)**

Specify the number of additional spaces used for indenting code after an opening brace, or a statement that continues onto a second line.

**Label (c)**

Specify the number of additional spaces used for indenting a label, including case labels.

**Sample code**

This area reflects the settings made in the text boxes for indentation. All indentations are relative to the preceding line, statement, or other syntactic structures.

**External Editor options**

The *External Editor* options are available by choosing *Tools>*Options.

![External Editor options](image)
Use this page to specify an external editor of your choice.

**Note:** The contents of this dialog box depends on the setting of the **Type** option.

See also *Using an external editor*, page 75.

**Use External Editor**

Enables the use of an external editor.

**Type**

Selects the type of interface. Choose between:

- **Command Line**
- **DDE** (Windows Dynamic Data Exchange).

**Editor**

Specify the filename and path of your external editor. A browse button is available for your convenience.

**Arguments**

Specify any arguments to be passed to the editor. This is only applicable if you have selected **Command Line** as the interface type, see *Type*, page 132.

**Service**

Specify the DDE service name used by the editor. This is only applicable if you have selected **DDE** as the interface type, see *Type*, page 132.

The service name depends on the external editor that you are using. Refer to the user documentation of your external editor to find the appropriate settings.

**Command**

Specify a sequence of command strings to be passed to the editor. The command strings should be typed as:

```
DDE-Topic CommandString1
DDE-Topic CommandString2
```

This is only applicable if you have selected **DDE** as the interface type, see *Type*, page 132.

The command strings depend on the external editor that you are using. Refer to the user documentation of your external editor to find the appropriate settings.

**Note:** You can use variables in arguments. See *Argument variables*, page 121, for information about available argument variables.
Editor Setup Files options

The Editor Setup Files options are available by choosing Tools>Options.

![Editor Setup Files options](image)

Use this page to specify setup files for the editor.

**Use Custom Keyword File**

Specify a text file containing keywords that you want the editor to highlight. For information about syntax coloring, see Syntax coloring, page 70.

**Use Code Templates**

Specify a text file with code templates that you can use for inserting frequently used code in your source file. For information about using code templates, see Using and adding code templates, page 71.
Editor Colors and Fonts options

The Editor Colors and Fonts options are available by choosing Tools>Options.

![Editor Colors and Fonts options dialog box]

Use this page to specify the colors and fonts used for text in the editor windows. The keywords controlling syntax highlighting for assembler and C or C++ source code are specified in the files syntax.icc.cfg and syntax.asm.cfg, respectively. These files are located in the arm\config directory.

Editor Font

Click the Font button to open the standard Font dialog box where you can choose the font and its size to be used in editor windows.

Syntax Coloring

Selects a syntax element in the list and sets the color and style for it:

- **Color**: Lists colors to choose from. Choose Custom from the list to define your own color.
- **Type Style**: Select Normal, Bold, or Italic style for the selected element.
- **Sample**: Displays the current appearance of the selected element.
Note: The User keyword syntax element refers to the keywords that you have listed in the custom keyword file; see Use Custom Keyword File, page 133.

Messages options

The Messages options are available by choosing Tools>Options.

![Figure 63: Messages options]

Use this page to choose the amount of output in the Build messages window.

Show build messages

Selects the amount of output to display in the Build messages window. Choose between:

- **All**: Shows all messages, including compiler and linker information.
- **Messages**: Shows messages, warnings, and errors.
- **Warnings**: Shows warnings and errors.
- **Errors**: Shows errors only.
Log in file

Select the **Log build messages in file** option to write build messages to a log file. Choose between:

- **Append to end of file** — Appends the messages at the end of the specified file.
- **Overwrite old file** — Replaces the contents in the file you specify.

Type the filename you want to use in the text box. A browse button is available for your convenience.

Enable All Dialogs

Enables all dialog boxes you have suppressed by selecting a **Don’t show again** check box, for example:

![Figure 64: Message dialog box containing a Don’t show again option](image)

*Figure 64: Message dialog box containing a Don’t show again option*
Project options

The Project options are available by choosing Tools>Options.

Use this page to set options for the Make and Build commands.

Stop build operation on

Selects when the build operation should stop. Choose between:

- **Never**: Never stops.
- **Warnings**: Stops on warnings and errors.
- **Errors**: Stops on errors.

Save editor windows before building

Selects when the editor windows should be saved before a build operation. Choose between:

- **Never**: Never saves.
- **Ask**: Prompts before saving.
- **Always**: Always saves before Make or Build.
Save workspace and projects before building
Selects when a workspace and included projects should be saved before a build operation. Choose between:

- **Never**: Never saves.
- **Ask**: Prompts before saving.
- **Always**: Always saves before Make or Build.

Make before debugging
Selects when a Make operation should be performed as you start a debug session. Choose between:

- **Never**: Never performs a Make operation before debugging.
- **Ask**: Prompts before performing a Make operation.
- **Always**: Always performs a Make operation before debugging.

Reload last workspace at startup
Loads the last active workspace automatically the next time you start the IAR Embedded Workbench IDE.

Play a sound after build operations
Plays a sound when the build operations are finished.

Generate browse information
Enables the use of the Source Browser window, see *Source Browser window*, page 48.
Source Code Control options

The Source Code Control options are available by choosing Tools>Options.

Use this page to configure the interaction between an IAR Embedded Workbench project and an SCC project.

Keep items checked out when checking in

Determines the default setting for the option Keep Checked Out in the Check In Files dialog box; see Check In Files dialog box, page 53.

Save editor windows before performing source code control commands

Determines whether editor windows should be saved before you perform any source code control commands. Choose between:

- **Never** — Never saves editor windows before performing any source code control commands.
- **Ask** — Prompts before performing any source code control commands.
- **Always** — Always saves editor windows before performing any source code control commands.
Debugger options

The Debugger options are available by choosing Tools>Options.

![Debugger options](image)

Use this page to configure the debugger environment.

When source resolves to multiple function instances

Some source code corresponds to multiple code instances, for example template code. When specifying a source location in such code, for example when setting a source breakpoint, you can make C-SPY act on all instances or a subset of instances. Use the Automatically choose all instances option to let C-SPY act on all instances without asking first.

Source code color in disassembly window

Click the Color button to select the color of for source code in the Disassembly window. To define your own color, choose Custom from the list.

Step into functions

Controls the behavior of the Step Into command. Choose between:

- **All functions** Makes the debugger step into all functions.
Functions with source only
Makes the debugger step only into functions for which
the source code is known. This helps you avoid
stepping into library functions or entering disassembly
mode debugging.

STL container expansion
Specify how many elements that are shown initially when a container value is expanded
in, for example, the Watch window.

Update intervals
Specify how often the contents of the Live Watch window and the Memory window are
updated.
These text boxes are only available if the C-SPY driver you are using has access to the
target system memory while executing your application.

Default integer format
Selects the default integer format in the Watch, Locals, and related windows.

Stack options
The Stack options are available by choosing Tools>Options or from the context menu
in the Memory window.

Use this page to set options specific to the Stack window.
Enable graphical stack display and stack usage tracking

Enables the graphical stack bar available at the top of the Stack window. It also enables detection of stack overflows. To read more about the stack bar and the information it provides, see the C-SPY® Debugging Guide for ARM®.

% stack usage threshold

Specify the percentage of stack usage above which C-SPY should issue a warning for stack overflow.

Warn when exceeding stack threshold

Makes C-SPY issue a warning when the stack usage exceeds the threshold specified in the % stack usage threshold option.

Warn when stack pointer is out of bounds

Makes C-SPY issue a warning when the stack pointer is outside the stack memory range.

Stack pointer(s) not valid until program reaches

Specify a location in your application code from where you want the stack display and verification to occur. The Stack window will not display any information about stack usage until execution has reached this location.

By default, C-SPY will not track the stack usage before the main function. If your application does not have a main function, for example, if it is an assembler-only project, you should specify your own start label. If this option is selected, after each reset C-SPY keeps a breakpoint on the given location until it is reached.

Typically, the stack pointer is set up in the system initialization code cstartup, but not necessarily from the very first instruction. Select this option to avoid incorrect warnings or misleading stack display for this part of the application.

Warnings

Selects where warnings should be issued. Choose between:

Log

Warnings are issued in the Debug Log window.

Log and alert

Warnings are issued in the Debug Log window and as alert dialog boxes.

Limit stack display to

Limits the amount of memory displayed in the Stack window by specifying a number of bytes, counting from the stack pointer. This can be useful if you have a big stack or if
you are only interested in the topmost part of the stack. Using this option can improve the Stack window performance, especially if reading memory from the target system is slow. By default, the Stack window shows the whole stack, or in other words, from the stack pointer to the bottom of the stack. If the debugger cannot determine the memory range for the stack, the byte limit is used even if the option is not selected.

**Note:** The Stack window does not affect the execution performance of your application, but it might read a large amount of data to update the displayed information when the execution stops.

### Register Filter options

The **Register Filter** options are available by choosing **Tools>Options** when the debugger is running.

1. Choose **Tools>Options>Register Filter**.
2. Specify the filename for your new group.
3. Click **New Group** and specify the name of the group.
4. Select the registers to be included using the arrow buttons.

---

**Figure 69: Register Filter options**

Use this page to display registers in the Register window in groups you have created yourself.

For more information about register groups, see the *C-SPY® Debugging Guide for ARM®*.

**To define application-specific register groups:**

1. Choose **Tools>Options>Register Filter**.
2. Specify the filename for your new group.
3. Click **New Group** and specify the name of the group.
4. Select the registers to be included using the arrow buttons.
Optionally, you can override the default integer base.

Your new group is now available in the Register window.

**Use register filter**

Enables the use of register filters.

**Filter Files**

Displays a dialog box where you can select or create a new filter file.

**Groups**

Lists all available register groups in the filter file, alternatively displays the new register group.

**New Group**

Click to create a new register group.

**Group members**

Shows the registers in the group currently selected in the Groups drop-down list.

To add registers to the group, select the registers you want to add in the list of all available registers to the left and move them using the arrow button.

To remove registers from the group, select the registers you want to remove and move them using the arrow button.

**Base**

Overrides the default integer base.
Terminal I/O options

The Terminal I/O options are available by choosing Tools>Options when the debugger is running.

![Terminal I/O options](image)

Use this page to configure the C-SPY terminal I/O functionality.

**Input mode**

Controls how the terminal I/O input is read.

**Keyboard**

Makes the input characters be read from the keyboard. Choose between:

- **Buffered**: Buffers input characters.
- **Direct**: Does not buffer input characters.

**File**

Makes the input characters be read from a file. Choose between:

- **Text**: Reads input characters from a text file.
- **Binary**: Reads input characters from a binary file.

A browse button is available for locating the input file.
Input echoing
Determines whether to echo the input characters and where to echo them. The choices are:

- **Log file.** Requires that you have enabled the option **Debug>Logging>Enable log file.**
- **Terminal I/O window.**

Show target reset in Terminal I/O window
Displays a message in the C-SPY Terminal I/O window when the target resets.

Configure Tools dialog box
The **Configure Tools** dialog box is available from the **Tools** menu.

![Configure Tools dialog box](image_url)

Figure 71: Configure Tools dialog box
Use this dialog box to specify a tool of your choice to add to the **Tools** menu, like this:

![Figure 72: Customized Tools menu](image)

**Note:** If you intend to add an external tool to the standard build toolchain, see *Extending the toolchain*, page 64.

You can use variables in the arguments, which allows you to set up useful tools such as interfacing to a command line revision control system, or running an external tool on the selected file.

**Adding a command line command or batch file to the Tools menu:**

1. Specify or browse to the `cmd.exe` command shell in the **Command** text box.

2. Specify the command line command or batch file name in the **Argument** text box.

   The **Argument** text should be specified as:

   `/C name`

   where `name` is the name of the command or batch file you want to run.

   The `/C` option terminates the shell after execution, to allow the IDE to detect when the tool has finished.

   For an example, see *Adding command line commands*, page 28.

**New**

Creates a stub for a new menu command for you to configure using this dialog box.

**Delete**

Removes the command selected in the **Menu Content** list.

**Menu Content**

Lists all menu commands that you have defined.

**Menu Text**

Specify the name of the menu command. If you add the `&` sign anywhere in the name, the following letter, `N` in this example, will appear as the mnemonic key for this command. The text you specify will be reflected in the **Menu Content** list.
**Command**

Specify the tool and its path, to be run when you choose the command from the menu. A browse button is available for your convenience.

**Argument**

Optional: Specify an argument for the command.

**Initial Directory**

Specify an initial working directory for the tool.

**Redirect to Output window**

Makes the IDE send any console output from the tool to the **Tool Output** page in the message window. Tools that are launched with this option cannot receive any user input, for instance input from the keyboard.

Tools that require user input or make special assumptions regarding the console that they execute in, will not work at all if launched with this option.

**Prompt for Command Line**

Makes the IDE prompt for the command line argument when the command is chosen from the **Tools** menu.

**Tool Available**

Specifies in which context the tool should be available. Choose between:

- **Always**
- **When debugging**
- **When not debugging**.
Filename Extensions dialog box

The **Filename Extensions** dialog box is available from the **Tools** menu.

![Filename Extensions dialog box](image)

**Figure 73: Filename Extensions dialog box**

Use this dialog box to customize the filename extensions recognized by the build tools. This is useful if you have many source files with different filename extensions.

**Toolchain**

Lists the toolchains for which you have an IAR Embedded Workbench installed on your host computer. Select the toolchain you want to customize filename extensions for.

Note the * character which indicates user-defined overrides. If there is no * character, factory settings are used.

**Edit**

Displays the **Filename Extension Overrides** dialog box; see *Filename Extension Overrides dialog box*, page 150.
Filename Extension Overrides dialog box

The Filename Extension Overrides dialog box is available from the Filename Extensions dialog box.

![Filename Extension Overrides dialog box](image)

This dialog box lists filename extensions recognized by the build tools.

**Display area**

This area contains these columns:

- **Tool** The available tools in the build chain.
- **Factory Setting** The filename extensions recognized by default by the build tool.
- **Override** The filename extensions recognized by the build tool if there are overrides to the default setting.

**Edit**

Displays the Edit Filename Extensions dialog box for the selected tool.
Edit Filename Extensions dialog box

The Edit Filename Extensions dialog box is available from the Filename Extension Overrides dialog box.

![Edit Filename Extensions dialog box](image)

This dialog box lists the filename extensions recognized by the IDE and lets you add new filename extensions.

Factory setting

Lists the filename extensions recognized by default.

Override

Specify the filename extensions you want to be recognized. Extensions can be separated by commas or semicolons, and should include the leading period.

Configure Viewers dialog box

The Configure Viewers dialog box is available from the Tools menu.

![Configure Viewers dialog box](image)

This dialog box lists overrides to the default associations between the document formats that IAR Embedded Workbench can handle and viewer applications.
### Display area

This area contains these columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Extensions</strong></td>
<td>Explicitly defined filename extensions of document formats that IAR Embedded Workbench can handle.</td>
</tr>
<tr>
<td><strong>Action</strong></td>
<td>The viewer application that is used for opening the document type.</td>
</tr>
</tbody>
</table>

- **New**
  - Displays the **Edit Viewer Extensions** dialog box.

- **Edit**
  - Displays the **Edit Viewer Extensions** dialog box.

- **Delete**
  - Removes the association between the selected filename extensions and the viewer application.

---

**Edit Viewer Extensions dialog box**

The **Edit Viewer Extensions** dialog box is available from the **Configure Viewers** dialog box.

![Edit Viewer Extensions dialog box](image)

*Figure 77: Edit Viewer Extensions dialog box*
Use this dialog box to specify how to open a new document type or edit the setting for an existing document type.

**File name extensions**

Specify the filename extension for the document type—including the separating period (.).

**Action**

Selects how to open documents with the filename extension specified in the **Filename extensions** text box. Choose between:

- **Built-in text editor**: Opens all documents of the specified type with the IAR Embedded Workbench text editor.
- **Use file explorer associations**: Opens all documents of the specified type with the default application associated with the specified type in Windows Explorer.
- **Command line**: Opens all documents of the specified type with the viewer application you type or browse your way to. You can give any command line options you would like to the tool.

**Window menu**

The **Window** menu provides commands for manipulating the IDE windows and changing their arrangement on the screen.

![Window menu](image)

The last section of the **Window** menu lists the currently open windows. Choose the window you want to switch to.
These commands are available:

- **Close Tab**: Closes the active tab.
- **Close Window**: Closes the active editor window.
- **Ctrl+F4**: Splits an editor window horizontally or vertically into two or four panes, which means that you can see more parts of a file simultaneously.
- **New Vertical Editor Window**: Opens a new empty window next to the current editor window.
- **New Horizontal Editor Window**: Opens a new empty window under the current editor window.
- **Move Tabs To Next Window**: Moves all tabs in the current window to the next window.
- **Move Tabs To Previous Window**: Moves all tabs in the current window to the previous window.
- **Close All Tabs Except Active**: Closes all the tabs except the active tab.
- **Close All Editor Tabs**: Closes all tabs currently available in editor windows.

**Help menu**

The **Help** menu provides help about IAR Embedded Workbench and displays the version numbers of the user interface and of the IDE.

You can also access the Information Center from the **Help** menu. The Information Center is an integrated navigation system that gives easy access to the information resources you need to get started and during your project development: tutorials, example projects, user guides, support information, and release notes. It also provides shortcuts to useful sections on the IAR Systems web site.
General options

This chapter describes the general options in the IAR Embedded Workbench® IDE.

For more information about how to set options, see Setting options, page 59.

Description of general options

This section gives detailed information about the options in the General Options category.

To set general options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select General Options in the Category list.
3. To restore all settings to the default factory settings, click the Factory Settings button.

Target options

The Target options specify target-specific features for the IAR C/C++ Compiler and Assembler.

Figure 79: General target options
Description of general options

**Processor variant**

Selects the processor variant:

Core

The processor core you are using. For a description of the available variants, see the *IAR C/C++ Development Guide for ARM*.

Device

The device you are using. The choice of device will automatically determine the default C-SPY® device description file. For information about how to override the default files, see the *C-SPY® Debugging Guide for ARM®*.

**Endian mode**

Selects the byte order for your project:

Little

The lowest byte is stored at the lowest address in memory. The highest byte is the most significant; it is stored at the highest address.

Big

The lowest address holds the most significant byte, while the highest address holds the least significant byte. Choose between two variants of the big-endian mode:

BE8 to make data big-endian and code little-endian

BE32 to make both data and code big-endian.

**FPU**

Selects the floating-point unit:

None (default)

The software floating-point library is used.

VFPv2

A VFP unit conforming to architecture VFPv2.

VFPv3

A VFP unit conforming to architecture VFPv3.

VFPv3 + NEON

A VFP unit conforming to architecture VFPv3 and a NEON unit.

VFPv4

A VFP unit conforming to architecture VFPv4.

VFPv4 + NEON

A VFP unit conforming to architecture VFPv4 and a NEON unit.
By selecting a VFP coprocessor, you will override the use of the software floating-point library for all supported floating-point operations.

**Output**

The **Output** options determine the type of output file. You can also specify the destination directories for executable files, object files, and list files.

**Output file**

Selects the type of the output file:

- **Executable** (default)
  - As a result of the build process, the linker will create an application (an executable output file). When this setting is used, linker options will be available in the **Options** dialog box. Before you create the output you should set the appropriate linker options.

- **Library**
  - As a result of the build process, the library builder will create a library file. When this setting is used, library builder options will be available in the **Options** dialog box, and **Linker** will disappear from the list of categories. Before you create the library you can set the options.
Output directories

Specify the paths to the destination directories. Note that incomplete paths are relative to your project directory. You can specify:

**Executables/libraries**

Overrides the default directory for executable or library files. Type the name of the directory where you want to save executable files for the project.

**Object files**

Overrides the default directory for object files. Type the name of the directory where you want to save object files for the project.

**List files**

Overrides the default directory for list files. Type the name of the directory where you want to save list files for the project.

Library Configuration

The **Library Configuration** options determine which library to use.

![Library Configuration Options](image)

**Library**

Selects which runtime library to use. For information about available libraries, see the *IAR C/C++ Development Guide for ARM*.

For information about the runtime library, library configurations, the runtime environment they provide, and the possible customizations, see *IAR C/C++ Development Guide for ARM*.
The names of the library object file and library configuration file that actually will be used are displayed in the **Library** and **Configuration file** text boxes, respectively.

**Configuration file**

Displays the library configuration file that will be used. A library configuration file is chosen automatically depending on the project settings. If you have chosen **Custom** in the **Library** drop-down list, you must specify your own library configuration file.

**Library low-level interface implementation**

For Cortex-M, choose between:

- **None**
  - No low-level support for I/O available in the libraries. You must provide your own `write` function to use the I/O functions part of the library.

- **Semihosted and stdout/stderr via semihosting**
  - Semihostered I/O which uses the `BKPT` instruction.

- **Semihosted and stdout/stderr via SWO**
  - Semihostered I/O which uses the `BKPT` instruction for all functions except for the `stdout` and `stderr` output where the SWO interface—available on some J-Link debug probes—is used. This means a much faster mechanism where the application does not need to halt execution to transfer data.

- **IAR breakpoint**
  - Not available.

For other cores, choose between:

- **None**
  - No low-level support for I/O available in the libraries. You must provide your own `write` function to use the I/O functions part of the library.

- **Semihosted**
  - Semihostered I/O which uses the `SVC` instruction (earlier `SWI`).

- **IAR breakpoint**
  - The IAR proprietary variant of semihosting, which does not use the `SVC` instruction and thus does not need to set a breakpoint on the `SVC` vector. This is an advantage for applications which require the `SVC` vector for their own use, for example an RTOS. This method can also lead to performance improvements. However, note that this method does not work with applications, libraries, and object files that are built using tools from other vendors.
Description of general options

CMSIS

To enable CMSIS support, use these options:

Use CMSIS Adds the CMSIS header files to the compiler include path. Note that if your application source code include CMSIS header files explicitly, then you should not use this option. This option is only available for Cortex-M devices.

DSP library Links your application with the CMSIS DSP library. This option is only available for Cortex-M devices.

Library Options

The Library Options select the printf and scanf formatters.

![Library Options](image)

Figure 82: Library Options

For information about the capabilities of the formatters, see the IAR C/C++ Development Guide for ARM.

Printf formatter

If **auto** is selected, the linker automatically chooses the appropriate formatter for printf-related functions based on information from the compiler.

To override the default formatter for all printf-related functions, except for wprintf variants, choose between:

**Full**, **Full without multibytes**, **Large**, **Large without multibytes**, **Small**, **Small without multibytes**, and **Tiny**
Choose a formatter that suits the requirements of your application.

**Scanf formatter**

If `auto` is selected, the linker automatically chooses the appropriate formatter for `scanf`-related functions based on information from the compiler.

To override the default formatter for all `scanf`-related functions, except for `wscanf` variants, choose between:

- **Full**
- **Full without multibytes**
- **Large**
- **Large without multibytes**
- **Small**
- **Small without multibytes**

Choose a formatter that suits the requirements of your application.

**Buffered terminal output**

Buffers terminal output during program execution, instead of instantly printing each new character to the C-SPY Terminal I/O window. This option is useful when you use debugger systems that have slow communication.

**MISRA C**

The MISRA-C:1998 and MISRA-C:2004 options control how the IDE checks the source code for deviations from the MISRA C rules. The settings are used for both the compiler and the linker.

For details about specific options, see the *IAR Embedded Workbench® MISRA C:2004 Reference Guide* or the *IAR Embedded Workbench® MISRA C:1998 Reference Guide* available from the Help menu.
Description of general options
Compiler options

This chapter describes the compiler options available in the IAR Embedded Workbench® IDE.

For more information about how to set options, see Setting options, page 59.

Description of compiler options

This section gives detailed information about the options in the C/C++ Compiler category.

To set compiler options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select C/C++ Compiler in the Category list.
3. To restore all settings to the default factory settings, click the Factory Settings button.

Multi-file Compilation

Before you set specific compiler options, you can decide whether you want to use multi-file compilation, which is an optimization technique. Multi-file compilation enables multi-file compilation from the group of project files that you have selected in the workspace window.

You can use this option for the entire project or for individual groups of files. All C/C++ source files in such a group are compiled together using one invocation of the compiler.

Discard Unused Publics

Discards any unused public functions and variables from the compilation unit.

This means that all files included in the selected group are compiled using the compiler options which have been set on the group or nearest higher enclosing node which has any options set. Any overriding compiler options on one or more files are ignored when building, because a group compilation must use exactly one set of options.
For information about how multi-file compilation is displayed in the workspace window, see *Workspace window*, page 41.

For more information about multi-file compilation and discarding unused public functions, see the *IAR C/C++ Development Guide for ARM*.

### Language 1

The **Language 1** options determine which programming language to use and which extensions to enable.

*Figure 84: Compiler language options*

For more information about the supported languages, their dialects, and their extensions, see the *IAR C/C++ Development Guide for ARM*.

#### Language

Determines the compiler support for either C or C++:

- **C (default)**: Makes the compiler treat the source code as C, which means that features specific to C++ cannot be used.
- **C++**: Makes the compiler treat the source code as C++.
Compiler options

C dialect

Auto
Language support is decided automatically depending on the filename extension of the file being compiled:
- c, files with this filename extension are treated as C source files.
- cpp, files with this filename extension will be treated as C++ source files.

Selects the dialect if C is the supported language:

C89
Enables the C89 standard instead of Standard C. Note that this setting is mandatory when the MISRA C checking is enabled.

C99
Enables the C99 standard, also known as Standard C. This is the default standard used in the compiler, and it is stricter than C89. Features specific to C89 cannot be used. In addition, choose between:
- Allow VLA, allows the use of C99 variable length arrays.
- C++ inline semantics, enables C++ inline semantics when compiling a Standard C source code file.

Require prototypes
Forces the compiler to verify that all functions have proper prototypes, which means that source code containing any of the following will generate an error:
- A function call of a function with no declaration, or with a Kernighan & Ritchie C declaration.
- A function definition of a public function with no previous prototype declaration.
- An indirect function call through a function pointer with a type that does not include a prototype.

C++ dialect

Selects the dialect if C++ is the supported language:

Embedded C++
Makes the compiler treat the source code as Embedded C++. This means that features specific to C++, such as classes and overloading, can be used.
Description of compiler options

**Extended Embedded C++**  Enables features like namespaces or the standard template library in your source code.

**C++**  Makes the compiler treat the source code as Standard C++. Choose between:

- **With exceptions**, enables exception support in the C++ language.
- **With RTTI**, enables runtime type information (RTTI) support in the C++ language.

**Destroy static objects**  Makes the compiler generate code to destroy C++ static variables that require destruction at program exit.

**Language conformance**

Controls how strictly the compiler adheres to the standard C or C++ language:

- **Standard with IAR extensions**  Accepts ARM-specific keywords as extensions to the standard C or C++ language. In the IDE, this setting is enabled by default.
- **Standard**  Disables IAR Systems extensions, but does not adhere strictly to the C or C++ dialect you have selected. Some very useful relaxations to C or C++ are still available.
- **Strict**  Adheres strictly to the C or C++ dialect you have selected. This setting disables a great number of useful extensions and relaxations to C or C++.
Language 2

The Language 2 options control the use of some language extensions.

![Language 2 Options](image)

**Plain 'char' is**

Normally, the compiler interprets the plain `char` type as `unsigned char`. **Plain 'char' is** makes the compiler interpret the `char` type as `signed char` instead, for example for compatibility with another compiler.

**Note:** The runtime library is compiled with unsigned plain characters. If you select the **Signed** option, references to library functionality that uses plain unsigned characters will not work.

**Floating-point semantics**

Controls floating-point semantics. Choose between:

- **Strict conformance**
  
  Makes the compiler conform strictly to the C and floating-point standards for floating-point expressions.
Description of compiler options

Enable multibyte support

By default, multibyte characters cannot be used in C or Embedded C++ source code. **Enable multibyte support** makes the compiler interpret multibyte characters in the source code according to the host computer’s default setting for multibyte support.

Multibyte characters are allowed in C and C++ style comments, in string literals, and in character constants. They are transferred untouched to the generated code.

Code

The **Code** options control the code generation of the compiler.

*Figure 86: Code options*

**Relaxed**

Makes the compiler relax the language rules and perform more aggressive optimization of floating-point expressions. This option improves performance for floating-point expressions that fulfill these conditions:

- The expression consists of both single- and double-precision values
- The double-precision values can be converted to single precision without loss of accuracy
- The result of the expression is converted to single precision.

Note that performing the calculation in single precision instead of double precision might cause a loss of accuracy.
For detailed reference information about these compiler options, see the *IAR C/C++ Development Guide for ARM*.

**Generate interwork code**

Makes the compiler be able to mix ARM and Thumb code. This option is enabled by default.

**Processor mode**

Selects the processor mode for your project:

- **Arm**: Generates code that uses the full 32-bit instruction set.
- **Thumb**: Generates code that uses the reduced 16-bit instruction set. Thumb code minimizes memory usage and provides higher performance in 8/16-bit bus environments.

**Position-independence**

Determines how the compiler should handle position-independent code and data:

- **Code and read-only data (ropi)**: Generates code that uses PC-relative references to address code and read-only data.
- **Read/write data (rwpi)**: Generates code that uses an offset from the static base register to address-writable data.
- **No dynamic read/write initialization**: Disables runtime initialization of static C variables.
Optimizations

The Optimizations options determine the type and level of optimization for the generation of object code.

![Figure 87: Optimizations options](image)

**Level**

Selects the optimization level:

- **None**: No optimization; provides best debug support.
- **Low**: The lowest level of optimization.
- **Medium**: The medium level of optimization.
- **High, balanced**: The highest level of optimization, balancing between speed and size.
- **High, speed**: The highest level of optimization, favors speed.
- **High, size**: The highest level of optimization, favors size.

By default, a debug project will have a size optimization that is fully debuggable, while a release project will have a high balanced optimization that generates small code without sacrificing speed.

For a list of optimizations performed at each optimization level, see the *IAR C/C++ Development Guide for ARM*. 
Enabled transformations

Selects which transformations that are available at different optimization levels. When a transformation is available, you can enable or disable it by selecting its check box. Choose between:

- Common subexpression elimination
- Loop unrolling
- Function inlining
- Code motion
- Type-based alias analysis
- Static variable clustering
- Instruction scheduling.

In a debug project the transformations are, by default, disabled. In a release project the transformations are, by default, enabled.

For a brief description of the transformations that can be individually disabled, see the IAR C/C++ Development Guide for ARM.

Output

The **Output** options determine the generated compiler output.

![Output options](image)

**Generate debug information**

Makes the compiler include additional information in the object modules that is required by C-SPY® and other symbolic debuggers.
**Generate debug information** is selected by default. Deselect it if you do not want the compiler to generate debug information.

**Note:** The included debug information increases the size of the object files.

**Code section name**

The compiler places functions into named sections which are referred to by the IAR ILINK Linker. **Code section name** specifies a different name than the default name to place any part of your application source code into separate non-default sections. This is useful if you want to control placement of your code to different address ranges and you find the @ notation, alternatively the #pragma location directive, insufficient.

**Note:** Take care when you explicitly place a function in a predefined section other than the one used by default. This is useful in some situations, but incorrect placement can result in anything from error messages during compilation and linking to a malfunctioning application. Carefully consider the circumstances; there might be strict requirements on the declaration and use of the function or variable.

Note that any changes to the section names require a corresponding modification in the linker configuration file.

For detailed information about sections and the various methods for controlling the placement of code, see the *IAR C/C++ Development Guide for ARM*.

**List**

The **List** options make the compiler generate a list file and determine its contents.

![List options](image)

*Figure 89: Compiler list file options*
By default, the compiler does not generate a list file. Select any of the following options to generate a list file or an assembler file. The list file will be saved in the List directory, and its filename will consist of the source filename, plus the filename extension lst.

If you want to save the list file in another directory than the default directory for list files, use the Output Directories option in the General Options category; see Output, page 157, for additional information.

You can open the output files directly from the Output folder which is available in the Workspace window.

**Output list file**

Makes the compiler generate a list file. You can open the output files directly from the Output folder which is available in the Workspace window. By default, the compiler does not generate a list file. For the list file content, choose between:

- **Assembler mnemonics** Includes assembler mnemonics in the list file.
- **Diagnostics** Includes diagnostic information in the list file.

**Output assembler file**

Makes the compiler generate an assembler list file. For the list file content, choose between:

- **Include source** Includes source code in the assembler file.
- **Include call frame information** Includes compiler-generated information for runtime model attributes, call frame information, and frame size information.
**Preprocessor**

The **Preprocessor** options allow you to define symbols and include paths for use by the compiler.

**Ignore standard include directories**

Ignores the standard include files, which will not be used when the project is built.

**Additional include directories**

Specify the full file path to the list of `#include` file paths. The paths required by the product are specified automatically based on your choice of runtime library.

**Note:** Any directories you specify are searched before the standard include directories.

To make your project more portable, use the argument variable `$TOOLKIT_DIR$` for the subdirectories of the active product and `$PROJ_DIR$` for the directory of the current project. For an overview of the argument variables, see *Argument variables*, page 121.

**Preinclude file**

Makes the compiler include the include file you specify before the compiler starts to read the source file. This is useful if you want to change something in the source code for the entire application, for instance if you want to define a new symbol.

**Defined symbols**

Define symbols, which you otherwise must define in the source file. Type the symbols you want to define, one per line, and specify their values.
For example:

TESTVER=1

Note that there should be no space around the equal sign.

You might also want to arrange your source to produce either the test or production version of your application depending on whether the symbol TESTVER was defined. To do this you would use include sections such as:

```c
#define TESTVER
...
#endif
```

You would then define the symbol TESTVER in the Debug target but not in the Release target.

Defined symbols has the same effect as a `#define` statement at the top of the source file.

**Preprocessor output to file**

Generates preprocessor output to a file with the filename extension `i` and located in the `lst` directory. By default, the compiler does not generate preprocessor output. Choose between:

- Preserve comments
- Generate `#line` directives

**Diagnostics**

The Diagnostics options determine how diagnostic messages are classified and displayed. Use the diagnostics options to override the default classification of the specified diagnostics.
Description of compiler options

**Note:** The diagnostic messages cannot be suppressed for fatal errors, and fatal errors cannot be reclassified.

![Diagnoses](image.png)

**Enable remarks**

Makes the compiler generate remarks. By default, remarks are not issued.

The least severe diagnostic messages are called *remarks*. A remark indicates a source code construct that might cause strange behavior in the generated code.

**Suppress these diagnostics**

Suppresses the output of diagnostic messages for the tags that you specify.

For example, to suppress the warnings Pe117 and Pe177, type:

Pe117,Pe177

**Treat these as remarks**

Classifies diagnostic messages as remarks. A remark is the least severe type of diagnostic message. It indicates a source code construct that might cause strange behavior in the generated code.

For example, to classify the warning Pe177 as a remark, type:

Pe177

**Treat these as warnings**

Classifies diagnostic messages as warnings. A *warning* indicates an error or omission that is of concern, but which will not cause the compiler to stop before compilation is completed.
For example, to classify the remark Pe826 as a warning, type:

\texttt{Pe826}

**Treat these as errors**

Classifies diagnostic messages as errors. An \textit{error} indicates a violation of the C or C++ language rules, of such severity that object code will not be generated, and the exit code will be non-zero.

For example, to classify the warning Pe117 as an error, type:

\texttt{Pe117}

**Treat all warnings as errors**

Classifies all warnings as errors. If the compiler encounters an error, object code is not generated.

**MISRA C**

The MISRA-C:1998 and MISRA-C:2004 options override the corresponding options in the \texttt{General Options} category.

For details about specific option, see the \textit{IAR Embedded Workbench® MISRA C:2004 Reference Guide} or the \textit{IAR Embedded Workbench® MISRA C:1998 Reference Guide} available from the Help menu.

**Extra Options**

The \texttt{Extra Options} page provides you with a command line interface to the compiler.
Use command line options

Specify additional command line arguments to be passed to the compiler (not supported by the GUI).
Assembler options

This chapter describes the assembler options available in the IAR Embedded Workbench® IDE.

For more information about how to set options, see Setting options, page 59.

Description of assembler options

This section gives detailed information about the options in the Assembler category.

To set assembler options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select Assembler in the Category list.
3. To restore all settings to the default factory settings, click the Factory Settings button.

Language

The Language options control certain behavior of the assembler language.

User symbols are case sensitive

Toggles case sensitivity on and off. By default, case sensitivity is on. This means that, for example, LABEL and label refer to different symbols. When case sensitivity is off, LABEL and label will refer to the same symbol.
Enable multibyte support

Makes the assembler interpret multibyte characters in the source code according to the host computer’s default setting for multibyte support. By default, multibyte characters cannot be used in assembler source code.

Multibyte characters are allowed in comments, in string literals, and in character constants. They are transferred untouched to the generated code.

Macro quote characters

Selects the characters used for the left and right quotes of each macro argument. By default, the characters are `<` and `>`. 

Macro quote characters changes the quote characters to suit an alternative convention or simply to allow a macro argument to contain `<` or `>`. 

Allow alternative register names, mnemonics and operands

To enable migration from an existing application to the IAR Assembler for ARM, alternative register names, mnemonics, and operands can be allowed. This is controlled by the assembler command line option `-j`. Use this option for assembler source code written for the ARM ADS/RVCT Assembler. For more information, see the ARM® IAR Assembler Reference Guide.
Output

The **Output** options determine the generated assembler output.

**Generate debug information**

Makes the assembler generate debug information. Use this option if you want to use a debugger with your application. By default, this option is selected in a Debug project, but not in a Release project.

**List**

The **List** options make the assembler generate a list file and determine its contents.
**Output list file**

Makes the assembler generate a list file and send it to the file *sourcename.lst*. By default, the assembler does not generate a list file.

If you want to save the list file in another directory than the default directory for list files, use the **Output Directories** option in the **General Options** category; see *Output*, page 157, for additional information. You can open the output files directly from the **Output** folder which is available in the Workspace window.

**Include header**

Includes the header. The header of the assembler list file contains information about the product version, date and time of assembly, and the command line equivalents of the assembler options that were used.

**Include listing**

Selects which type of information to include in the list file:

- **#included text**
  - Includes preprocessor `#include` files in the list file.

- **Macro definitions**
  - Includes macro definitions in the list file.

- **Macro expansion**
  - Excludes macro expansions from the list file.

- **Macro execution info**
  - Prints macro execution information on every call of a macro.

- **Assembled lines only**
  - Excludes lines in false conditional assembler sections from the list file.

- **Multiline code**
  - Lists the code generated by directives on several lines if necessary.

**Include cross-reference**

Includes a cross-reference table at the end of the list file:

- **#define**
  - Includes preprocessor `#defines`.

- **Internal symbols**
  - Includes all symbols, user-defined as well as assembler-internal.

- **Dual line spacing**
  - Uses dual-line spacing.

**Lines/page**

Specify the number of lines per page, within the range 10 to 150. The default number of lines per page is 80 for the assembler list file.
Tab spacing

Specify the number of character positions per tab stop, within the range 2 to 9. By default, the assembler sets eight character positions per tab stop.

Preprocessor

The **Preprocessor** options allow you to define symbols and include paths for use by the assembler.

![Preprocessor options](image)

**Ignore standard include directories**

Ignores the standard include files, which will not be used when the project is built.

**Additional include directories**

Specify the full path to the list of `#include` file paths. The path required by the product is specified automatically.

To make your project more portable, use the argument variable `$TOOLKIT_DIR$` for the subdirectories of the active product and `$PROJ_DIR$` for the directory of the current project. For an overview of the argument variables, see *Argument variables*, page 121.

See the *ARM® IAR Assembler Reference Guide* for information about the `#include` directive.

**Note:** By default, the assembler also searches for `#include` files in the paths specified in the `TASMARM_INC` environment variable. We do not, however, recommend that you use environment variables in the IDE.
Defined symbols

Define symbols, which you otherwise must define in the source file. Specify the symbols you want to define, one per line, and specify their values.

For example, you might arrange your source to produce either the test or production version of your application depending on whether the symbol `TESTVER` was defined. To do this you would use include sections such as:

```
#ifdef TESTVER
  ...
#endif
```

You would then define the symbol `TESTVER` in the Debug target but not in the Release target.

Alternatively, your source might use a variable that you need to change often, for example `FRAMERATE`. You would leave the variable undefined in the source and use this option to specify a value for the project, for example `FRAMERATE=3`.

Diagnostics

The Diagnostics options control individual warnings or ranges of warnings.

![Diagnostics options](image)

Figure 98: Assembler diagnostics options

Warnings

Controls the assembler warnings. The assembler displays a warning message when it finds an element of the source code that is legal, but probably the result of a programming error. By default, all warnings are enabled. To control the generation of warnings, choose between:
For additional information about assembler warnings, see the *ARM® IAR Assembler Reference Guide*.

### Max number of errors

Specify the maximum number of errors. This means that you can increase or decrease the number of reported errors, for example, to see more errors in a single assembly. By default, the maximum number of errors reported by the assembler is 100.

### Extra Options

The Extra Options page provides you with a command line interface to the assembler.

![Extra Options for the assembler](image)

**Use command line options**

Specify the additional command line arguments to be passed to the assembler (not supported by the GUI).
Output converter options

This chapter describes the options available in the IAR Embedded Workbench® IDE for converting output files from the ELF format.

For more information about how to set options, see Setting options, page 59.

Description of output converter options

This section gives detailed information about the options in the Output Converter category.

To set output converter options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select Output Converter in the Category list.

Output

The Output options determine details about the promable output format.

Generate additional output

The ILINK linker generates ELF as output, optionally including DWARF for debug information. Generate additional output makes the converter ielftool convert the
Description of output converter options

ELF output to the format you specify, for example Motorola or Intel-extended. For more information about the converter, see the *IAR C/C++ Development Guide for ARM*.

**Output format**

Selects the format for the output from `ielftool`. Choose between: Motorola, Intel-extended, binary, and simple-code. For more information about the converter, see the *IAR C/C++ Development Guide for ARM*.

**Output file**

Specifies the name of the `iarelf` converted output file. By default, the linker will use the project name with a filename extension. The filename extension depends on which output format you choose; for example, either `srec` or `hex`. To override the default name, select **Override default** and specify the alternative filename or filename extension.
Custom build options

This chapter describes the Custom Build options available in the IAR Embedded Workbench® IDE.

For more information about how to set options, see Setting options, page 59.

Description of custom build options

This section gives detailed information about the options in the Custom Build category. To set custom build options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select Custom Build in the Category list.

Custom Tool Configuration

The Custom Tool Configuration options control the invocation of the tools you want to add to the tool chain.

For an example, see Extending the toolchain, page 64.
Filename extensions
Specify the filename extensions for the types of files that are to be processed by the custom tool. You can type several filename extensions. Use commas, semicolons, or blank spaces as separators. For example:

`*.htm; .html`

Command line
Specify the command line for executing the external tool.

Output file
Specify the name for the output files from the external tool.

Additional input files
Specify any additional files to be used by the external tool during the build process. If these additional input files, dependency files, are modified, the need for a rebuild is detected.
Build actions options

This chapter describes the options for pre-build and post-build actions available in the IAR Embedded Workbench® IDE.

For more information about how to set options, see Setting options, page 59.

Description of build actions options

This section gives detailed information about the options in the Build Actions category.

To set build action options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select Build Actions in the Category list.

Build Actions Configuration

The Build Actions Configuration options specify pre-build and post-build actions in the IDE. These options apply to the whole build configuration, and cannot be set on groups or files.

![Build Actions Configuration](image)

Figure 102: Build actions configuration options
Description of build actions options

**Pre-build command line**
Specify the command line to be executed directly before a build. Use the browse button to locate the tool you want to be executed. The commands will not be executed if the configuration is already up-to-date.

**Post-build command line**
Specify the command line to be executed directly after each successful build. Use the browse button to locate the tool you want to be executed. The commands will not be executed if the configuration was up-to-date. This is useful for copying or post-processing the output file.
Linker options

This chapter describes the linker options available in the IAR Embedded Workbench® IDE.

For more information about how to set options, see Setting options, page 59.

Description of linker options

This section gives detailed information about the options in the Linker category.

To set linker options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select Linker in the Category list.
3. To restore all settings to the default factory settings, click the Factory Settings button.

Config

The Config options specify the path and name of the linker configuration file and define symbols for the configuration file.

![Linker configuration options](Image)

Figure 103: Linker configuration options
Description of linker options

Linker configuration file

A default linker configuration file is selected automatically based on your project settings. To override the default file, select **Override default** and specify an alternative file.

The argument variables $TOOLKIT_DIR$ or $PROJ_DIR$ can be used for specifying a project-specific or predefined configuration file.

Configuration file symbol definitions

Define constant configuration symbols to be used in the configuration file. Such a symbol has the same effect as a symbol defined using the `define` symbol directive in the linker configuration file.

Library

The **Library** options select the set of used libraries.

![Library options](image)

*Figure 104: Linker library options*

See the *IAR C/C++ Development Guide for ARM* for more information about available libraries.

Automatic runtime library selection

Makes the linker automatically choose the appropriate library based on your project settings.
Additional libraries

Specify additional libraries that you want the linker to include during the link process. You can only specify one library per line and you must specify the full path to the library. The argument variables $PROJ_DIR$ and $TOOLKIT_DIR$ can be used.

Alternatively, you can add an additional library directly to your project in the workspace window. You can find an example of this in the tutorial for creating and using libraries.

Override default program entry

By default, the program entry is the label __iar_program_start. The linker makes sure that a module containing the program entry label is included, and that the section containing that label is not discarded.

Override default program entry overrides the default entry label; choose between:

- **Entry symbol** Specify an entry symbol other than default.
- **Defined by application** Uses an entry symbol defined in the linked object code. The linker will, as always, include all program modules, and enough library modules to satisfy all symbol references, keeping all sections that are marked with the root attribute or that are referenced, directly or indirectly, from such a section.

Input

The Input options specify how to handle input to the linker.

Figure 105: Linker input options
Description of linker options

**Keep symbols**

Define the symbol, or several symbols one per line, that shall always be included in the final application.

By default, the linker keeps a symbol only if your application needs it.

**Raw binary image**

Links pure binary files in addition to the ordinary input files. Specify these parameters:

- **File**: The pure binary file you want to link.
- **Symbol**: The symbol defined by the section where the binary data is placed.
- **Section**: The section where the binary data is placed.
- **Align**: The alignment of the section where the binary data is placed.

The entire contents of the file are placed in the section you specify, which means it can only contain pure binary data, for example, the raw binary output format. The section where the contents of the specified file are placed, is only included if the specified symbol is required by your application. Use the `--keep` linker option if you want to force a reference to the symbol. Read more about single output files and the `--keep` option in the *IAR C/C++ Development Guide for ARM*. 
Optimizations

The Optimizations options control linker optimizations.

For more information about these options, see the IAR C/C++ Development Guide for ARM.

**Inline small routines**

Makes the linker replace the call of a routine with the body of the routine, where applicable.

**Merge duplicate sections**

Makes the linker keep only one copy of equivalent read-only sections. Note that this can cause different functions or constants to have the same address, so an application that depends on the addresses being different will not work correctly with this option selected.

**Perform C++ Virtual Function Elimination**

Enables the Virtual Function Elimination optimization.

To force the use of Virtual Function Elimination, enable the Even if some modules are missing VFE information option. This might be unsafe if some of the modules that lack the needed information perform virtual function calls or use dynamic Runtime Type Information.

**Allow C++ exceptions**

If this option is not selected, the linker generates an error if there is a throw in the included code.
Description of linker options

Do not use this option if you want the linker to check that exceptions are not used by mistake in your application.

**Always include C++ exceptions**

Makes the linker include exception handling code and tables even if they do not appear to be needed.

The linker considers exceptions to be used if there is a `throw` expression that is not a rethrow in the included code. If there is no such `throw` expression in the rest of the code, the linker arranges for `operator new`, `dynamic_cast`, and `typeid` to call `abort` instead of throwing an exception on failure. If you need to catch exceptions from these constructs but your code contains no other throws, you might need to use this option.

**Output**

The **Output** options determine the generated linker output.

- **Output filename**
  
  Sets the name of the ILINK output file. By default, the linker will use the project name with the filename extension `.out`. To override the default name, specify an alternative name of the output file.

- **Include debug information in output**
  
  Makes the linker generate an ELF output file including DWARF for debug information.
List

The List options control the generation of linker listings.

- Generate linker map file
  Makes the linker generate a linker memory map file and send it to the projectname.map file located in the list directory. For detailed information about the map file and its contents, see the IAR C/C++ Development Guide for ARM.

- Generate log file
  Makes the linker save log information to the projectname.log file located in the list directory. The log information can be useful for understanding why an executable image became the way it is. You can log:
  - Automatic library selection
  - Initialization decisions
  - Module selections
  - Redirected symbols
  - Section selections
  - Unused section fragments
  - Veneer statistics.
The **#define** options define absolute symbols at link time.

### Defined symbols

Define absolute symbols to be used at link time. This is especially useful for configuration purposes. Type the symbols that you want to define for the project, one per line, and specify their value. For example:

```
TESTVER=1
```

Note that there should be no space around the equal sign.

Any number of symbols can be defined in a linker configuration file. The symbol(s) defined in this manner will be located in a special module called `?ABS_ENTRY_MOD`, which is generated by the linker.

The linker will display an error message if you attempt to redefine an existing symbol.

### Diagnostics

The **Diagnostics** options determine how diagnostics are classified and displayed. Use the diagnostics options to override the default classification of the specified diagnostics.
**Note:** The diagnostics cannot be suppressed for fatal errors, and fatal errors cannot be reclassified.

![Linker diagnostics options](Figure 110: Linker diagnostics options)

**Enable remarks**

Makes the linker generate remarks. By default, remarks are not issued. The least severe diagnostic messages are called remarks. A remark indicates a source code construct that might cause strange behavior in the generated code.

**Suppress these diagnostics**

Suppresses the output of diagnostic messages for the tags that you specify. For example, to suppress the warnings Pe117 and Pe177, type:

```
Pe117, Pe177
```

**Treat these as remarks**

Classifies diagnostic messages as remarks. For example, to classify the warning Pe177 as a remark, type:

```
Pe177
```

**Treat these as warnings**

Classifies diagnostic messages as warnings. A warning indicates an error or omission that is of concern, but which will not cause the linker to stop before linking is completed. For example, to classify the remark Pe826 as a warning, type:

```
Pe826
```
Description of linker options

**Treat these as errors**

Classifies diagnostic messages as errors. An *error* indicates a violation of the linking rules, of such severity that an executable image will not be generated, and the exit code will be non-zero.

For example, to classify the warning Pe117 as an error, type:

```
Pe117
```

**Treat all warnings as errors**

Classifies all warnings as errors. If the linker encounters an error, an executable image is not generated.

**Checksum**

The *Checksum* options control filling and checksumming.

![Checksum options](image)

*Figure 111: Linker checksum and fill options*

For more information about filling and checksumming, see the IAR C/C++ Development Guide for ARM.

**Fill unused code memory**

Fills unused memory in the range you specify:

- **Fill pattern** Specify a size, in hexadecimal notation, of the filler to be used in gaps between segment parts.
- **Start address** Specify the start address for the range to be filled.
Linker options

End address
Specify the end address for the range to be filled.

Generate checksum
Checksums the specified range.
Choose between:

Size
Selects the size of the checksum, which can be 1, 2, or 4 bytes.

Alignment
Specify an optional alignment for the checksum. If you do not specify an alignment explicitly, an alignment of 2 is used.

Arithmetic sum
Selects the simple arithmetic sum algorithm. The result is truncated to one byte.

Result in full size
Generates the result of the arithmetic sum algorithm in the size you specify instead of truncating it to one byte.

CRC16 (default)
Selects the CRC16 algorithm (generating polynomial 0x11021).

CRC32
Selects the CRC32 algorithm (generating polynomial 0x104C11DB7).

Crc polynomial
Selects the Crc polynomial algorithm, a generating polynomial of the value you specify.

Complement
Selects the complement variant, either the one’s complement or two’s complement.

Bit order
Selects the bit order of the result to be output. Choose between:

MSB first, which outputs the most significant bit first for each byte.

LSB first, which reverses the bit order for each byte and outputs the least significant bit first.

Reverse byte order within word
Reverses the byte order of the input data within each word of the size specified in Size.

Initial value
Specify an initial value for the checksum. This is useful if the core you are using has its own checksum calculation and you want that calculation to correspond to the calculation performed by the linker.
Extra Options

The **Extra Options** page provides you with a command line interface to the linker.

**Use command line options**

Specify additional command line arguments to be passed to the linker (not supported by the GUI).

**Use as input**

Prefixes the input data with a word of size **Size** that contains the value specified in **Initial value**.
Library builder options

This chapter describes the library builder options available in the IAR Embedded Workbench® IDE.

For more information about how to set options, see Setting options, page 59.

Description of library builder options

This section gives detailed information about the options in the Library Builder category.

Options for the library builder are not available by default. Before you can set these options in the IDE, you must add the library builder tool to the list of categories.

1 Choose Project>Options>General Options>Output.

2 Select the Library option, which means that Library Builder appears as a category in the Options dialog box.

3 Select Library Builder in the Category list.
Description of library builder options

Output

The Output options control the library builder and as a result of the build process, the library builder will create a library output file.

Figure 113: Library builder output options

Factory Settings
Restores all settings to the default factory settings.

Output file
Specifies the name of the output file from the library builder. By default, the linker will use the project name with a filename extension. To override the default name, select Override default and specify an alternative name of the output file.
Glossary

This is a general glossary for terms relevant to embedded systems programming. Some of the terms do not apply to the IAR Embedded Workbench® version that you are using.

A

**Absolute location**
A specific memory address for an object specified in the source code, as opposed to the object being assigned a location by the linker.

**Address expression**
An expression which has an address as its value.

**AEABI**
Embedded Application Binary Interface for ARM, defined by ARM Limited.

**Application**
The program developed by the user of the IAR Systems toolkit and which will be run as an embedded application on a target processor.

**Ar**
The GNU binary utility for creating, modifying, and extracting from archives, that is, libraries. See also *larchive*.

**Architecture**
A term used by computer designers to designate the structure of complex information-processing systems. It includes the kinds of instructions and data used, the memory organization and addressing, and the methods by which the system is implemented. The two main architecture types used in processor design are *Harvard architecture* and *von Neumann architecture*.

**Archive**
See *Library*.

**Assembler directives**
The set of commands that control how the assembler operates.

**Assembler language**
A machine-specific set of mnemonics used to specify operations to the target processor and input or output registers or data areas. Assembler language might sometimes be preferred over C/C++ to save memory or to enhance the execution speed of the application.

**Assembler options**
Parameters you can specify to change the default behavior of the assembler.

**Attributes**
See *Section attributes*.

**Auto variables**
The term refers to the fact that each time the function in which the variable is declared is called, a new instance of the variable is created automatically. This can be compared with the behavior of local variables in systems using static overlay, where a local variable only exists in one instance, even if the function is called recursively. Also called local variables. Compare *Register variables*.

B

**Backtrace**
Information for keeping call frame information up to date so that the IAR C-SPY® Debugger can return from a function correctly. See also *Call frame information*.

**Bank**
See *Memory bank*.

**Bank switching**
Switching between different sets of memory banks. This software technique increases a computer’s usable memory by allowing different pieces of memory to occupy the same address space.

**Banked code**
Code that is distributed over several banks of memory. Each function must reside in only one bank.
**Banked data**
Data that is distributed over several banks of memory. Each data object must fit inside one memory bank.

**Banked memory**
Has multiple storage locations for the same address. See also *Memory bank*.

**Bank-switching routines**
Code that selects a memory bank.

**Batch files**
A text file containing operating system commands which are executed by the command line interpreter. In Unix, this is called a “shell script” because it is the Unix shell which includes the command line interpreter. Batch files can be used as a simple way to combine existing commands into new commands.

**Bitfield**
A group of bits considered as a unit.

**Block, in linker configuration file**
A continuous piece of code or data. It is either built up of blocks, overlays, and sections or it is empty. A block has a name, and the start and end address of the block can be referred to from the application. It can have attributes such as a maximum size, a specific size, or a minimum alignment. The contents can have a specific order or not.

**Breakpoint**
1. Code breakpoint. A point in a program that, when reached, triggers some special behavior useful to the process of debugging. Generally, breakpoints are used for stopping program execution or dumping the values of some or all of the program variables. Breakpoints can be part of the program itself, or they can be set by the programmer as part of an interactive session with a debugging tool for scrutinizing the program's execution.

2. Data breakpoint. A point in memory that, when accessed, triggers some special behavior useful to the process of debugging. Generally, data breakpoints are used to stop program execution when an address location is accessed either by a read operation or a write operation.

3. Immediate breakpoint. A point in memory that, when accessed, triggers some special behavior useful in the process of debugging. Immediate breakpoints are generally used for halting the program execution in the middle of a memory access instruction (before or after the actual memory access depending on the access type) while performing some user-specified action. The execution is then resumed. This feature is only available in the simulator version of C-SPY.

**C**

**Call frame information**
Information that allows the IAR C-SPY® Debugger to show, without any runtime penalty, the complete stack of function calls—*call stack*—wherever the program counter is, provided that the code comes from compiled C functions. See also *Backtrace*.

**Calling convention**
A calling convention describes the way one function in a program calls another function. This includes how register parameters are handled, how the return value is returned, and which registers that will be preserved by the called function. The compiler handles this automatically for all C and C++ functions. All code written in assembler language must conform to the rules in the calling convention to be callable from C or C++, or to be able to call C and C++ functions. The C calling convention and the C++ calling conventions are not necessarily the same.

**Cheap**
As in *cheap memory access*. A cheap memory access either requires few cycles to perform, or few bytes of code to implement. A cheap memory access is said to have a low cost. See *Memory access cost*.

**Checksum**
A computed value which depends on the ROM content of the whole or parts of the application, and which is stored along with the application to detect corruption of the data. The checksum is produced by the linker to be verified with the application. Several algorithms are supported. Compare *CRC* (*cyclic redundancy checking*).
**Code banking**

*See Banked code.*

**Code model**

The code model controls how code is generated for an application. Typically, the code model controls behavior such as how functions are called and in which code section functions will be located. All object files of an application must be compiled using the same code model.

**Code pointers**

A code pointer is a function pointer. As many cores allow several different methods of calling a function, compilers for embedded systems usually provide the users with the ability to use all these methods.

Do not confuse code pointers with data pointers.

**Code sections**

Read-only sections that contain code. See also *Section.*

**Compilation unit**

*See Translation unit.*

**Compiler options**

Parameters you can specify to change the default behavior of the compiler.

**Cost**

*See Memory access cost.*

**CRC (cyclic redundancy checking)**

A number derived from, and stored with, a block of data to detect corruption. A CRC is based on polynomials and is a more advanced way of detecting errors than a simple arithmetic checksum. Compare *Checksum.*

**C-SPY options**

Parameters you can specify to change the default behavior of the IAR C-SPY Debugger.

**Cstartup**

Code that sets up the system before the application starts executing.

**C-style preprocessor**

A preprocessor is either a stand-alone application or an integrated part of a compiler, that performs preprocessing of the input stream before the actual compilation occurs. A C-style preprocessor follows the rules set up in Standard C and implements commands like `#define`, `#if`, and `#include`, which are used to handle textual macro substitution, conditional compilation, and inclusion of other files.

**Data banking**

*See Banked data.*

**Data model**

The data model specifies the default memory type. This means that the data model typically controls one or more of the following: The method used and the code generated to access static and global variables, dynamically allocated data, and the runtime stack. It also controls the default pointer type and in which data sections static and global variables will be located. A project can only use one data model at a time, and the same model must be used by all user modules and all library modules in the project.

**Data pointers**

Many cores have different addressing modes to access different memory types or address spaces. Compilers for embedded systems usually have a set of different data pointer types so they can access the available memory efficiently.

**Data representation**

How different data types are laid out in memory and what value ranges they represent.

**Declaration**

A specification to the compiler that an object, a variable or function, exists. The object itself must be defined in exactly one translation unit (source file). An object must either be declared or defined before it is used. Normally an object that is used in many files is defined in one source file. A declaration is normally placed in a header file that is included by the files that use the object.
For example:

```c
/* Variable "a" exists somewhere. Function "b" takes two int parameters and returns an int. */
extern int a;
int b(int, int);
```

**Definition**
The variable or function itself. Only one definition can exist for each variable or function in an application. See also **Tentative definition**.

For example:

```c
int a;
int b(int x, int y)
{
    return x + y;
}
```

**Demangling**
To restore a mangled name to the more common C/C++ name. See also **Mangling**.

**Device description file**
A file used by C-SPY that contains various device-specific information such as I/O registers (SFR) definitions, interrupt vectors, and control register definitions.

**Device driver**
Software that provides a high-level programming interface to a particular peripheral device.

**Digital signal processor (DSP)**
A device that is similar to a microprocessor, except that the internal CPU is optimized for use in applications involving discrete-time signal processing. In addition to standard microprocessor instructions, digital signal processors usually support a set of complex instructions to perform common signal-processing computations quickly.

**Disassembly window**
A C-SPY window that shows the memory contents disassembled as machine instructions, interspersed with the corresponding C source code (if available).

**DWARF**
An industry-standard debugging format which supports source level debugging. This is the format used by the IAR ILINK Linker for representing debug information in an object.

**Dynamic initialization**
Variables in a program written in C are initialized during the initial phase of execution, before the main function is called. These variables are always initialized with a static value, which is determined either at compile time or at link time. This is called static initialization. In C++, variables might require initialization to be performed by executing code, for example, running the constructor of global objects, or performing dynamic memory allocation.

**Dynamic memory allocation**
There are two main strategies for storing variables: statically at link time, or dynamically at runtime. Dynamic memory allocation is often performed from the heap and it is the size of the heap that determines how much memory that can be used for dynamic objects and variables. The advantage of dynamic memory allocation is that several variables or objects that are not active at the same time can be stored in the same memory, thus reducing the memory requirements of an application. See also **Heap memory**.

**Dynamic object**
An object that is allocated, created, destroyed, and released at runtime. Dynamic objects are almost always stored in memory that is dynamically allocated. Compare **Static object**.

**EEPROM**
Electrically Erasable, Programmable Read-Only Memory. A type of ROM that can be erased electronically, and then be re-programmed.
**ELF**
Executable and Linking Format, an industry-standard object file format. This is the format used by the IAR ILINK Linker. The debug information is formatted using DWARF.

**Embedded C++**
A subset of the C++ programming language, which is intended for embedded systems programming. The fact that performance and portability are particularly important in embedded systems development was considered when defining the language.

**Embedded system**
A combination of hardware and software, designed for a specific purpose. Embedded systems are often part of a larger system or product.

**Emulator**
An emulator is a hardware device that performs emulation of one or more derivatives of a processor family. An emulator can often be used instead of the actual core and connects directly to the printed circuit board—where the core would have been connected—via a connecting device. An emulator always behaves exactly as the processor it emulates, and is used when debugging requires all systems actuators, or when debugging device drivers.

**Enea OSE Load module format**
A specific ELF format that is loadable by the OSE operating system. See also **ELF**.

**Enumeration**
A type which includes in its definition an exhaustive list of possible values for variables of that type. Common examples include Boolean, which takes values from the list [true, false], and day-of-week which takes values [Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday]. Enumerated types are a feature of typed languages, including C and Ada.

Characters, (fixed-size) integers, and even floating-point types might be (but are not usually) considered to be (large) enumerated types.

**EPROM**
Erasable, Programmable Read-Only Memory. A type of ROM that can be erased by exposing it to ultraviolet light, and then be re-programmed.

**Executable image**
Contains the executable; the result of linking several relocatable object files and libraries. The file format used for an object file is ELF with embedded DWARF for debug information.

**Exceptions**
An exception is an interrupt initiated by the processor hardware, or hardware that is tightly coupled with the processor, for instance, a memory management unit (MMU). The exception signals a violation of the rules of the architecture (access to protected memory), or an extreme error condition (division by zero).

Do not confuse this use of the word exception with the term *exception* used in the C++ language (but not in Embedded C++).

**Expensive**
As in *expensive memory access*. An expensive memory access either requires many cycles to perform, or many bytes of code to implement. An expensive memory access is said to have a high cost. See *Memory access cost*.

**Extended keywords**
Non-standard keywords in C and C++. These usually control the definition and declaration of objects (that is, data and functions). See also **Keywords**.

**F**

**Filling**
How to fill up bytes—with a specific fill pattern—that exists between the sections in an executable image. These bytes exist because of the alignment demands on the sections.
Format specifiers
Used to specify the format of strings sent by library functions such as \texttt{printf}. In the following example, the function call contains one format string with one format specifier, \texttt{%c}, that prints the value of \texttt{a} as a single ASCII character:

\begin{verbatim}
printf("a = %c", a);
\end{verbatim}

General options
Parameters you can specify to change the default behavior of all tools that are included in the IDE.

Generic pointers
Pointers that have the ability to point to all different memory types in, for example, a core based on the Harvard architecture.

Harvard architecture
A core based on the Harvard architecture has separate data and instruction buses. This allows execution to occur in parallel. As an instruction is being fetched, the current instruction is executing on the data bus. Once the current instruction is complete, the next instruction is ready to go. This theoretically allows for much faster execution than a von Neumann architecture, but adds some silicon complexity. Compare von Neumann architecture.

Heap memory
The heap is a pool of memory in a system that is reserved for dynamic memory allocation. An application can request parts of the heap for its own use; once memory is allocated from the heap it remains valid until it is explicitly released back to the heap by the application. This type of memory is useful when the number of objects is not known until the application executes. Note that this type of memory is risky to use in systems with a limited amount of memory or systems that are expected to run for a very long time.

Heap size
Total size of memory that can be dynamically allocated.

Host
The computer that communicates with the target processor. The term is used to distinguish the computer on which the debugger is running from the core the embedded application you develop runs on.

Iarchive
The IAR Systems utility for creating archives, that is, libraries. Iarchive is delivered with IAR Embedded Workbench.

IDE (integrated development environment)
A programming environment with all necessary tools integrated into one application.

Ielfdumparm
The IAR Systems utility for creating a text representation of the contents of ELF relocatable or executable image.

Ielftool
The IAR Systems utility for performing various transformations on an ELF executable image, such as fill, checksum, and format conversion.

ILINK
The IAR ILINK Linker which produces absolute output in the ELF/DWARF format.

ILINK configuration
The definition of available physical memories and the placement of sections—pieces of code and data—into those memories. ILINK requires a configuration to build an executable image.

Image
See Executable image.

Include file
A text file which is included into a source file. This is often done by the preprocessor.
Initialization setup in linker configuration file
Defines how to initialize RAM sections with their initializers. Normally, only non-constant non-noinit variables are initialized but, for example, pieces of code can be initialized as well.

Initialized sections
Read-write sections that should be initialized with specific values at startup. See also Section.

Inline assembler
Assembler language code that is inserted directly between C statements.

Inlining
An optimization that replaces function calls with the body of the called function. This optimization increases the execution speed and can even reduce the size of the generated code.

Instruction mnemonics
A word or acronym used in assembler language to represent a machine instruction. Different processors have different instruction sets and therefore use a different set of mnemonics to represent them, such as, ADD, BR (branch), BLT (branch if less than), MOVE, LDR (load register).

Interrupt vector
A small piece of code that will be executed, or a pointer that points to code that will be executed when an interrupt occurs.

Interrupt vector table
A table containing interrupt vectors, indexed by interrupt type. This table contains the processor's mapping between interrupts and interrupt service routines and must be initialized by the programmer.

Interrupts
In embedded systems, the use of interrupts is a method of detecting external events immediately, for example a timer overflow or the pressing of a button.

Interrupts are asynchronous events that suspend normal processing and temporarily divert the flow of control through an “interrupt handler” routine. Interrupts can be caused by both hardware (I/O, timer, machine check) and software (supervisor, system call or trap instruction). Compare Trap.

Intrinsic
An adjective describing native compiler objects, properties, events, and methods.

Intrinsic functions
1. Function calls that are directly expanded into specific sequences of machine code. 2. Functions called by the compiler for internal purposes (that is, floating-point arithmetic etc.).

Iobjmanip
The IAR Systems utility for performing low-level manipulation of ELF object files.

K

Key bindings
Key shortcuts for menu commands used in the IDE.

Keywords
A fixed set of symbols built into the syntax of a programming language. All keywords used in a language are reserved—they cannot be used as identifiers (in other words, user-defined objects such as variables or procedures). See also Extended keywords.

L

L-value
A value that can be found on the left side of an assignment and thus be changed. This includes plain variables and de-referenced pointers. Expressions like \((x + 10)\) cannot be assigned a new value and are therefore not L-values.

Language extensions
Target-specific extensions to the C language.
Library
See Runtime library.

Library configuration file
A file that contains a configuration of the runtime library. The file contains information about what functionality is part of the runtime environment. The file is used for tailoring a build of a runtime library. See also Runtime library.

Linker configuration file
A file that contains a configuration used by the IAR ILINK Linker when building an executable image. See also ILINK configuration.

Local variable
See Auto variables.

Location counter
See Program location counter (PLC).

Logical address
See Virtual address (logical address).

MAC (Multiply and accumulate)
A special instruction, or on-chip device, that performs a multiplication together with an addition. This is very useful when performing signal processing where many filters and transforms have the form:

\[ y_j = \sum_{i=0}^{N} c_i \cdot x_{i+j} \]

The accumulator of the MAC usually has a higher precision (more bits) than normal registers. See also Digital signal processor (DSP).

Macro
1. Assembler macros are user-defined sets of assembler lines that can be expanded later in the source file by referring to the given macro name. Parameters will be substituted if referred to.
2. C macro. A text substitution mechanism used during preprocessing of source files. Macros are defined using the \#define preprocessing directive. The replacement text of each macro is then substituted for any occurrences of the macro name in the rest of the translation unit.
3. C-SPY macros are programs that you can write to enhance the functionality of C-SPY. A typical application of C-SPY macros is to associate them with breakpoints; when such a breakpoint is hit, the macro is run and can for example be used to simulate peripheral devices, to evaluate complex conditions, or to output a trace.

The C-SPY macro language is like a simple dialect of C, but is less strict with types.

Mailbox
A mailbox in an RTOS is a point of communication between two or more tasks. One task can send messages to another task by placing the message in the mailbox of the other task. Mailboxes are also known as message queues or message ports.

Mangling
Mangling is a technique used for mapping a complex C/C++ name into a simple name. Both mangled and unmangled names can be produced for C/C++ symbols in ILINK messages.

Memory, in linker configuration file
A physical memory. The number of units it contains and how many bits a unit consists of, are defined in the linker configuration file. The memory is always addressable from 0x0 to size -1.
**Memory access cost**
The cost of a memory access can be in clock cycles, or in the number of bytes of code needed to perform the access. A memory which requires large instructions or many instructions is said to have a higher access cost than a memory which can be accessed with few, or small instructions.

**Memory area**
A region of the memory.

**Memory bank**
The smallest unit of continuous memory in banked memory. One memory bank at a time is visible in a core’s physical address space.

**Memory map**
A map of the different memory areas available to the core.

**Memory model**
Specifies the memory hierarchy and how much memory the system can handle. Your application must use only one memory model at a time, and the same model must be used by all user modules and all library modules.

**Microcontroller**
A microprocessor on a single integrated circuit intended to operate as an embedded system. In addition to a CPU, a microcontroller typically includes small amounts of RAM, PROM, timers, and I/O ports.

**Microprocessor**
A CPU contained on one (or a few) integrated circuits. A single-chip microprocessor can include other components such as memory, memory management, caches, floating-point unit, I/O ports and timers. Such devices are also known as microcontrollers.

**Module**
An object. An object file contains a module and library contains one or more objects. The basic unit of linking. A module contains definitions for symbols (exports) and references to external symbols (imports). When you compile C/C++, each translation unit produces one module.

**Multi-file compilation**
A technique which means that the compiler compiles several source files as one compilation unit, which enables for interprocedural optimizations such as inlining, cross call, and cross jump on multiple source files in a compilation unit.

**Nested interrupts**
A system where an interrupt can be interrupted by another interrupt is said to have nested interrupts.

**Non-banked memory**
Has a single storage location for each memory address in a core’s physical address space.

**Non-initialized memory**
Memory that can contain any value at reset, or in the case of a soft reset, can remember the value it had before the reset.

**No-init sections**
Read-write sections that should not be initialized at startup. See also *Section*.

**Non-volatile storage**
Memory devices such as battery-backed RAM, ROM, magnetic tape and magnetic disks that can retain data when electric power is shut off. Compare *Volatile storage*.

**NOP**
No operation. This is an instruction that does not do anything, but is used to create a delay. In pipelined architectures, the NOP instruction can be used for synchronizing the pipeline. See also *Pipeline*.

**Objcopy**
A GNU binary utility for converting an absolute object file in ELF format into an absolute object file, for example the format Motorola-std or Intel-std. See also *Ielftool*.

**Object**
An object file or a library member.
Object file, absolute
See Executable image.

Object file, relocatable
The result of compiling or assembling a source file. The file format used for an object file is ELF with embedded DWARF for debug information.

Operator
A symbol used as a function, with infix syntax if it has two arguments (+, for example) or prefix syntax if it has only one (for instance, bitwise negation, ~). Many languages use operators for built-in functions such as arithmetic and logic.

Operator precedence
Each operator has a precedence number assigned to it that determines the order in which the operator and its operands are evaluated. The highest precedence operators are evaluated first. Use parentheses to group operators and operands to control the order in which the expressions are evaluated.

Options
A set of commands that control the behavior of a tool, for example the compiler or linker. The options can be specified on the command line or via the IDE.

Output image
The resulting application after linking. This term is equivalent to executable image, which is the term used in the IAR Systems user documentation.

Overlay, in linker configuration file
Like a block, but it contains several overlaid entities, each built up of blocks, overlays, and sections. The size of an overlay is determined by its largest constituent.

P
Parameter passing
See Calling convention.

Peripheral unit
A hardware component other than the processor, for example memory or an I/O device.

Pipeline
A structure that consists of a sequence of stages through which a computation flows. New operations can be initiated at the start of the pipeline even though other operations are already in progress through the pipeline.

Placement, in linker configuration file
How to place blocks, overlays, and sections into a region. It determines how pieces of code and data are actually placed in the available physical memory.

Pointer
An object that contains an address to another object of a specified type.

#pragma
During compilation of a C/C++ program, the #pragma preprocessing directive causes the compiler to behave in an implementation-defined manner. This can include, for example, producing output on the console, changing the declaration of a subsequent object, changing the optimization level, or enabling/disabling language extensions.

Pre-emptive multitasking
An RTOS task is allowed to run until a higher priority process is activated. The higher priority task might become active as the result of an interrupt. The term preemptive indicates that although a task is allotted to run a given length of time (a timeslice), it might lose the processor at any time. Each time an interrupt occurs, the task scheduler looks for the highest priority task that is active and switches to that task. If the located task is different from the task that was executing before the interrupt, the previous task is suspended at the point of interruption.

Compare Round Robin.

Preprocessing directives
A set of directives that are executed before the parsing of the actual code is started.

Preprocessor
See C-style preprocessor.
Processor variant
The different chip setups that the compiler supports.

Program counter (PC)
A special processor register that is used to address instructions. Compare Program location counter (PLC).

Program location counter (PLC)
Used in the IAR Assembler to denote the code address of the current instruction. The PLC is represented by a special symbol (typically $) that can be used in arithmetic expressions. Also called simply location counter (LC).

Project
The user application development project.

Project options
General options that apply to an entire project, for example the target processor that the application will run on.

PROM
Programmable Read-Only Memory. A type of ROM that can be programmed only once.

Qualifiers
See Type qualifiers.

Real-time system
A computer system whose processes are time-sensitive. Compare Real-time operating system (RTOS).

Region, in linker configuration file
A set of non-overlapping ranges. The ranges can lie in one or more memories. For ILINK, blocks, overlays, and sections are placed into regions in the linker configuration file.

Region expression, in linker configuration file
A region built up from region literals, regions, and the common set operations possible in the linker configuration file.

Region literal, in linker configuration file
A literal that defines a set of one or more non-overlapping ranges in a memory.

Register
A small on-chip memory unit, usually just one or a few bytes in size, which is particularly efficient to access and therefore often reserved as a temporary storage area during program execution.

Register constant
A register constant is a value that is loaded into a dedicated processor register when the system is initialized. The compiler can then generate code that assumes that the constants are present in the dedicated registers.

Register locking
Register locking means that the compiler can be instructed that some processor registers shall not be used during normal code generation. This is useful in many situations. For example, some parts of a system might be written in assembler language to gain speed. These parts might be given dedicated processor registers. Or the register might be used by an operating system, or by other third-party software.

Register variables
Typically, register variables are local variables that are placed in registers instead of on the (stack) frame of the function. Register variables are much more efficient than other variables because they do not require memory accesses, so the compiler can use shorter/faster instructions when working with them. See also Auto variables.

Real-time operating system (RTOS)
An operating system which guarantees the latency between an interrupt being triggered and the interrupt handler starting, and how tasks are scheduled. An RTOS is typically much smaller than a normal desktop operating system. Compare Real-time system.

Range, in linker configuration file
A range of consecutive addresses in a memory. A region is built up of ranges.

Read-only sections
Sections that contain code or constants. See also Section.

Registering
Registering
Relay
A synonym to veneer, see Veneer.

Relocatable sections
Sections that have no fixed location in memory before linking.

Reset
A reset is a restart from the initial state of a system. A reset can originate from hardware (hard reset), or from software (soft reset). A hard reset can usually not be distinguished from the power-on condition, which a soft reset can be.

ROM-monitor
A piece of embedded software designed specifically for use as a debugging tool. It resides in the ROM of the evaluation board chip and communicates with a debugger via a serial port or network connection. The ROM-monitor provides a set of primitive commands to view and modify memory locations and registers, create and remove breakpoints, and execute your application. The debugger combines these primitives to fulfill higher-level requests like program download and single-step.

Round Robin
Task scheduling in an operating system, where all tasks have the same priority level and are executed in turn, one after the other. Compare Pre-emptive multitasking.

RTOS
See Real-time operating system (RTOS).

Runtime library
A collection of relocatable object files that will be included in the executable image only if referred to from an object file, in other words conditionally linked.

Runtime model attributes
A mechanism that is designed to prevent modules that are not compatible to be linked into an application. A runtime attribute is a pair constituted of a named key and its corresponding value.

ILINK uses the runtime model attributes when automatically choosing a library, to verify that the correct one is used.

R-value
A value that can be found on the right side of an assignment. This is just a plain value. See also L-value.

Saturation arithmetics
Most, if not all, C and C++ implementations use mod–2^N 2-complement-based arithmetics where an overflow wraps the value in the value domain, that is, \((127 + 1) = -128\). Saturation arithmetics, on the other hand, does not allow wrapping in the value domain, for instance, \((127 + 1) = 127\), if 127 is the upper limit. Saturation arithmetics is often used in signal processing, where an overflow condition would have been fatal if value wrapping had been allowed.

Scheduler
The part of an RTOS that performs task-switching. It is also responsible for selecting which task that should be allowed to run. Many scheduling algorithms exist, but most of them are either based on static scheduling (performed at compile-time), or on dynamic scheduling (where the actual choice of which task to run next is taken at runtime, depending on the state of the system at the time of the task-switch). Most real-time systems use static scheduling, because it makes it possible to prove that the system will not violate the real-time requirements.

Scope
The section of an application where a function or a variable can be referenced by name. The scope of an item can be limited to file, function, or block.

Section
An entity that either contains data or text. Typically, one or more variables, or functions. A section is the smallest linkable unit.

Section attributes
Each section has a name and an attribute. The attribute defines what a section contains, that is, if the section content is read-only, read/write, code, data, etc.
**Section fragment**
A part of a section, typically a variable or a function.

**Section selection**
In the linker configuration file, defining a set of sections by using section selectors. A section belongs to the most restrictive section selector if it can be part of more than one selection. Three different selectors can be used individually or in conjunction to select the set of sections: *section attribute* (selecting by the section content), *section name* (selecting by the section name), and *object name* (selecting from a specific object).

**Semaphore**
A semaphore is a type of flag that is used for guaranteeing exclusive access to resources. The resource can be a hardware port, a configuration memory, or a set of variables. If several tasks must access the same resource, the parts of the code (the critical sections) that access the resource must be made exclusive for every task. This is done by obtaining the semaphore that protects that resource, thus blocking all other tasks from it. If another task wishes to use the resource, it also must obtain the semaphore. If the semaphore is already in use, the second task must wait until the semaphore is released. After the semaphore is released, the second task is allowed to execute and can obtain the semaphore for its own exclusive access.

**Severity level**
The level of seriousness of the diagnostic response from the assembler, compiler, or debugger, when it notices that something is wrong. Typical severity levels are remarks, warnings, errors, and fatal errors. A remark just points to a possible problem, while a fatal error means that the programming tool exits without finishing.

**Sharing**
A physical memory that can be addressed in several ways. For ILINK, defined in the linker configuration file.

**Short addressing**
Many cores have special addressing modes for efficient access to internal RAM and memory mapped I/O. Short addressing is therefore provided as an extended feature by many compilers for embedded systems. See also Data pointers.

**Side effect**
An expression in C or C++ is said to have a side-effect if it changes the state of the system. Examples are assignments to a variable, or using a variable with the post-increment operator. The C and C++ standards state that a variable that is subject to a side-effect should not be used more that once in an expression. As an example, this statement violates that rule:

```
*d++ = *d;
```

**Signal**
Signals provide event-based communication between tasks. A task can wait for one or more signals from other tasks. Once a task receives a signal it waits for, execution continues. A task in an RTOS that waits for a signal does not use any processing time, which allows other tasks to execute.

**Simulator**
A debugging tool that runs on the host and behaves as similar to the target processor as possible. A simulator is used to debug the application when the hardware is unavailable, or not needed for proper debugging. A simulator is usually not connected to any physical peripheral devices. A simulated processor is often slower, or even much slower, than the real hardware.

**Single stepping**
Executing one instruction or one C statement at a time in the debugger.

**Skeleton code**
An incomplete code framework that allows the user to specialize the code.

**Special function register (SFR)**
A register that is used to read and write to the hardware components of the core.
Stack frames
Data structures containing data objects like preserved registers, local variables, and other data objects that must be stored temporary for a particular scope (usually a function).

Earlier compilers usually had a fixed size and layout on a stack frame throughout a complete function, while modern compilers might have a very dynamic layout and size that can change anywhere and anytime in a function.

Stack sections
The section or sections that reserve space for the stack(s). Most processors use the same stack for calls and parameters, but some have separate stacks.

Standard libraries
The C and C++ library functions as specified by the C and C++ standard, and support routines for the compiler, like floating-point routines.

Static object
An object whose memory is allocated at link-time and is created during system startup (or at first use). Compare Dynamic object.

Static overlay
Instead of using a dynamic allocation scheme for parameters and auto variables, the linker allocates space for parameters and auto variables at link time. This generates a worst-case scenario of stack usage, but might be preferable for small chips with expensive stack access or no stack access at all.

Statically allocated memory
This kind of memory is allocated once and for all at link-time, and remains valid all through the execution of the application. Variables that are either global or declared static are allocated this way.

Structure value
A collecting names for structs and unions. A struct is a collection of data object placed sequentially in memory (possibly with pad bytes between them). A union is a collection of data sharing the same memory location.

Symbolic location
A location that uses a symbolic name because the exact address is unknown.

Target
1. An architecture. 2. A piece of hardware. The particular embedded system you are developing the application for. The term is usually used to distinguish the system from the host system.

Task (thread)
A task is an execution thread in a system. Systems that contain many tasks that execute in parallel are called multitasking systems. Because a processor only executes one instruction stream at the time, most systems implement some sort of task-switch mechanism (often called context switch) so that all tasks get their share of processing time. The process of determining which task that should be allowed to run next is called scheduling. Two common scheduling methods are Pre-emptive multitasking and Round Robin.

Tentative definition
A variable that can be defined in multiple files, provided that the definition is identical and that it is an absolute variable.

Terminal I/O
A simulated terminal window in C-SPY.

Timer
A peripheral that counts independent of the program execution.

Timeslice
The (longest) time an RTOS allows a task to run without running the task-scheduling algorithm. A task might be allowed to execute during several consecutive timeslices before being switched out. A task might also not be allowed to use its entire time slice, for example if, in a preemptive system, a higher priority task is activated by an interrupt.
Translation unit
A source file together with all the header files and source files included via the preprocessor directive `#include`, except for the lines skipped by conditional preprocessor directives such as `#if` and `#ifdef`.

Trap
A trap is an interrupt initiated by inserting a special instruction into the instruction stream. Many systems use traps to call operating system functions. Another name for trap is software interrupt.

Type qualifiers
In Standard C/C++, `const` or `volatile`. IAR Systems compilers usually add target-specific type qualifiers for memory and other type attributes.

UBROF (Universal Binary Relocatable Object Format)
File format produced by some of the IAR Systems programming tools, if your product package includes the XLINK linker.

Value expressions, in linker configuration file
A constant number that can be built up out of expressions that has a syntax similar to C expressions.

Veneer
A small piece of code that is inserted as a springboard between caller and callee when:

- There is a mismatch in mode, for example ARM and Thumb
- The call instruction does not reach its destination.

Virtual address (logical address)
An address that must be translated by the compiler, linker or the runtime system into a physical memory address before it is used. The virtual address is the address seen by the application, which can be different from the address seen by other parts of the system.

Virtual space
An IAR Embedded Workbench Editor feature which allows you to place the insertion point outside of the area where there are actual characters.

Volatile storage
Data stored in a volatile storage device is not retained when the power to the device is turned off. To preserve data during a power-down cycle, you should store it in non-volatile storage. This should not be confused with the C keyword `volatile`. Compare Non-volatile storage.

von Neumann architecture
A computer architecture where both instructions and data are transferred over a common data channel. Compare Harvard architecture.

Watchpoints
Watchpoints keep track of the values of C variables or expressions in the C-SPY Watch window as the application is being executed.

XLINK
The IAR XLINK Linker which uses the UBROF output format.

Zero-initialized sections
Sections that should be initialized to zero at startup. See also Section.
**Zero-overhead loop**
A loop in which the loop condition, including branching back to the beginning of the loop, does not take any time at all. This is usually implemented as a special hardware feature of the processor and is not available in all architectures.

**Zone**
Different processors have widely differing memory architectures. Zone is the term C-SPY uses for a named memory area. For example, on processors with separately addressable code and data memory there would be at least two zones. A processor with an intricate banked memory scheme might have several zones.
banked code, definition of ........................................... 207
banked data, definition of .......................................... 208
banked memory, definition of ...................................... 208
bank-switching routines, definition of ............................ 208
Base (Register filter option) ........................................... 144
bat (filename extension) ............................................... 83
Batch Build ............................................................... 61
Batch Build Configuration dialog box (Project menu) ....... 123
Batch Build dialog box (Project menu) .......................... 122
batch files
  definition of .......................................................... 208
  specifying from the Tools menu ................................. 28
Big (Endian mode setting) ............................................. 156
bin, arm (subdirectory) ................................................ 81
bin, common (subdirectory) ......................................... 82
Bit order (Generate checksum setting) ............................ 203
bitfield, definition of .................................................. 208
Block, definition of .................................................... 208
board (filename extension) .......................................... 83
Body (b) (Configure auto indent option) ......................... 131
bold style, in this guide ............................................... 19
bookmarks
  adding ................................................................. 74
  showing in editor ................................................... 130
breakpoints, definition of .......................................... 208
Buffered write (linker option) .................................... 161
-build (iarbuild command line option) ......................... 63
Build Actions .......................................................... 62
Build Actions Configuration (Build Actions options) ....... 191
build configuration
  creating ............................................................... 35
  definition of ....................................................... 32
Build window (View menu) .......................................... 96
building
  commands for ........................................................ 61
  from the command line ........................................... 63
  options .................................................................... 137
  pre- and post-actions .............................................. 62
the process ............................................................... 59
byte order, setting ...................................................... 156

C

C comments, text style in editor .................................... 70
C dialect (compiler option) .......................................... 165
C keywords, text style in editor .................................... 70
C source file (Workspace window icon) ......................... 42
c (filename extension) .................................................. 83
C (Language setting) .................................................... 164
call frame information
  definition of .......................................................... 208
  including in assembler list file .................................. 173
call frame information See also backtrace information
calling convention, definition of ................................. 208
category, in Options dialog box .................................... 60, 120
cfg (filename extension) .............................................. 83
characters, in assembler macro quotes .......................... 180
cheap memory access, definition of .............................. 208
Check In Files dialog box .......................................... 53
Check In (Source code control menu) ............................ 51
Check Out Files dialog box ........................................ 54
Check Out (Source code control menu) .......................... 52
checkmark (source code control icon) ........................... 56
checksum
  definition of .......................................................... 208
  Checksum (linker options) ...................................... 202
  checksum, generating .............................................. 203
  chm (filename extension) ........................................... 83
  -clean (iarbuild command line option) ....................... 63
  Clean (Workspace window context menu) ..................... 44
  Close Workspace (File menu) ................................... 102
  CMSIS (general option) .......................................... 160
  CMSIS, arm (subdirectory) ...................................... 81
code
  banked, definition of .............................................. 207
  skeleton, definition of ............................................ 219
testing ................................................................. 63
custom build ........................................... 64
using .................................................. 65
custom tool configuration .......................... 64
Custom Tool Configuration (custom build options) .... 189
C-SPY options
   definition of .................................... 209
     in Options dialog box ......................... 120
   setting ........................................... 59
C-style preprocessor, definition of ..... 209
C/C++ syntax
   enabling in compiler ............................ 164
   options for styles .............................. 134
C++ comments, text style in editor .......... 70
C++ dialect (compiler option) ............... 165
C++ inline semantics (C dialect setting) ...... 165
C++ keywords, text style in editor .......... 70
C++ source file (Workspace window icon) .... 42
C++ terminology .................................. 18
C++ (Language setting) ......................... 164
C89 (C dialect setting) ......................... 165
C99 (C dialect setting) ......................... 165
default installation path ...................... 81
Default integer format (IDE option) ........ 141
#define options (linker options) ............... 200
#define statement, in compiler .................. 175
define (linker options) ......................... 200
Defined by application (Override default program
   entry setting) .................................. 195
Defined symbols (assembler option) .......... 184
Defined symbols (compiler option) .......... 174
Defined symbols (linker option) .............. 200
definition, definition of ....................... 210
demangling, definition of ....................... 210
dep (filename extension) ....................... 83
Destroy static objects (C++ dialect setting) .... 166
development environment, introduction ...... 23
device description files ......................... 81
decision, definition of ......................... 210
device driver, definition of .................... 210
device selection files ......................... 81
Device (Processor variant setting) ........... 156
diagnostics
   compiler
      including in list file ....................... 173
      suppressing .................................. 176
     linker, suppressing .......................... 201
   Diagnostics (assembler options) ........... 184
   Diagnostics (compiler options) ............. 175
   Diagnostics (linker options) ............... 200
   Diff (Subversion control menu) ............ 57
digital signal processor, definition of ..... 210
directories
   arm ............................................. 81
   assembler, ignore standard include ......... 183
   common ........................................ 82
   compiler, ignore standard include ......... 174
   root .......................................... 81
directory structure ............................ 81
Disable language extensions (Language conformance
   setting) ....................................... 166
Disable (Warning setting) ..................... 185

dat (filename extension) ....................... 83
data model, definition of ....................... 209
data pointers, definition of .................... 209
data representation, definition of .......... 209
$DATE$ (argument variable) .................... 121
dft (filename extension) ....................... 83
ddf (filename extension) ....................... 83
debug information
   generating in assembler ..................... 181
   in compiler, generating ..................... 171
Debug Log window (View menu) ................ 99
Debug without downloading text box .......... 89
Debug (Configuration factory setting) ........ 48
Debugger (IDE Options dialog box) .......... 140
declaration, definition of .................... 209
IDE Project Management and Building Guide
for ARM
226
UIDEARM-2
Index

Disassembly window, definition of ................................. 210
Discard Unused Publics (multi-file compilation setting) . 163
disclaimer .................................................................. 2
Disconnect Project from SCC Project
(Source code control menu) ................................. 52
Disconnect Project from SVN Project
(Subversion control menu) ................................. 57
DLIB, documentation ........................................ 17
DLIB library functions, reference information .. 69
dni (filename extension) ....................................... 83
dockable windows ................................................ 25
document conventions ......................................... 18
documentation ...................................................... 81
   online .................................................................. 82
   overview of guides ........................................... 17
   overview of this guide ....................................... 16
   this guide .......................................................... 15
doc, arm (subdirectory) ..................................... 82
doc, common (subdirectory) ................................. 83
drag-and-drop
   of files in workspace window ...................... 34
   text in editor window .................................. 69
drivers, arm (subdirectory) ................................. 82
DSP. See digital signal processor
Dual line spacing (Include cross-reference setting) .. 182
DWARF, definition of ........................................ 210
Dynamic Data Exchange (DDE) ............................ 75
calling external editor ........................................ 132
dynamic initialization, definition of .................. 210
dynamic memory allocation, definition of ........ 210
dynamic object, definition of ............................ 210
editor
   code templates .................................................. 71
   commands ......................................................... 69
   customizing the environment ......................... 75
   external .......................................................... 75
   indentation ....................................................... 70
   keyboard commands ..................................... 95
   matching parentheses and brackets ............. 71
   options .......................................................... 128
   shortcut to functions .................................... 74, 92
   splitter controls ............................................. 92
   status bar, using in ......................................... 71
    using ............................................................ 67
Editor Colors and Fonts (IDE Options dialog box) .... 134
Editor Font (Editor colors and fonts option) ........... 134
Editor Setup Files (IDE Options dialog box) .......... 133
caller setup files, options ................................. 133
Editor window .................................................. 90
Editor (External editor option) ............................. 132
Editor (IDE Options dialog box) ............................ 128
EEC++ syntax (C++ dialect setting) .................... 166
EEPROM, definition of .................................. 210
ELF, converting from ....................................... 188
Embedded C++
   definition of .................................................. 211
   syntax, enabling in compiler ......................... 165
Embedded C++ Technical Committee .................... 18
Embedded C++ (C++ dialect setting) .................. 165
embedded system, definition of ......................... 211
Embedded Workbench
   editor ........................................................... 67
    exiting from ................................................ 25
    layout ......................................................... 25
    main window .............................................. 24, 88
    reference information ................................. 87
    running ...................................................... 24
    version number, displaying ....................... 154
emulator (C-SPY driver), definition of ............... 154
Enable graphical stack display and stack usage
   tracking (Stack option) ................................ 142

E

Edit Filename Extensions dialog box (Tools menu) .... 151
Edit menu ...................................................... 103
Edit Viewer Extensions (Tools menu) .................... 152
editing source files .......................................... 67
edition, of this guide ......................................... 2
Enabling multibyte support (assembler option) ........ 180
Enabling multibyte support (compiler option) .......... 168
Enable remarks (compiler option) ..................... 176
Enable remarks (linker option) ....................... 201
Enable virtual space (editor option) ................. 130
Enable (Warning setting) .................................. 185
Enabled transformations (compiler option) ........... 171
End address (Fill setting) ................................. 203
Endian mode (general option) ............................. 156
Enea OSE load module format, definition of ........ 211
Entry symbol (Override default program entry setting) 195
Enumeration, definition of ................................ 211
Environment variables, as argument variables ........ 121
EOL character (editor option) .............................. 129
Environment variables, as argument variables ........ 121
Extra Options
for assembler ............................................. 185
for compiler ............................................. 177
for linker ................................................ 204
Factory Settings (library builder options) ............... 206
Factory settings, restoring default settings ............ 61
File menu .................................................. 100
File Properties (Workspace window context menu) .... 44
File types
device description ......................................... 81
device selection ........................................... 81
documentation ............................................. 82
drivers ..................................................... 82
extended command line .................................. 85
flash loader applications ................................. 81
header ..................................................... 82
include ................................................... 82
library ..................................................... 82
linker configuration files ................................. 81
project templates ........................................ 81
readme ..................................................... 82
syntax coloring configuration ............................ 81
File (Raw binary image setting) ......................... 196
filename extensions ...................................... 83
cfg, syntax highlighting ................................ 134
evwx, the workspace file ................................. 25
other than default ....................................... 85
Filename Extensions dialog box (Tools menu) ......... 149
Filename Extensions Overrides dialog box (Tools menu) 150
Filename extensions (custom build option) ............ 190
Files
editing ................................................ 67
navigating among ....................................... 30
$FILE_DIRS (argument variable) ......................... 121
$FILE_FNAMEs (argument variable) ..................... 121
examples, arm (subdirectory) ............................ 82
exceptions, definition of ................................ 211
executable image, definition of ......................... 211
Executable (Output file setting) ......................... 157
Executable/libraries (output directory setting) ..... 158
$EXE_DIRS (argument variable) ......................... 121
exit (Exit menu) ........................................ 25
expensive memory access, definition of ............... 211
extended command line file .............................. 85
Extended Embedded C++ syntax, enabling in compiler . 166
Extended Embedded C++ syntax, enabling in compiler . 166
Extended Embedded C++ syntax, enabling in compiler . 166
file extensions. See filename extensions
Flash loader application ................................ 81
Project templates ........................................ 81
readme ..................................................... 82
syntax coloring configuration ............................ 81
Factory Settings (library builder options) ............... 206
Factory settings, restoring default settings ............ 61
Filename Extensions dialog box (Tools menu) ......... 149
Filename Extensions Overrides dialog box (Tools menu) 150
Filename extensions (custom build option) ............ 190
Files
editing ................................................ 67
navigating among ....................................... 30
$FILE_DIRS (argument variable) ......................... 121
$FILE_FNAMEs (argument variable) ..................... 121
examples, arm (subdirectory) ............................ 82
exceptions, definition of ................................ 211
executable image, definition of ......................... 211
Executable (Output file setting) ......................... 157
Executable/libraries (output directory setting) ..... 158
$EXE_DIRS (argument variable) ......................... 121
EOL character (editor option) .............................. 129
File menu .................................................. 100
File Properties (Workspace window context menu) .... 44
factory settings, restoring default settings ............ 61
File menu .................................................. 100
File Properties (Workspace window context menu) .... 44
factory settings, restoring default settings ............ 61
Extra Options
for assembler ............................................. 185
for compiler ............................................. 177
for linker ................................................ 204
error messages
compiler ..................................................... 177
 linker ..................................................... 202
 ewd (filename extension) .................................. 83
evpass (filename extension) ............................... 84
ewp (filename extension) ................................... 84
eww (filename extension) ................................... 84
the workspace file .......................................... 25
$EWW_DIRS (argument variable) ......................... 121
for assembler ............................................. 185
for compiler ............................................. 177
for linker ................................................ 204
filename extensions ...................................... 83
cfg, syntax highlighting ................................ 134
evwx, the workspace file ................................. 25
other than default ....................................... 85
Extra Options
for assembler ............................................. 185
for compiler ............................................. 177
for linker ................................................ 204
filename extensions ...................................... 83
cfg, syntax highlighting ................................ 134
evwx, the workspace file ................................. 25
other than default ....................................... 85
Factory Settings (library builder options) ............... 206
Factory settings, restoring default settings ............ 61
Extra Options
for assembler ............................................. 185
for compiler ............................................. 177
for linker ................................................ 204
filename extensions ...................................... 83
cfg, syntax highlighting ................................ 134
evwx, the workspace file ................................. 25
other than default ....................................... 85
Factory Settings (library builder options) ............... 206
Factory settings, restoring default settings ............ 61

HTML text file (Workspace window icon) ................. 42
html (filename extension) ........................................ 84

i (filename extension) ........................................ 84
iarbuild, building from the command line ............... 63
 iaridepm.exe ...................................................... 24
icf (filename extension) ...................................... 84
icons
   in Workspace window ....................................... 41
   SVN states ................................................... 57
icons, in this guide ........................................... 19
IDE
   definition of .............................................. 212
   overview ................................................... 23
IDE internal file (Workspace window icon) ............. 42
Ignore standard include directories (assembler option) . 183
Ignore standard include directories (compiler option) . 174
ILINK
   definition of .............................................. 212
   options ................................................... 193
inc (filename extension) ...................................... 84
Include compiler call frame information (Output assembler file setting) ............. 173
Include debug information in output (linker option) .... 198
include files ................................................... 82
   assembler, specifying path ................................ 183
   compiler, specifying path ................................. 174
   definition of .............................................. 212
Include header (assembler option) .......................... 182
Include listing (assembler option) ........................... 182
Include source (Output assembler file setting) ........ 173
Incremental Search dialog box (Edit menu) .............. 111
inc, arm (subdirectory) ...................................... 82
Indent size (editor option) .................................. 128
Indent with spaces (Tab Key Function setting) ........ 129
indentation, in editor ........................................ 70
inherited settings, overriding ................................ 60
ini (filename extension) ...................................... 84
Initial value (Generate checksum setting) .................. 84
initialization in ILINK config file, definition of ........ 213
initialized sections, definition of .......................... 213
inline assembler, definition of .............................. 213
Inline small routines (linker option) ....................... 197
inlining, definition of ........................................ 213
Input (linker option) ........................................... 195
Insert tab (Tab Key Function setting) ....................... 129
insertion point, shortcut key for moving ................ 69
installation directory ........................................... 18
installation path, default ..................................... 81
installed files ................................................... 81
documentation ................................................... 82
   executable .................................................. 82
   include ..................................................... 82
   library ..................................................... 82
instruction mnemonics, definition of ....................... 213
Integrated Development Environment (IDE)
   definition of .............................................. 212
Internal symbol (Include cross-reference setting) .... 182
interrupt vector table, definition of ...................... 213
interrupt vector, definition of .............................. 213
interrupts
   definition of .............................................. 213
   nested, definition of .................................... 215
interwork code, generating .................................. 169
intrinsic functions, definition of ......................... 213
intrinsic, definition of ..................................... 213
iobjmanip, definition of .................................... 213
italic style, in this guide ................................... 19
i79 (filename extension) ...................................... 84

Just warning (Warning setting) ...................... 185
K

Keep symbol (linker option) ................................ 196
Key bindings (IDE Options dialog box) ................... 126
key bindings, definition of ................................ 213
key summary, editor ........................................ 95
keywords
  definition of ........................................ 213
  enable language extensions for ........................ 166
  specify syntax color for in editor ..................... 70

L

Label (c) (Configure auto indent option) ................. 131
Language conformance (compiler option) ................ 166
language extensions
  definition of ........................................ 213
  disabling in compiler ............................... 166
Language (assembler options) ............................ 179
Language (compiler option) ................................ 164
Language (IDE Options dialog box) ...................... 127
Language (Language option) ............................ 128
Language 1 (compiler options) .......................... 164
Language 2 (compiler options) .......................... 167
layout, of Embedded Workbench ............................ 25
Level (compiler option) ................................ 170
library builder options, factory settings .............. 206
library builder, output options ......................... 206
library configuration file
  definition of ........................................ 214
  specifying from IDE ................................ 159
Library Configuration (general options) ............... 158
library files ........................................... 82
library functions
  configurable ......................................... 82
  reference information ................................ 69
Library low-level interface
  implementation (general option) ..................... 159
Library Options (general options) ....................... 160

Library (general option) ................................ 158
Library (linker options) ................................ 194
Library (Output file setting) ............................ 157
library, definition of ................................ 218
lib, arm (subdirectory) ................................. 82
lightbulb icon, in this guide ............................. 19
#line directives, generating
  in compiler ......................................... 175
Lines/page (assembler option) ......................... 182
linker
  command line version ................................ 23
linker command file. See linker configuration file
linker configuration file
  definition of ........................................ 214
  in directory ........................................ 81
  specifying in linker ................................ 194
Linker configuration file (linker option) .............. 194
linker diagnostics, suppressing ......................... 201
linker options ........................................ 193
  Checksum .......................................... 202
  Config ............................................. 193
  define ............................................ 200
  Diagnostics ....................................... 200
  Extra Options ..................................... 204
  Input .............................................. 195
  Library ............................................ 194
  List ................................................ 199
  Optimizations ..................................... 197
  Output ............................................ 198
linker symbols, defining ................................. 200
list files
  assembler
    compiler runtime information
      conditional information, specifying ................ 182
      cross-references, generating ..................... 182
      header, including ................................ 182
      lines per page, specifying ....................... 182
      tab spacing, specifying ........................ 183
compiler
  assembler mnemonics, including ................. 173
  generating .................................... 173
  source code, including ......................... 173
List files (Output directories setting) ............ 158
List (assembler options) .......................... 181
List (compiler options) ........................... 172
List (linker option) ............................... 199
SLIST_DIR$ (argument variable) ................... 121
Little endian (Endian mode setting) ............... 156
location counter, definition of .................... 217
-log (iarbuild command line option) ............... 63
log file, generate from linker ...................... 199
log (filename extension) .......................... 84
Log (Subversion control menu) ..................... 57
logical address, definition of ..................... 221
Low (Level setting) ................................ 170
lst (filename extension) ........................... 84
L-value, definition of ............................. 213
mac (filename extension) ........................... 84
Macro definitions (Include listing setting) ......... 182
Macro execution info (Include listing setting) ..... 182
Macro expansions (Include listing setting) ........ 182
Macro quote characters (assembler option) .......... 180
macros, definition of ............................. 214
MAC, definition of ................................ 214
mailbox (RTOS), definition of .................... 214
-make (iarbuild command line option) .............. 63
Make before debugging (IDE Project options) ..... 138
Make (Workspace window context menu) .............. 43
mangling, definition of ............................ 214
map file, generate from linker ..................... 199
Max number of errors (assembler option) .......... 185
Medium (Level setting) ............................ 170
memory
  definition of .................................... 214
filling unused ..................................... 202
memory access cost, definition of ................. 215
memory area, definition of ....................... 215
memory bank, definition of ....................... 215
memory map, definition of ....................... 215
memory model, definition of ..................... 215
menu bar ........................................... 88
menu (filename extension) .......................... 84
Menu (Key bindings option) ....................... 126
menus ................................................ 100
Merge duplicate sections (linker option) .......... 197
Messages window, amount of output ................. 135
Messages (IDE Options dialog box) ................ 135
metadata (subdirectory) ............................ 83
microcontroller, definition of .................... 215
microprocessor, definition of ..................... 215
migration, from earlier IAR compilers ............. 17
MISRA C
  compiler options ................................ 177
documentation ..................................... 17
general options ................................... 161
modules, definition of ............................ 215
Multiline code (Include listing setting) .......... 182
Multiply and accumulate, definition of ............ 214
multitasking, definition of ....................... 216
multi-file compilation ............................. 163–164, 167
definition of ...................................... 215
naming conventions .................................. 19
Navigate Backward (button) ........................ 89
Navigate Forward (button) ........................ 89
NDEBUG, preprocessor symbol ....................... 32
nested interrupts, definition of ................... 215
New Configuration dialog box (Project menu) ...... 47
New Document (button) ............................ 89
New Group (Register filter option) ................. 144
No dynamic read/write initialization (compiler option) .... 169
parameters

typographic convention ........................................ 19
when building from command line .......................... 63
parentheses and brackets, matching (in editor) ........ 71
part number, of this guide .................................. 2
Paste (button) .................................................... 89
paths
   assembler include files .................................. 183
   compiler include files .................................. 174
   relative, in Embedded Workbench ......................... 33, 91
   source files .................................................. 91
   pbd (filename extension) .................................. 84
   pbi (filename extension) .................................. 84
   Perform C++ Virtual Function Elimination (linker option) 197
   peripheral units, definition of ............................. 216
   pew (filename extension) .................................. 84
   pipeline, definition of ................................... 216
   placement, definition of .................................. 216
   Plain ‘char’ is (compiler option) ......................... 142
   Play a sound after build operations (IDE Project options) 138
   plugins
      arm (subdirectory) ........................................ 82
      common (subdirectory) ................................... 83
   pointers
      definition of ............................................. 216
      warn when stack pointer is out of range ................ 142
      Position-independence (code option) .................... 169
      Post-build command line (build actions option) .......... 192
      #pragma directive, definition of .......................... 216
      precedence, definition of ................................ 216
      preemptive multitasking, definition of .................. 216
   Preinclude file (compiler option) ......................... 174
   preprocessor
      definition of. See C-style preprocessor
      macros for initializing string variables ................ 62
      NDEBUG symbol ........................................... 32
   preprocessor directives
      definition of ............................................. 216
   text style in editor ......................................... 70
   Preprocessor output to file (compiler option) .......... 175
   Preprocessor (assembler option) ......................... 183
   Preprocessor (compiler options) ......................... 174
   prerequisites, programming experience ..................... 15
   Preserve comments (Preprocessor output
to file setting) ............................................. 175
   Press shortcut key (Key bindings option) ................ 126
   Pre-build command line (build actions option) ........ 192, 206
   Primary (Key bindings option) ............................ 126
   Printf formatter (general option) ......................... 160
   Processor mode (code option) ............................ 169
   Processor variant (general option) ....................... 156
   processor variant, definition of .......................... 217
   product overview
      directory structure ...................................... 81
      file types .................................................. 83
      program counter, definition of .......................... 217
      program location counter, definition of ................ 217
      programming experience .................................. 15
   Project Make, options ..................................... 137
   Project menu ................................................ 115
   project model ............................................... 29
   project options, definition of ............................ 217
   Project page (IDE Options dialog box) .................... 137
   Project with multi-file compilation
     (Workspace window icon) ................................ 41
   Project (Workspace window icon) ........................ 41
   projects
      adding files to ............................................ 35, 115
      build configuration, creating .......................... 35
      building .................................................... 61
      in batches ............................................... 61
      creating ................................................... 35
      definition of ............................................. 31, 217
      excluding groups and files .............................. 35
      files, moving ............................................. 35
      groups, creating .......................................... 35
      managing .................................................. 29
      organization ............................................. 30
removing items ........................................ 35
setting options ....................................... 59
source code control ................................. 34
testing .................................................. 63
version control systems ............................ 34
workspace, creating ................................. 35
$PROJ_DIRS (argument variable) .................. 121
$PROJ_FNAMEs (argument variable) ............... 121
$PROJ_PATHS (argument variable) ................. 121
Provable output format (converter option) ........ 188
PROM, definition of ................................ 217
Properties (Source code control menu) ........... 52
Properties (Subversion control menu) ............ 57
Proportional width font (IDE option) ............. 125
prototypes, verifying the existence of ............. 165
publication date, of this guide ..................... 2

Q
qualifiers, definition of. See type qualifiers
Quick Search text box ............................... 89

R
range, definition of ................................... 217
Raw binary image (linker option) .................. 196
reading guidelines .................................... 15
readme files ........................................... 82
See also release notes
read-only sections, definition of ................. 217
Read/write data (compiler option) ............... 169
real-time operating system, definition of ........ 217
real-time system, definition of .................... 217
Rebuild All (Workspace window context menu) .... 44
red padlock (source code control icon) .......... 56
Redo (button) ......................................... 89
reference information, typographic convention .. 19
Refresh (Source code control menu) ............. 52
Refresh (Subversion control menu) ............... 57
region expression, definition of .................. 217
region literal, definition of ....................... 217
register constant, definition of ................... 217
Register Filter (IDE Options dialog box) ........ 143
register locking, definition of ..................... 217
register variables, definition of .................. 217
registered trademarks ................................ 2
registers
  definition of ........................................ 217
  header files for in inc directory ................. 82
relative paths ........................................ 33, 91
relay, definition of ................................ 218
Release (Configuration factory setting) .......... 48
Reload last workspace at startup (IDE Project options) ... 138
relocatable segments, definition of ............ 218
relocatable segments, definition of ............ 218
remains
  compiler diagnostics .............................. 176
  linker diagnostics ................................ 201
Remove trailing blanks (editor option) .......... 130
Remove (Workspace window context menu) ........ 44
Rename Group dialog box ........................... 44
Rename (Workspace window context menu) ........ 44
Replace dialog box (Edit menu) ................. 108
Replace (button) .................................... 89
Require prototypes (C dialect setting) .......... 165
Reset All (Key bindings option) ................. 127
reset, definition of ................................ 218
restoring default factory settings ............... 61
Result in full size (Generate checksum setting) ... 203
Reverse byte order within word
  (Generate checksum setting) ....................... 203
Revert (Subversion control menu) ............... 57
ROM-monitor, definition of ....................... 218
root directory ...................................... 81
ropi, position-independence ....................... 169
Round Robin, definition of ....................... 218
RTOS, definition of ................................ 217
runtime libraries
  definition of ....................................... 218
specifying .......................................... 158
runtime model attributes, definition of .................. 218
rwpi, position-independence .................................. 169
R-value, definition of ......................................... 218

S

s (filename extension) ........................................... 85
saturation arithmetics, definition of ......................... 218
Save (button) ...................................................... 89
Save All (button) .................................................. 89
Save All (File menu) .............................................. 102
Save As (File menu) .............................................. 102
Save editor windows before building (IDE Project options) .................................................. 137
Save workspace and projects before building (IDE Project options) .............................................. 138
Save Workspace (File menu) .................................... 102
Save (button) ...................................................... 89
Save (File menu) .................................................. 102
Scan for changed files (editor option) ....................... 130
Scanf formatter (general option) ............................. 161
SCC. See source code control systems
scheduler (RTOS), definition of ............................. 218
scope, definition of ............................................. 218
scrolling, shortcut key for ................................     69
searching in editor windows .................................. 74
section
   definition of .................................................. 218
   for binary data .............................................. 196
section fragment, definition of .............................. 219
section selection, definition of .............................. 219
Section (Raw binary image setting) ......................... 196
Select SCC Provider dialog box (Project menu) ............ 53
selecting text, shortcut key for .............................. 69
semaphores, definition of ................................... 219
Service (External editor option) .............................. 132
Set as Active (Workspace window context menu) ........... 44
settings (directory) ........................................... 85
severity level
   changing default for compiler diagnostics .............. 175
   changing default for linker diagnostics ............... 200
SFR
   definition of .................................................. 219
   in header files .............................................. 82
sharing, definition of ....................................... 221
shortcut keys ..................................................... 69
Show bookmarks (editor option) ............................ 130
Show line numbers (editor option) ......................... 130
Show right margin (editor option) ......................... 129
side-effect, definition of .................................... 219
signals, definition of ........................................ 219
simulator, definition of ...................................... 219
size optimization ............................................... 170
Size (Generate checksum setting) ............................ 203
skeleton code, definition of ................................ 219
Source Code Control (IDE Options dialog box) ............ 139
Source file excluded from the build (Workspace window icon) ............................................... 42
source code
   including in compiler list file ......................... 173
   templates ..................................................... 71
Source code color in Disassembly window (IDE option) 140
source code control systems ................................. 34
Source Code Control (IDE Options dialog box) ............ 139
Source file excluded from the build
   (Workspace window icon) ................................ 42
source files
   editing .......................................................... 67
   managing in projects ...................................... 33
   paths to ...................................................... 33, 91
special function registers (SFR)
   definition of .................................................. 219
   in header files .............................................. 82
specifying options for multi-file compilation .............. 163
speed optimization ............................................ 170
src, arm (subdirectory) ...................................... 82
stack frames, definition of .................................. 220
stack segment, definition of ................................ 220
Stack (IDE Options dialog box) .............................. 141
Index

Standard C  
  making compiler adhere to .................................. 166  
  syntax, enabling in compiler ................................ 165  
standard libraries, definition of .............................. 220  
Standard (Language conformance setting) .................... 166  
Start address (Fill setting) .................................. 202  
static objects, definition of .................................. 220  
static overlay, definition of .................................. 220  
statically allocated memory, definition of .................. 220  
status bar ......................................................... 89  
Step into functions (IDE option) ............................... 140  
stepping, definition of ......................................... 219  
STL container expansion (IDE option) ......................... 141  
Stop build operation on (IDE Project options) .............. 137  
Stop Build (Workspace window context menu) ............... 44  
Strict (Language conformance setting) ....................... 166  
strings, text style in editor .................................. 70  
structure value, definition of .................................. 220  
Subversion states and corresponding icons ................... 57  
Suppress these diagnostics (compiler option) ............... 176  
Suppress these diagnostics (linker option) ................. 201  
svd (filename extension) ....................................... 85  
Symbol (Raw binary image setting) ............................ 196  
symbolic location, definition of ................................ 220  
symbols  
  See also user symbols  
  defining in assembler ......................................... 184  
  defining in compiler ......................................... 174  
  defining in linker ............................................ 200  
  definition of .................................................. 220  
syntax coloring  
  configuration files ........................................... 81  
in editor ......................................................... 70  
Syntax Coloring (Editor colors and fonts option) ............ 134  
Syntax highlighting (editor option) ........................... 129  
syntax highlighting, in editor window ......................... 70  

T  
  Tab Key Function (editor option) ............................ 129  
  Tab size (editor option) ...................................... 128  
  Tab spacing (assembler option) .............................. 183  
  Target (general options) ..................................... 155  
  TARGET_BNAMES (argument variable) ....................... 121  
  TARGET_BPATHS (argument variable) ....................... 121  
  TARGET_DIRS (argument variable) ........................... 121  
  TARGET_FNAMES (argument variable) ....................... 121  
  TARGET_PATHS (argument variable) ........................ 121  
target, definition of ......................................... 220  
task, definition of ............................................ 220  
  Template dialog box (Edit menu) ............................ 112  
templates for code, using .................................... 71  
tentative definition, definition of ............................ 220  
  Terminal I/O window, definition of ......................... 220  
  Terminal I/O (IDE Options dialog box) ....................... 145  
terminology .................................................... 18, 207  
text style ....................................................... 23  
terminology .................................................... 23  
text file (Workspace window icon) ............................ 42  
thread, definition of ......................................... 220  
  Thumb code, mixing with ARM code ........................... 169  
  Thumb (Processor mode setting) .............................. 169  
timer, definition of ......................................... 220  
timeslice, definition of ...................................... 220  
  Toggle Bookmark (button) .................................... 89  
  Toggle Breakpoint (button) .................................. 89  
  Tool Output window ......................................... 98  
toolbar, IDE ................................................... 89  
toolchain  
  extending ..................................................... 64  
  overview ...................................................... 23  
  STOOLKIT_DIRS (argument variable) ......................... 121  
tools icon, in this guide ..................................... 19  
  Tools menu ................................................... 124  
tools, user-configured ....................................... 146  
touch, open-source command line utility ....................... 62  
trademarks ..................................................... 2
transformations, enabled in compiler .......................... 171
translation unit, definition of ................................. 221
trap, definition of .............................................. 221
Treat all warnings as errors (compiler option) ............ 177
Treat all warnings as errors (linker option) ............... 202
Treat these as errors (compiler option) ..................... 177
Treat these as warnings (compiler option) .................. 201
Tutor, arm (subdirectory) ...................................... 82
type qualifiers, definition of .................................. 221
type (External editor option) .................................. 132
typographic conventions ........................................ 19
UBROF, definition of ........................................... 221
Undo Checkout (Source code control menu) ................ 52
Undo (button) .................................................... 89
Update intervals (IDE option) ................................ 141
Update (Subversion control menu) ......................... 57
Use as input (Generate checksum setting) .................... 204
Use Code Templates (editor option) ......................... 133
Use command line options (assembler option) ............ 185
Use command line options (compiler option) ................ 178
Use command line options (linker option) ................... 204
Use Custom Keyword File (editor option) .................... 133
Use External Editor (External editor option) ............... 132
Use register filter (Register filter option) .................... 144
User symbols are case sensitive (assembler option) ...... 179
$USER_NAMES (argument variable) ........................... 121
value expressions, definition of ............................... 221
variable length arrays .......................................... 165
variables, using in arguments ................................ 148
Version Control System menu .................................. 51, 56
Version Control System (Workspace window context menu) ............. 44
version control systems ....................................... 34
version number of Embedded Workbench .................. 154
of this guide ....................................................... 2
VFPv2 (FPU setting) ............................................ 156
VFPv3 (FPU setting) ............................................ 156
VFPv3 + NEON (FPU setting) .................................. 156
VFPv4 (FPU setting) ............................................ 156
VFPv4 + NEON (FPU setting) .................................. 156
VFP9-S (FPU setting) ............................................ 157
View menu ........................................................ 112
virtual address, definition of .................................. 221
virtual space, definition of .................................... 221
visualSTATE part of the tool chain ............................. 23
project file ......................................................... 85
volatile storage, definition of ................................ 221
von Neumann architecture, definition of ..................... 221
vsp (filename extension) ........................................ 85
Warn when exceeding stack threshold (Stack option) .... 142
Warn when stack pointer is out of bounds (Stack option) . 142
warnings compiler ................................................. 176–177
linker .............................................................. 201–202
Warnings from to (Warning setting) .......................... 185
warnings icon, in this guide .................................... 19
Warnings (assembler option) ................................... 184
watchpoints, definition of ...................................... 221
web sites, recommended ......................................... 18
When source resolves to multiple function instances ....... 140
Window menu ..................................................... 153
windows .......................................................... 87
organizing on the screen ......................................... 25
Workspace window .............................................. 41
drag-and-drop of files ........................................ 34
Workspace window icons ...................................... 41
Workspace (Workspace window icon) ....................... 41
workspaces
creating ....................................................... 35
using ....................................................... 35
wsdt (filename extension) ..................................... 85

x
xcl (filename extension) ....................................... 85
XLINK, definition of ........................................... 221

Z
zero-initialized sections, definition of ................. 221
zero-overhead loop, definition of ....................... 222
zone, definition of ........................................... 222

Symbols
#define options (linker options) ......................... 200
#define statement, in compiler ............................ 175
#define (Include cross-reference setting) ............. 182
#includeed text (Include listing setting) ............. 182
#pragma directive, definition of ....................... 216
% stack usage threshold (Stack option) .............. 142
$CONFIG_NAME$ (argument variable) ................. 121
$CUR_DIRS$ (argument variable) ....................... 121
$CUR_LINES$ (argument variable) ...................... 121
$DATE$ (argument variable) .............................. 121
$EW_DIRS$ (argument variable) ......................... 121
$EXE_DIRS$ (argument variable) ....................... 121
$FILE_DIRS$ (argument variable) ...................... 121
$FILE_FNAME$ (argument variable) .................. 121
$FILE_PATHS$ (argument variable) ................. 121
$LIST_DIRS$ (argument variable) ..................... 121
$OBJ_DIRS$ (argument variable) ....................... 121
$PROJ_DIRS$ (argument variable) ..................... 121
$PROJ_FNAME$ (argument variable) .................. 121
$PROJ_PATHS$ (argument variable) ................. 121
$TARGET_BNAME$ (argument variable) ............. 121
$TARGET_BPATHS$ (argument variable) ............. 121
$TARGET_DIRS$ (argument variable) ................. 121
$TARGET_FNAME$ (argument variable) ............. 121
$TARGET_PATHS$ (argument variable) ............. 121
$TOOLKIT_DIRS$ (argument variable) .............. 121
$USER_NAME$ (argument variable) .................... 121