
Program corrections for the IAR Embedded Workbench shared components 7.5.1  

Program Corrections  

 Version 7.5.0 EW24988 / IDE-2304  
In some situations, stepping out from an interrupt handler might cause the debugger to lose the connection 

to target.  

See also: IDE-1131  

 Version 7.5.0 EW22379 / IDE-1131  
In some situations, stepping out from an interrupt handler might cause the debugger to lose the connection 

to target.  

See also: IDE-2304  

 Version 7.4.1 IDE-3153  
During debug sessions, when collecting trace information, the debugger could become unresponsive or 

even crash.  

 Version 7.4.1 IDE-2977  
The build process can be severely slowed down if it cannot create temporary files in the %TEMP% folder.  

 Version 7.4.0 EW25929 / IDE-3015  
Dragging variables to the Data Sample Setup window can make the debugger unresponsive or even crash.  

 Version 7.4.0 EW24425 / IDE-2031  
Making the Disassembly window extremely high and wide could make it flicker.  

 Version 7.3.3 IDE-2993  
Some C-SPY debugger drivers that use 'internal' flash loaders sometimes generated an incorrect 

verification error message because the verification started before the driver could program the flash 

memory. The driver now programs the flash before verification starts.  

 Version 7.3.2 IDE-373  
It is now possible to rename a workspace by using Save Workspace As.  

See also: IDE-2463  

 Version 7.3.2 EW25803 / IDE-2938  
The Event Log in the Timeline window might display incorrect levels for values between 0 and 3 when you 

zoom in and out.  

 Version 7.3.2 EW22793 / IDE-2892  
A file corruption problem might cause dependency files (filename extension .dep) to describe some include 

files as files that generate output files (like, for example, .c and .cpp files). This will cause the IAR 

Embedded Workbench IDE to terminate unexpectedly when: - performing a "Find in Files" search with the 

"Project files and user include files" option selected or - choosing the editor window context menu 

command "Open file.h" on an #include "file.h" line  

See also: IDE-2779  

 Version 7.3.2 IDE-2884  
Autostep now saves the settings between debug sessions (not per project). It also prints a log when starting 

and stopping.  

 Version 7.3.2 IDE-2803  
The macro registration window is now more reliable with respect to visualizing the load status of macro 

files.  

 Version 7.3.2 EW25756 / IDE-2779  
Find in Files (Ctrl+Shift+F) might run out of memory if the source code includes recursive include files.  

See also: IDE-2892  

 Version 7.3.2 EW23642 / IDE-2704  
A problem, that caused breakpoints to end up on the wrong line when editing source code, has been 

corrected.  

 Version 7.3.2 EW25491 / IDE-2672  
The dependency file (.dep) may become corrupt with parallel builds.  



 Version 7.3.2 EW25637 / IDE-2669  
Inserting a new line in a line that contains only a comment will remove any white space before the 

comment.  

See also: IDE-1901  

 Version 7.3.2 EW25639 / IDE-2668  
When overriding inherited settings the dialog box title now shows the file for which settings are overridden.  

 Version 7.3.2 EW25328 / IDE-2495  
Enabling parallel may block post-build actions.  

See also: IDE-2476  

 Version 7.3.2 EW25314 / IDE-2480  
The first time a project is built with both multi-file compilation and parallel build enabled, no .out file is 

generated.  

See also: IDE-2477 IDE-2476  

 Version 7.3.2 EW25282 / IDE-2476  
Post-build fails to execute if both multi-file compilation and parallel build are enabled.  

See also: IDE-2495 IDE-2477 IDE-2480  

 Version 7.3.2 EW24049 / IDE-1901  
When the editor option Auto indent was enabled, pressing Enter when the insertion point was positioned 

before a space character in an editor window might cause the cursor to disappear.  

See also: IDE-2669  

 Version 7.3.0 EW25538 / IDE-2670  
Dropping an .eww file on Info Center starts an Example project save sequence.  

See also: IDE-2658  

 Version 7.3.0 EW25616 / IDE-2658  
Dropping an Embedded Workbench IDE workspace file (.eww) on the Information Center window started 

an Example project save sequence.  

See also: IDE-2670  

 Version 7.2.9 EW25727 / IDE-2783  
The context menu for setting breakpoints now discriminates for plausible identifiers  

 Version 7.2.8 EW25737 / IDE-2759  
When the ThreadX plugin was enabled C-SPY might crash unexpectedly when stopping at, for example, a 

breakpoint, even if the plugin was not being used.  

 Version 7.2.8 IDE-2757  
An error in retrieving the current locale could load the wrong code page, thus misinterpreting non-ASCII 

characters.  

 Version 7.2.8 EW25709 / IDE-2749  
Relative paths specified in the 'Output directories' boxes (available by choosing Project>Options>General 

Options>Output) might fail.  

See also: IDE-2464  

 Version 7.2.7 EW25555 / IDE-2904  
If a program contains several different unnamed structure types with equally named and typed fields, but 

with different offsets, the debugger can display some of the structure types incorrectly.  

 Version 7.2.7 EW25679 / IDE-2712  
The source browser could become unresponsive if the .pbi or .pbd file was corrupt.  

 Version 7.2.7 EW25666 / IDE-2703  
Double-clicking an .eww file do now start a new instance of IAR Embedded Workbench.  

See also: IDE-2660  

 Version 7.2.7 EW25650 / IDE-2699  
Saving the contents of the Interrupt Log window to a file now includes the Execution Time field.  

 Version 7.2.7 EW25535 / IDE-2689  
Too long texts in a tooltip could cause a crash. Now a text that does not fit is truncated.  



 Version 7.2.7 EW25351 / IDE-2676  
Pressing Alt+R in the Find in Files dialog box resulted in a Replace in Files action instead of selecting the 

Match regular expression option.  

 Version 7.2.7 EW25643 / IDE-2667  
The 'Replace with' field in the 'Replace in Files' dialog box no longer has a string size limit.  

 Version 7.2.7 EW25653 / IDE-2662  
Dragging and dropping an item within the Workspace window could lead to a crash.  

 Version 7.2.7 EW23376 / IDE-2660  
Windows could incorrectly issue the message "There was a problem sending the command to the program" 

when trying to open an .eww file.  

See also: IDE-2703  

 Version 7.2.7 EW25507 / IDE-2562  
Evaluating expressions that produced out-of-bounds results could cause the Debugger to crash. The 

problem affected the Watch windows and some plugins.  

 Version 7.2.7 EW25253 / IDE-2464  
Custom argument variables that expand to an absolute path are not recognized as such when expanded as a 

part of an output directory path on the General Options Output page in the Project Options dialog box.  

See also: IDE-2749  

 Version 7.2.7 EW24581 / IDE-2110  
In the simulator it was not possible to read registers (for instance the PC) in the execUserExecutionStopped 

macro. It is now fixed.  

 Version 7.2.5 EW25411 / IDE-2556  
Cspybat might fail to handle paths that contain spaces.  

 Version 7.2.4 EW25456 / IDE-2542  
A dependency on loading user arguments variables made that any failure on loading a user argument 

variable prevented subsequent loads, this is now corrected.  

 Version 7.2.4 IDE-2537  
Viewing external web content could cause script error alerts to be displayed  

 Version 7.2.4 IDE-2510  
The project connection file's element works properly now.  

 Version 7.2.4 EW25310 / IDE-2477  
Batch builds ignore the 'Tools>Options>Project>Stop build operation on' option.  

See also: IDE-2476 IDE-2480  

 Version 7.2.1 EW25317 / IDE-2486  
In some situations toggling a breakpoint in an editor window might create a new breakpoint instead of just 

toggling an existing one.  

 Version 7.2.1 EW25312 / IDE-2478  
For larger projects (~100 files under version control) the IDE could fail to update the Subversion status  

 Version 7.2.1 EW25267 / IDE-2463  
If you save a newly created workspace it might still be named "Untitled Workspace" on the Overview tab 

in the Workspace window.  

See also: IDE-373  

 Version 7.2.1 EW24549 / IDE-2111  
Under certain circumstances, for example when changing Project>Options or selecting another 

configuration, automatic Windows 8 compatibility settings can cause problems for IAR Embedded 

Workbench. Error message(s) produced then contain information similar to: - Faulting application path: 

$EW_DIR$\common\bin\IarIdePm.exe - Faulting module path: $EW_DIR$\common\bin\kernel.dll 

Workaround Install another copy of your IAR Embedded Workbench product in a different location or 

rename the directory of your current installation.  

 Version 7.2.1 EW23171 / IDE-1291  
If you switch the memory zone in the Disassembly window, the IAR Embedded Workbench IDE might 

stop responding.  



 Version 7.2.0 EW24980 / IDE-2303  
The Call Graph window might show incomplete results due to a change in the source browser output 

format.  

 Version 7.2.0 IDE-2295  
It is now possible to process all configurations defined in a project when running iarbuild. For example 

iarbuild proj.ewp -build * will build all configurations defined in project file proj.ewp  

 Version 7.2.0 EW24948 / IDE-2283  
Sometimes it is impossible to check in files with a file path relative to $PROJ_DIR$ when using the SCC 

interface.  

See also: IDE-2254  

 Version 7.2.0 EW23115 / IDE-1272  
Variables in The Live Watch window might be marked red even though their values remain unchanged 

through several updates of the window.  

 Version 7.1.5 EW19444 / IDE-802  
If you define "class xxx" or "struct xxx" and variable "xxx" in the same scope, it is impossible to evaluate 

variable "xxx" in the Watch/Quick Watch/Locals windows.  

 Version 7.1.5 EW25071 / IDE-2336  
The message box caused by an assertion is not modal. This means that it is possible to execute other 

commands, which could lead to a crash.  

 Version 7.1.5 EW25052 / IDE-2319  
If stack usage tracking is enabled, failure to read stack memory might cause false stack overflow warnings.  

 Version 7.1.5 EW25023 / IDE-2314  
Project connection files are no longer removed unintentionally from projects when you open a workspace.  

 Version 7.1.5 EW25019 / IDE-2309  
The source browser is not always re-enabled after having been disabled. (The source browser can 

temporarily be disabled, for example during a build or when a debug session is started).  

 Version 7.1.5 EW24972 / IDE-2291  
The Start Debugging and Stop Debugging commands cause resource leaks.  

See also: IDE-2292  

 Version 7.1.4 EW25037 / IDE-2313  
Sometimes the automatic update of the Code Coverage window fails to mark executed statements as 

executed.  

 Version 7.1.4 EW25007 / IDE-2306  
Expanding a pointer to function in the Watch/Quickwatch window might cause the debugger to crash.  

 Version 7.1.4 EW25034 / IDE-2300  
If "--code_coverage_file" is specified as a debugger extra option, it is appended at the end of the 

autogenerated cspybat command line line. This is incorrect because it is a general option, it must be placed 

before the "--backend" option.  

 Version 7.1.4 EW24974 / IDE-2292  
The SFR Setup window leaks resources.  

See also: IDE-2291  

 Version 7.1.4 EW24954 / IDE-2284  
Data Log graph settings in the Timeline window are not preserved.  

 Version 7.1.4 EW24795 / IDE-2254  
An unreliable connection to the SCC server could prevent the SCC client from checking in/out files.  

See also: IDE-2283  

 Version 7.1.2 EW24827 / IDE-2274  
Long function names are truncated in the Call Stack window.  

 Version 7.1.2 IDE-2267  
Pointers now may be displayed in Watch windows with the same syntax as for arrays, i.e. ptr;{,}  



 Version 7.1.2 EW24906 / IDE-2265  
When processing a file with a large number of lines, the source browser might take a very long time, thus 

preventing the build tools from working.  

 Version 7.1.1 EW24709 / IDE-2185  
Adding a C-RUN rule or changing the default C-RUN action caused the IDE to crash when the C-RUN 

windows were grouped together.  

 Version 7.1.0 EW24421 / IDE-2012  
It is not possible to view a variable in the Watch window as a 64 bit signed or unsigned integer, as the 

Watch window is missing the Show As>64-bit Signed and 64-bit Unsigned commands.  

 Version 7.0.7 EW24875 / IDE-2268  
The Workspace window leaks icon resources.  

 Version 7.0.7 EW24878 / IDE-2238  
When code completion is used in an editor window, member/function/variable names are not correctly 

completed with the item selected from the completion list.  

 Version 7.0.7 EW24868 / IDE-2237  
The Call Stack window leaks resources.  

See also: IDE-1078  

 Version 7.0.6 EW24717 / IDE-2208  
You must click in an editor window before using shortcuts in it, if you just closed another editor window.  

 Version 7.0.6 EW24759 / IDE-2206  
Using the $WS_DIR$ argument variable in the project file could cause iarbuild.exe to exit abnormally.  

 Version 7.0.6 EW24719 / IDE-2197  
The SymList plugin should be loaded by default but is not.  

 Version 7.0.6 EW21235 / IDE-2174  
Argument variables related to the build output (e.g., $TARGET_DIR$ and $TARGET_BNAME$) will 

now be expanded correctly when the output file itself is missing.  

 Version 7.0.6 EW24641 / IDE-2145  
The progress information when examples were downloaded was incorrect in the Japanese language mode.  

 Version 7.0.6 EW24660 / IDE-2144  
When accessing files in the project, Windows could display the error message: "The requested operation 

cannot be performed on a file with a user-mapped section open." The reason was that the source browser 

could lock the files.  

 Version 7.0.6 EW24599 / IDE-2132  
Some objects of a class/struct/union type might be impossible to expand (there is no '+' sign in front of 

them).  

 Version 7.0.6 IDE-2128  
Code completion can now be manually invoked (using the Edit menu or Ctrl+Space), even if the cursor is 

not placed after '->', '::' or '.'. Invoking code completion by typing a period ('.') still works, but using 

Ctrl+Space is the recommended method.  

 Version 7.0.6 EW24586 / IDE-2112  
A mismatch when converting character sets using Active Code Page encoding mixed with UTF8 might 

make some paths unusable for the source browser.  

 Version 7.0.5 EW24607 / IDE-2125  
The menu command View>Cores was disabled even though the project was configured for asymmetrical 

multicore debugging.  

 Version 7.0.3 EW24593 / IDE-2117  
Sometimes SFR groups might not be shown in the Register window even though they are defined in the 

.ddf file.  

 Version 7.0.3 EW24589 / IDE-2115  
In some rare cases data is shown as code in the Disassembly window.  

 Version 7.0.3 EW24552 / IDE-2099  
In some cases, using a macro to save target memory to a file might cause the debugger to crash.  



 Version 7.0.3 EW24339 / IDE-2032  
The Sampled Graphs window displays the time in tooltips in seconds (s) instead of milliseconds (ms).  

 Version 7.0.3 EW24399 / IDE-1997  
Very rarely, adding a variable to the Watch window might cause the debugger to exit abnormally.  

 Version 7.0.0 IDE-1867  
Debugging cannot be started if the path to the Eclipse workspace and project contains non-ASCII 

characters.  

 Version 6.6.9 EW24451 / IDE-2062  
When the HTML-format linker map file is opened, it is not automatically updated even though the option 

'Scan for changed files' is enabled. Map files in text format are automatically updated.  

 Version 6.6.9 EW24468 / IDE-2052  
Auto indent now only plays a sound to indicate that the file is read-only.  

 Version 6.6.9 EW24472 / IDE-2038  
The Configure Viewers dialog does no longer crash when command lines longer than 1024 characters are 

entered.  

 Version 6.6.9 EW24474 / IDE-2025  
If a file is opened in the text editor using a Windows hard link, and then saved, the hard link will be 

replaces by a regular file path.  

 Version 6.6.8 IDE-2017  
Default key bindings are no longer active when new ones are defined.  

 Version 6.6.8 EW24417 / IDE-2013  
It is now possible to redefine a default key binding. However, it is not possible to permanently remove a 

default key binding; it will be restored in the next session.  

 Version 6.6.8 EW24302 / IDE-1939  
The number of editor code template entries has been increased to 2000.  

 Version 6.6.7 EW24375 / IDE-1984  
Removing of a breakpoint while the debugger is executing might make the debugger unstable.  

 Version 6.6.6 EW24266 / IDE-1967  
Defining the main function in a non-standard way that is not int main(int argc, char 

*argv[]) or int main(void) might limit source browse information.  

 Version 6.6.6 EW24313 / IDE-1948  
If an externally built ELF/DWARF object file contained a struct declared in a function scope prototype, the 

debugger could exit unexpectedly while downloading the file.  

 Version 6.6.6 EW24306 / IDE-1941  
Selecting the option 'Options>C/C++ Compiler>Preprocessor>Ignore standard include directories' caused 

the source browser to stop working.  

 Version 6.6.6 EW24304 / IDE-1940  
Increased the maximum number of functions in the Go To Function dropdown menu from 200 to 2000.  

 Version 6.6.6 EW24292 / IDE-1933  
When displaying the interrupt log in the Timeline window, the interrupt duration was always displayed in 

time units, even if Time Axis Unit was set to Cycles.  

 Version 6.6.6 EW24274 / IDE-1929  
If you created a source file using the "File>New File" command, code completion did not work until you 

closed and reopened the file in the editor.  

 Version 6.6.6 EW23383 / IDE-1170  
Lines over a certain length could not be viewed in their entirety in the Batch Build dialog box.  

 Version 6.6.5 EW24242 / IDE-1918  
When replacing text by clicking "Replace All" in the "Replace in Files" dialog box, truncation did not work 

correctly. That meant that if the replacement string was shorter than the text to replace, the resulting file 

would contain extra, unwanted characters at the end.  

 Version 6.6.4 EW20933 / IDE-374  
If you create a project using IAR Embedded Workbench installed together with visualSTATE and later 



open that project using IAR Embedded Workbench without visualSTATE, the warning "The project 'xx' 

contains the unknown tool 'Coder'" will be displayed. There is no way to suppress this warning other than 

editing the project file.  

 Version 6.6.4 EW24201 / IDE-1907  
Autocompletion, the "Go to function" button, and tooltip information did not work in IAR Embedded 

Workbench products based on the common components version 6.6.2 and 6.6.3.  

 Version 6.6.4 EW24190 / IDE-1904  
An .svd file that contains extremly long lines might cause the IAR Embedded Workbench IDE to stop 

responding.  

 Version 6.6.4 EW24027 / IDE-1858  
Using the argument variables $TARGET_BNAME$ and/or $TARGET_BPATH$ when specifying the 

linker output file could lead to unexpected termination.  

 Version 6.6.3 EW24183 / IDE-1882  
When the debugger stops at a breakpoint, the "Go to function" button and the insertion point position on the 

status bar are not visible until you click in the editor window.  

 Version 6.6.2 EW24170 / IDE-1893  
In some cases IarBuild failed to expand argument variables based on environment variables 

($_ENVVAR_$).  

 Version 6.6.2 EW24164 / IDE-1889  
ARM only: The SVD reader can now handle elements that do not contain any dimElementGroup.  

 Version 6.6.2 EW24124 / IDE-1880  
End of file (EOF) condition of stdin in the Terminal I/O is now handled correctly, making _read(), fread() 

and similar functions to return the proper status.  

 Version 6.6.2 EW24116 / IDE-1875  
Include paths that did not match the capitalization of the actual files and directories were ignored by the 

Source Browser.  

 Version 6.6.10 EW23494 / IDE-1362  
Deleting the folded line in the Editor window produces the gap in line numbering.  

 Version 6.6.1 EW24079 / IDE-1874  
Find/Replace in files sometimes failed to find matches in files that contain utf-8 encoded text.  

 Version 6.6.1 EW24053 / IDE-1865  
If you started and stopped the debugger several times during one IAR Embedded Workbench session, a 

serious memory leak could lead to abnormal termination.  

 Version 6.6.0 EW24010 / IDE-1824  
Trailing blanks were sometimes not trimmed from the name of the linker output file, which could cause 

problems when the extension ".out" was considered to be different than ".out ".  

 Version 6.6.0 EW23984 / IDE-1792  
Using of the argument variables $DATE$ and $USER_NAME$ in, for example, a file path could lead to a 

"Standard multi tool failed to establish output file name" error.  

 Version 6.6.0 EW23948 / IDE-1755  
Auto-indent always inserted spaces even when the option "Insert tab" was selected.  

 Version 6.6.0 IDE-1436  
Added support for restricting a search to the selected text. Supported in Find, Replace and Incremental 

search dialogs.  

 Version 6.6.0 EW23317 / IDE-1323  
The editor now uses different colors and fonts for the preprocessor information.  

 Version 6.6.0 EW23263 / IDE-1322  
Expanding a huge array in a debugger watch window could cause an out-of-memory crash. Now array 

expansion is halted after 5000 elements, but can be continued manually.  

 Version 6.5.9 EW23934 / IDE-1743  
Sometimes, when performing the internal integrity check, the flash loader caused a false alarm. This 

resulted in a long list of incorrect warnings in the flash0.trace file.  



 Version 6.5.9 EW23917 / IDE-1709  
Executing a Reset command while debugging could lead to a crash if the Stack window was open.  

 Version 6.5.9 EW23818 / IDE-1610  
The CPU load caused by monitoring the time stamps of the project files (and their dependencies) has been 

reduced.  

 Version 6.5.8 EW23810 / IDE-1609  
"Go to definition" failed to find functions defined in .cpp files if they were defined with extern 'C' linkage.  

 Version 6.5.7 EW23836 / IDE-1637  
Clicking the expand icon or scrolling in the Source Browser window before the information has been 

completely collected could lead to crash.  

 Version 6.5.7 EW23853 / IDE-1580  
When stopping at a breakpoint in the Disassembly window, the current position arrow is not visible, only 

the red breakpoint icon.  

 Version 6.5.6 EW23829 / IDE-1605  
In some situations, IAR Embedded Workbench might incorrectly stop reporting build errors if you retry 

Project>Make several times in a row without making any changes to source files. This is, of course 

incorrect. The errors are still there even if they are not reported, and the build will not be successful despite 

being reported as such.  

See also: IDE-1471  

 Version 6.5.5 IDE-1595  
Running IarBuild.exe in a Jenkins environment can fail with a "Build aborted" message. Building the same 

project with IarBuild.exe without Jenkins works fine.  

 Version 6.5.4 EW23757 / IDE-1569  
If a function was defined using the "static" keyword but declared without it, or vice versa, a "Go to 

definition" command for this function failed.  

 Version 6.5.4 EW23741 / IDE-1497  
Auto-indentation could in sometimes fail to indent a line directly after a preprocessor directive.  

 Version 6.5.4 EW23648 / IDE-1474  
If a search for a regular expression in the Find in Files window produced a result containing line breaks, 

only the first line was displayed.  

 Version 6.5.3 EW23743 / IDE-1498  
Undoing an auto indentation command applied to a source block required an undo for every line in the 

block. Now a single undo command reverts the entire block.  

 Version 6.5.3 EW23714 / IDE-1476  
Setting a breakpoint in a uC/OS-III project could make C-SPY unresponsive. This has been corrected.  

 Version 6.5.3 EW23669 / IDE-1475  
The "Go to Definition" and "Go to Declaration" commands did not find names located in comments or 

inactive source code.  

 Version 6.5.3 EW23726 / IDE-1473  
In some cases incorrect project settings caused the debugger to issue an error upon starting, only to exit 

unexpectedly after the error was corrected. This no longer happens.  

 Version 6.5.3 EW23711 / IDE-1472  
Projects with many include files and/or many #define's could make the source browser slow. This has been 

corrected.  

 Version 6.5.3 EW23688 / IDE-1471  
The source browser no longer issues repeated warnings if undefined environment variables are part of any 

include path.  

See also: IDE-1605  

 Version 6.5.3 EW23704 / IDE-1466  
If a "Project>Project Connection" command added an include path to the "Additional include directories" 

field on the "Project>Options>C/C++ Compiler>Preprocessor" options page, and that path contained any 

environment variables like "$PROJ_DIR$", they were expanded and the path was saved that way. Now 

paths are saved unconverted.  



 Version 6.5.3 EW23463 / IDE-1450  
It was impossible to place the insertion point to edit names of variables in undocked windows.  

 Version 6.5.3 EW23234 / IDE-1297  
The editor's "Open include file" command did not work correctly for include files excluded from the build.  

 Version 6.5.2 EW23525 / IDE-1455  
Because of a problem with processing paths containing "..\\.." patterns, some include files could be 

displayed twice in the Workspace window.  

 Version 6.5.2 EW23619 / IDE-1443  
Some problems that could cause the IDE to freeze terminating a debug session have been corrected.  

 Version 6.5.2 EW23620 / IDE-1441  
Executing a Debug>Memory>Restore... command to non-writable memory gave an incorrect error 

message. This message is correct now.  

 Version 6.5.2 EW23612 / IDE-1420  
The source browser generated incomplete information when the --preinclude directive was used. This has 

been corrected.  

 Version 6.5.2 EW23610 / IDE-1419  
In previous versions of IAR Embedded Workbench, source browser and build status updates stopped when 

the IDE was not the foreground process. This behavior is now controlled by an option in the Tools>Project 

dialog box.  

 Version 6.5.2 EW23596 / IDE-1414  
Sometimes, setting a breakpoint in highly optimized code could cause IAR Embedded Workbench to exit 

unexpectedly. This has been corrected.  

 Version 6.5.2 EW23434 / IDE-1349  
Expressions in the Live Watch window which did not evaluate to a C/C++ lvalue did not update during 

execution. This has been corrected.  

 Version 6.5.2 EW23432 / IDE-1344  
Because of a missing notification, the Source Browser window could display "Collecting information..." for 

ever. Now it is updated as soon as the source browse information is ready.  

 Version 6.5.12 EW24172 / IDE-1897  
The source browser did not recognize a mixed case file extension (e.g. *.Cpp) as a valid extension for a 

C++ source file.  

 Version 6.5.12 EW23420 / IDE-1644  
Because linker input files were sorted case-sensitive, the output files could differ from linking to linking, 

even though the linker input files were identical, binary-wise. However, the output files were correct in all 

cases.  

 Version 6.5.12 EW23825 / IDE-1613  
Reloading an externally modified project file (.ewp) might crash the debugger.  

 Version 6.5.11 EW23991 / IDE-1785  
The source browser did not recognize target-specific extended keywords for M16C, RL78, V850 and RX. 

If there were more than 100 keywords in a source file, the source browsing information was not generated 

(too many errors).  

 Version 6.4.8 EW23564 / IDE-1394  
The text editor failed to automatically detect the character encoding that was used, because of missing 

DLLs. This has now been corrected.  

 Version 6.4.7 EW23514 / IDE-1380  
Creating or editing configurations in the Memory Configuration dialog box when running a session in 

Japanese could cause IAR Embedded Workbench to exit unexpectedly.  

 Version 6.4.7 EW23500 / IDE-1366  
The commands Next/Previous Bookmark now wrap at the beginning and the end of the document.  

 Version 6.4.6 EW23441 / IDE-1361  
When the downloaded application does not contain any C variables (with static storage duration), the I-jet 

driver will no longer issue a warning about finding no variables in memory designated as RAM.  



 Version 6.4.6 EW23474 / IDE-1359  
In some cases stopping execution in the heavily optimized code could cause the debugger to exit 

abnormally. This has been corrected.  

 Version 6.4.6 EW23471 / IDE-1358  
Executing the context menu command "Force" on a vacant area in the "Forced Interrupt" window caused 

the debugger to exit unexpectedly. This has been corrected.  

 Version 6.4.6 EW23330 / IDE-1356  
C-SPY could misinterpret certain flags in an ELF file and consider some read-only segments writable. This 

could interfere with memory integrity checks when launching a debug session. This has been corrected.  

 Version 6.4.6 EW23451 / IDE-1354  
It is no longer possible in the Memory Configuration Window to enter an end address that is lower than the 

start address.  

 Version 6.4.6 EW23454 / IDE-1353  
The "Project>Import File List..." dialog box in the Japanese version of IAR Embedded Workbench did not 

show *.ewp files by default. This has been corrected.  

 Version 6.4.6 EW23428 / IDE-1345  
Strings and C/C++-style comments were not colored in assembler files. This has been corrected.  

 Version 6.4.5 EW23409 / IDE-1333  
The text editor will now correctly reload files that were opened as read-only.  

 Version 6.4.5 EW23403 / IDE-1332  
The "Memory Restore" command did not work in some cases for the Motorola format. This has been 

corrected.  

 Version 6.4.5 EW23334 / IDE-1331  
The horizontal scroll bar in the editor window did not show all of a very long line. This has been corrected.  

 Version 6.4.5 EW23336 / IDE-1330  
Sometimes the localized (Japanese) strings were garbled in the Watch window. This has been corrected.  

 Version 6.4.5 EW23341 / IDE-1329  
The Memory window lost focus when editing memory content after entering one unit. This has been 

corrected.  

 Version 6.4.5 EW23378 / IDE-1328  
Defining a typedef and a struct using the same identifier caused the source browser to stop working. This 

has been corrected.  

 Version 6.4.5 EW23085 / IDE-1267  
Specifying the "General Options->Output->Executables/libraries" path with a trailing space caused IAR 

Embedded Workbench to quit unexpectedly. This no longer occurs.  

 Version 6.4.4 EW23343 / IDE-1325  
A project in an initial stage (with missing source files) may crash the SourceBrowser when doing a 

Rebuild. This has been corrected.  

 Version 6.4.2 EW23283 / IDE-1320  
The IDE could crash when double clicking a leaf in the code coverage window, due to a missing path in the 

editor view. This is now fixed.  

 Version 6.4.2 EW23285 / IDE-1319  
The editor could become sluggish when operating on files located on a slow network drive. Speed has been 

improved by changing the behavior of file monitoring (i.e. detecting file changes made externally).  

 Version 6.4.2 EW23324 / IDE-1318  
Input via a non-Latin keyboard (e.g. Cyrillic) was not working. This has been corrected.  

 Version 6.4.2 EW23287 / IDE-1316  
The IDE no longer becomes unresponsive when .ddf file containing empty sections is opened.  

 Version 6.4.2 EW23278 / IDE-1305  
Caret color is now set to white if the background is dark, and black otherwise.  



 Version 6.4.2 EW23265 / IDE-1303  
The editor no longer tries to identify special comments like '//!' or '///' (e.g. Doxygen or javadoc comments). 

Now everything after '//' is handled as a normal C++ comment.  

 Version 6.4.2 EW23253 / IDE-1296  
Reloaded editor files were incorrectly scrolled to the beginning. They are now opened at the expected 

location.  

 Version 6.4.0 EW22351 / IDE-1279  
The source browser could cause the IDE to become unresponsive if the license for the compiler could not 

be verified. This no longer occurs.  

 Version 6.4.0 EW23111 / IDE-1270  
A failed post-build step was not included in error count displayed in the status bar. This has been corrected.  

 Version 6.4.0 EW23041 / IDE-1259  
Setting/clearing breakpoints on the lowest line in the Disassembly window by clicking on the leftmost 

column now works correctly in all cases.  

 Version 6.4.0 EW22820 / IDE-1221  
The Timeline window was not updated correctly when data log breakpoints were enabled/disabled during a 

debug session. This has been corrected.  

 Version 6.3.6 EW22665 / IDE-1185  
Using the __setSimBreak C-SPY macro to set a "write" breakpoint ("W") resulted in a breakpoint set as 

"read" ("R") instead. This has been corrected.  

 Version 6.3.22 EW23261 / IDE-1317  
It is now possible to restore an srec/hex file via the debugger using the 

"Debugger>Memory>Restore>Memory Restore" command.  

 Version 6.3.2 EW22463 / IDE-1147  
The command 'Undo Checkout' in the Version Control System submenu for SCC did not work. This has 

been corrected.  

 Version 6.3.19 EW23623 / IDE-1458  
In some cases the debugger could exit unexpectedly when stopping at a breakpoint with a Condition and/or 

Action to be executed.  

 Version 6.3.18 EW23123 / IDE-1273  
C-SPY could exit unexpectedly when stepping through heavily optimized code containing cross calls. This 

has been corrected.  

 Version 6.3.17 EW23081 / IDE-1265  
Choosing Debug>Memory>Save/Restore while the target was running could produce incorrect data. These 

operations are now disabled when the target is running.  

 Version 6.3.17 EW23031 / IDE-1255  
It was impossible to set the offset on the Project>Options>Debugger>Images page to a value greater than 

0x7FFFFFFF. This is possible now.  

 Version 6.3.17 EW22969 / IDE-1251  
Previously IAR Embedded Workbench did not remember a connection to some source control systems (for 

example ClearCase) between sessions. This has been corrected.  

 Version 6.3.16 EW23009 / IDE-1252  
The Interrupt Log Summary window could show uninitialized content directly after a debugging session 

started. This has been corrected.  

 Version 6.3.15 EW22923 / IDE-1236  
In some cases executing multiple Page Up commands in the Disassembly window could cause the code to 

be disassembled incorrectly. This has been corrected.  

 Version 6.3.15 EW22868 / IDE-1235  
Trying to load a file that contains modules produced with gcc could cause the IDE to crash. This has been 

corrected.  

 Version 6.3.15 EW22901 / IDE-1231  
The contents of the Statics window were not filtered when it was opened after the start of a debugging 



session. The correct contents were not displayed until after a window update (for example after executing a 

step command). This has been corrected.  

 Version 6.3.14 EW22920 / IDE-1232  
The Source Browser failed to browse include files specified with an absolute path. This has been corrected.  

 Version 6.3.14 EW22893 / IDE-1230  
The IAR Embedded Workbench integration with Subversion could misinterpret some Subversion version 

1.7.x messages, which resulted in the internal error: "SVN: Internal Error: SVN_Status - did not find file". 

This has been corrected.  

 Version 6.3.14 EW22861 / IDE-1222  
{anchor} When forcing an interrupt the pending flag was not set.  

 Version 6.3.12 EW22710 / IDE-1217  
If a path for the build log file contained an argument variable (like "$PROJ_DIR$) and the "Overwrite old 

file" option was selected, the log was still appended to the existing file. This has been corrected.  

 Version 6.3.12 EW22795 / IDE-1215  
Release Note: Function-like macros with zero parameters caused the Source Browser to lose the definition 

following the macro. For example, after this definition: #define MACRO() macro_body x in the following 

lines would not be recognized the Source Browser: MACRO() int x; This has been corrected.  

 Version 6.3.12 IDE-1214  
{anchor} Under some conditions, the debug server (CSpyServer.exe) may be left hanging after a shutdown 

has been requested.  

 Version 6.3.12 EW22784 / IDE-1210  
The debugger might close unexpectedly during long trace acquisition (several hours) in the time line 

window. This no longer happens.  

 Version 6.3.10 EW22766 / IDE-1203  
In some cases, single stepping or running to breakpoints when the Call Stack window is open could make 

the IDE unresponsive. This has been corrected.  

 Version 6.3.10 EW22764 / IDE-1202  
If you used two or more monitors, ending a debug session with the main IDE window open on one monitor 

but the Disassembly window on another monitor, IAR Embedded Workbench could terminate 

unexpectedly when you restarted the debug session. This has been corrected.  

 Version 6.3.10 EW22528 / IDE-1188  
A minor memory leak when using the source browser has been corrected.  

 Version 6.3.10 EW22667 / IDE-1187  
In watch windows, pointers to ARM Thumb functions now correctly show the function name.  

 Version 6.3.10 EW22609 / IDE-1174  
Files in editor panes were not always restored to the correct panes. This has been corrected.  

 Version 6.3.1 EW22409 / IDE-1136  
If the Watch window was not already open, executing "Add to Watch" on a selection in the editor window 

just opened the Watch window without adding an entry to it. Now it does.  

 Version 6.3.1 EW22401 / IDE-1133  
A build problem where argument variables, in some circumstances, were not expanded relative to the 

configuration actually being built has been corrected  

 Version 6.3.0 EW23385 / IDE-1326  
If two or more IAR Embedded Workbench toolchains (for different microcontroller architectures) were 

installed in the same directory, and some of the toolchains were only available in English, launching IAR 

Embedded Workbench in a non-English language meant that the Information Center was not available for 

English-only toolchains. This has been corrected.  

 Version 6.3.0 EW22342 / IDE-1123  
If two or more IAR Embedded Workbench toolchains (for different microcontroller architectures) were 

installed in the same directory, and some of the toolchains were only available in English, launching IAR 

Embedded Workbench in a non-English language meant that the Information Center was not available for 

English-only toolchains. This has been corrected.  



 Version 6.1.6 EW22203 / IDE-1093  
Errors and warnings detected when building were reported as twice as many they really were. This has 

been corrected.  

 Version 6.1.5 EW21536 / IDE-829  
The "Go to definition" command applied to a symbol which definition was located in a conditionally 

included header file could fail. This has been corrected.  

 Version 6.1.3 EW22125 / IDE-1072  
In some cases, when using trace based data features, executing an application in the debugger over a long 

time could result in a "Runtime Error!" message and abrupt IAR Embedded Workbench termination. This 

no longer occurs.  

 Version 6.1.0 EW21840 / IDE-1043  
Using a path containing ".." to defined output directories could make it impossible to start the debugger. 

This has been corrected.  

 Version 6.1.0 EW21869 / IDE-1042  
Namespaces could not be used when the IAR C-SPY Debugger resolved names. This has been corrected.  

 Version 6.1.0 EW22005 / IDE-1041  
The "Project>Options>Linker>Output>Output file:" text box accepted a file path instead of just a file name 

which could lead to project building problems. This has been corrected and the option has been renamed.  

 Version 6.0.0 EW21413 / IDE-682  
Opening a context menu in the Editor window will no longer produce strange error entries in the Debug 

Log window.  

See also: IDE-678  

 Version 5.8.2 EW22178 / IDE-1088  
Recursive definitions of a preprocessor macro no longer causes IAR Embedded Workbench to terminate 

abnormally.  

 Version 5.8.2 EW22127 / IDE-1086  
Large and complex projects no longer cause the IAR Embedded Workbench source browser to freeze.  

 Version 5.8.2 EW22076 / IDE-1061  
The IDE command Stop Build now works properly when it is applied to pre- or post build actions when 

they are started in a new command shell.  

 Version 5.8.1 EW22156 / IDE-1078  
IAR Embedded Workbench could leak GDI (Graphics Device Interface) objects in some cases. This no 

longer occurs.  

See also: IDE-2237  

 Version 5.8.1 EW21751 / IDE-1008  
Corrupt .wsdt and .dbgdt files in a project's settings directory could cause IAR Embedded Workbench to 

quit unexpectedly. Now, if this situation occurs, the IAR Embedded Workbench IDE reverts to default 

layouts.  

 Version 5.8.1 EW21924 / IDE-1006  
A serious memory leak could lead to IAR Embedded Workench abnormal termination. This has been 

corrected.  

 Version 5.6.7 EW23875 / IDE-1667  
Printing more than 16,000 characters to the Terminal I/O window produces incorrect output.  

 Version 5.6.3 EW21603 / IDE-833  
Incorrect address of members of anonymous structs and unions was shown in the Live Watch window. This 

has been corrected.  

 Version 5.6.3 EW21565 / IDE-828  
Large and complex projects could cause the IAR Embedded Workbench source browser to freeze. This has 

been corrected.  

 Version 5.6.2 EW21532 / IDE-814  
If you exited the debugger while the application was running and the option "Leave Target Running" is 

selected, an incorrect stack treshold exceeding warning was issued. This no longer happens.  



 Version 5.6.2 EW21491 / IDE-750  
Adding a file to a project will now use the current case of the file name, even if it was previously included 

in the project with another case.  

 Version 5.6.0 EW21413 / IDE-678  
Opening a context menu in the Editor window will no longer produce strange error entries in the Debug 

Log window.  

See also: IDE-682  

 Version 5.6.0 EW20856 / IDE-349  
There was a problem when switching from multi-file compilation mode to single-file compilation, causing 

the error "Build error: Multiple tools write to the same file" to be issued. This problem has been corrected.  

 Version 5.5.5 EW21391 / IDE-633  
Dragging an expression containing a dereferenced function pointer onto the Memory window no longer 

causes the debugger to crash.  

 Version 5.5.4 EW21255 / IDE-562  
The source file paths retrieved from the externally built ELF/DWARF object file are now correctly 

interpreted by the debugger.  

 Version 5.5.3 EW21301 / IDE-564  
Sometimes, while stepping in a complex C++ program, the displayed source code location did not reflect 

the current program counter. This has been corrected.  

 Version 5.5.0 EW20980 / IDE-422  
A rare problem with downloading files in the Motorola S37 format into the wrong memory location has 

been corrected.  
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