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HW-RTOS Accelerator Kernel Viewer Plug-in for C-SPY   User's Guide 

Introduction 
 

This document explains the following. 

- Overview of HW-RTOS Accelerator Kernel Viewer Plug-in for C-SPY 

- How to Installation procedure 

- How to use 

 
Target Device 
 

R-IN Family R-IN32M3 Series 

  R-IN32M4 Series 

RZ Family RZ/T1 Series 

  RZ/N1 Series 
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1. Introduction 
 

1.1 Overview 
 
The HW-RTOS accelerator Kernel Viewer Plug-in for C-SPY is a plug-in for displaying HW-RTOS kernel 

information of the R-IN Engine inside the C-SPY debugger of the IAR Embedded Workbench IDE. 
 
 

1.2 Limitations 
 
The plug-in is supported by the C-SPY debugger of IAR Embedded Workbench for Arm v8.3 for Renesas devices 

R-IN32M3, R-IN32M4, RZ/T1, and RZ/N1. 
 

 The plug-in acquires information from HW-RTOS only when reaching a break point. If a HW ISR happens during 
this time, there is a possibility that a HW ISR is lost. Best is therefore to turn off the plug-in if there is suspicion that 
a HW ISR is lost, and to not have breakpoints active during final testing. Explanation: This is caused by the plug-in's 
direct access to HW-RTOS register and memory, which may in rare circumstances compete with a HW ISR 
occurring in silicon. Observe that the HW-RTOS library also has indirect access to HW-RTOS via the normal system 
call (command) interface for which this conflict does not exist, however that interface cannot provide full kernel 
information. 
 

For RZ/N1 GOAL software, the plug-in gets part of the kernel information from GOAL. If a task function name is 
"goal_tgtTaskWrapper", the plug-in assumes that the task is used for GOAL. Additionally, if task stack size is a 
default value defined by GOAL, "Stack Size" field in task status window shows 0. 
 

If you encounter a problem with this plug-in's behavior, or if you have any comments or requests, please contact 
our support desk. 
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2. Folder structure 
 

When IAR Embedded Workbench for Arm is installed, it becomes the following folder structure. 
 
C:/Program Files 

└─IAR Systems 

    └─Embedded Workbench 8.1 

        └─arm 

            ├─doc 

            │ ├─HWRTOSplugin.ENU.pdf 

            │ └─HWRTOSplugin.JPN.pdf 

            └─plugins 

                └─rtos  

                    └─HWRTOSplugin 

                        ├─HWRTOSplugin.dll 

                        └─HWRTOSplugin.ewplugin 
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3. Settings for using plug-ins 
 

3.1 Create debug information 
 
Start IAR Embedded Workbench for Arm. 
To enable the plug-in to reference necessary debug information, select [Project]->[Option]->[C/C++Compiler]-

>[Output]->[Generate debug information].  
 

 
 
 

3.2 Enable plug-in 
 
Enable HW-RTOS accelerator Kernel Viewer Plug-in for C-SPY by selecting [Project]->[Option]->[Debug]-

>[Plugins]->[HW-RTOS]. 
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3.3 Preparation to use plug-in 
 
If debugger cache is enabled, the plug-in may fail to access memory data needed for HW-RTOS. Therefore, 

debugger cache should be disabled by checking [I-jet/JTAGjet]->[Disable Debugger Cache].  
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4. How to use Plug-in 
 
After activating the plug-in, start the C-SPY debugger by selecting [Project]->[Download and Debug]. 
If the plug-in successfully loads, the "HW-RTOS" menu will be displayed in the menu bar.  

 

 
 
 

4.1 Menu Item list 
 
Object status 
Display status monitor of each object 

Task 

Semaphore 

Event Flag 

MailBox 

Mutex 

Interrupt Service Routine 

System information 
System   Displays system information (system time) 

Other 
Help   Refer user’s guide (opens this document) 

About   Information about plug-in version 
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4.2 Task / Status of task 
 

 
 

Display task status  

Column name Description 

* Currently running task 

ID Task ID number 

Task Address Task ID start address 

Task Name Task function name 

Pri Task priority 

Status Task status 

WAITING: Waiting state, RUNNING: Execution state, READY: 
Executable state, DORMANT: Dormant state 

Waiting Cause Wait cause for task in wait state  

 SLEEP: Waiting to wake up, DELAY: Pending time,  

<object type> ID: <object ID> = Wait object 

  <object type>Display list: 

   SEM: semaphore, FLG: event flag,  

MBX: mailbox, MTX: mutex 

Wait cause for task in running state 

INTERRUPT: Interrupt processing in progress 

Left Time Time left until task wait state times out. 

 TMO_FEVR: Permanent wait 

Stack Used Stack usage size of currently executing task. 

Sizes other than the execution task are hidden. 

Stack Size Task stack area size 

Stack Pointer Current trade stack pointer 

 Sizes other than the execution task are hidden. 

Stack Base Task base stack pointer 
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4.3 Semaphore / Status of Semaphore 
 

 
 

Display the semaphore status 

Column name Description 

ID Semaphore ID number 

Count Number of resources of current semaphore 

Waiting Task ID number of the task at the head of the semaphore's queue 

Max Count Maximum number of resources of current semaphore 

Attribute Attributes of semaphores 

( TA_TFIFO || TA_TPRI ) 

 

 

4.4 Event Flag / Status of event flag 
 

 
 

Display the status of event flag 

Column name description 

ID Event flag ID number 

Pattern Current bit pattern 

Waiting Task ID number of the task at the head of the event flag's queue 

Initial Pattern Initial bit pattern 

Attribute Attributes of event flag 

 (( TA_TFIFO || TA_TPRI ) | (TA_WMUL ) | [ TA_CLR ]) 
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4.5 MailBox / Status of mailbox 
 

 
 

Display the status of mailbox 

Column name Description 

ID Mailbox ID number 

Waiting Task ID number of the task at the head of the mailbox's queue 

Attribute Attributes of Mailbox 

 ((TA_TFIFO || TA_TPRI) | (TA_MFIFO || TA_MPRI)) 

 

 

4.6 Mutex / Status of mutex 
 

 
 

Display the status of mutex 

Column name Description 

ID Mutex ID number 

Locked Task ID number of the task locking the mutex 

Waiting Task ID number of the task at the head of the mutex's queue 

Attribute Attributes of mutex 

 (TA_TFIFO || TA_TPRI) 

  



R-IN32M3, R-IN32M4, RZ/T, RZ/N Series  
HW-RTOS Accelerator Kernel Viewer Plug-in for C-SPY 

R01AN0510EJ0100  Rev.1.00  Page 11 of 12 
Jul 26, 2018  

4.7 Interrupt Service Routine / Status of interrupt service routine 
 

 
 

Display status of interrupt service routine 

Column name description 

Handler Address Start address of the interrupt service routine 

Handler Name Function name of the interrupt service routine 

IRQ Line No. The exception number corresponding to the interrupt service 

routine 

 

 

4.8 System / system information 
 

 
 

Display kernel system information 

Column name Description 

Parameter System information parameter 

Status System information status 

System Parameter Status 

System Clock Current system time 
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5. Website and Support  
Renesas Electronics Website 

http://www.renesas.com/ 
 
Inquiries 

http://www.renesas.com/contact/ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
All trademarks and registered trademarks are the property of their respective owners. 

http://www.renesas.com/
http://www.renesas.com/contact/
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General Precautions in the Handling of Microprocessing Unit and Microcontroller Unit Products 
 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. 
For detailed usage notes on the products covered by this document, refer to the relevant sections of the document as 
well as any technical updates that have been issued for the products. 
 

1.  Handling of Unused Pins 
Handle unused pins in accordance with the directions given under Handling of Unused Pins in the 
manual. 
 The input pins of CMOS products are generally in the high-impedance state. In operation with 

an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 
LSI, an associated shoot-through current flows internally, and malfunctions occur due to the 
false recognition of the pin state as an input signal become possible. Unused pins should be 
handled as described under Handling of Unused Pins in the manual. 

2.  Processing at Power-on 
The state of the product is undefined at the moment when power is supplied. 
 The states of internal circuits in the LSI are indeterminate and the states of register settings and 

pins are undefined at the moment when power is supplied. 
In a finished product where the reset signal is applied to the external reset pin, the states of 
pins are not guaranteed from the moment when power is supplied until the reset process is 
completed. 
In a similar way, the states of pins in a product that is reset by an on-chip power-on reset 
function are not guaranteed from the moment when power is supplied until the power reaches 
the level at which resetting has been specified. 

3.  Prohibition of Access to Reserved Addresses 
Access to reserved addresses is prohibited. 
 The reserved addresses are provided for the possible future expansion of functions. Do not 

access these addresses; the correct operation of LSI is not guaranteed if they are accessed. 
4.  Clock Signals 

After applying a reset, only release the reset line after the operating clock signal has become 
stable. When switching the clock signal during program execution, wait until the target clock signal 
has stabilized. 
 When the clock signal is generated with an external resonator (or from an external oscillator) 

during a reset, ensure that the reset line is only released after full stabilization of the clock 
signal. Moreover, when switching to a clock signal produced with an external resonator (or by 
an external oscillator) while program execution is in progress, wait until the target clock signal is 
stable. 

5.  Differences between Products 
Before changing from one product to another, i.e. to a product with a different part number, confirm 
that the change will not lead to problems. 
 The characteristics of Microprocessing unit or Microcontroller unit products in the same group 

but having a different part number may differ in terms of the internal memory capacity, layout 
pattern, and other factors, which can affect the ranges of electrical characteristics, such as 
characteristic values, operating margins, immunity to noise, and amount of radiated noise. 
When changing to a product with a different part number, implement a system-evaluation test 
for the given product. 

 



 

 

- Arm and Cortex® are registered trademarks of Arm Limited (or its subsidiaries) in the EU and/or  
elsewhere. All rights reserved.  

- Ethernet is a registered trademark of Fuji Xerox Co., Ltd. 
- IEEE is a registered trademark of the Institute of Electrical and Electronics Engineers Inc  
- TRON is an acronym for "The Real-time Operation system Nucleus. 
- ITRON is an acronym for "Industrial TRON.  
- μITRON is an acronym for "Micro Industrial TRON. 
- TRON, ITRON, and μITRON do not refer to any specific product or products.  
- Additionally all product names and service names in this document are a trademark or a registered  
trademark which belongs to the respective owners. 
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Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for

the incorporation or any other use of the circuits, software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by

you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, or other intellectual property rights of third parties, by or

arising from the use of Renesas Electronics products or technical information described in this document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application

examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any and all liability for any losses or damages incurred by

you or third parties arising from such alteration, modification, copying or reverse engineering.

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for each Renesas Electronics product depends on the

product’s quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic

equipment; industrial robots; etc.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are

not intended or authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause

serious property damage (space system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics disclaims any and all

liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product that is inconsistent with any Renesas Electronics data sheet, user’s manual or

other Renesas Electronics document.

6. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for Handling and Using Semiconductor Devices” in the

reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation

characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such specified

ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics, such as the occurrence of failure at a

certain rate and malfunctions under certain use conditions. Unless designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas

Electronics document, Renesas Electronics products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily injury, injury

or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as safety design for hardware and software, including but not limited to

redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult

and impractical, you are responsible for evaluating the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. You are responsible for carefully and

sufficiently investigating applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics

products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable

laws and regulations.

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws

or regulations. You shall comply with any applicable export control laws and regulations promulgated and administered by the governments of any countries asserting jurisdiction over the parties or

transactions.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or transfers the product to a third party, to notify such third

party in advance of the contents and conditions set forth in this document.

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products.

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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